Project

General

Profile

Bug #26329

Fix 11.1 Prerelease registering as a downgrade

Added by Ron Hubbard about 1 year ago. Updated about 1 year ago.

Status:
Resolved
Priority:
Expected
Assignee:
William Grzybowski
Category:
OS
Target version:
Seen in:
Severity:
New
Reason for Closing:
Reason for Blocked:
Needs QA:
No
Needs Doc:
Yes
Needs Merging:
Yes
Needs Automation:
No
Support Suite Ticket:
n/a
Hardware Configuration:
ChangeLog Required:
No

Description

The Prerelease showing in the update options is seen as a older version then 11.0 U4 rather then newer making updating impossible.

downgrade.png (11.2 KB) downgrade.png Rishabh Chauhan, 11/03/2017 12:28 PM
u4toprerel.png (79.6 KB) u4toprerel.png Rishabh Chauhan, 11/03/2017 12:28 PM
12909
12910

Associated revisions

Revision 759c8e78 (diff)
Added by William Grzybowski about 1 year ago

fix(gui): dont show update from 11-STABLE to 11.1-PRERELEASE as downgrade

Ticket: #26329

History

#1 Avatar?id=14398&size=24x24 Updated by Kris Moore about 1 year ago

  • Assignee changed from Release Council to Vaibhav Chauhan
  • Priority changed from No priority to Expected
  • Target version set to 11.1-BETA1

Vb, can you and Sean take a look at this? I saw you update from CLI this afternoon, perhaps the naming is confusing the updater?

#2 Updated by Ron Hubbard about 1 year ago

More specific it thinks your going from a nightly train to a stable one.

You're not allowed to change away from the nightly train, it is considered a downgrade.
If you have an existing boot environment that uses that train, boot into it in order to upgrade that train

#3 Updated by Bonnie Follweiler about 1 year ago

Just adding that it wont let me upgrade from FreeNAS-11.0-U4 (54848d13b) to the FreeNAS 11.1-Prerelease. I get the same error message

#4 Updated by Ron Hubbard about 1 year ago

This appears to be more then just a naming issue as manual updates also fail.

Likely they are aware of this since a simple naming issue would have be resolved quickly and this was reported 9 hours ago.

So a little more waiting is needed it seems.

#5 Updated by Dru Lavigne about 1 year ago

  • Target version changed from 11.1-BETA1 to Master - FreeNAS Nightlies

#6 Updated by Ron Hubbard about 1 year ago

Ahhh i see where this went wrong.

I was designed with the new UI rather then the old so updating through the new UI works but the old one broke tell testing goes through in the nighties.

For now people can upgrade using the new UI.

A easy oversight to make given all that's going on.

#7 Updated by Bonnie Follweiler about 1 year ago

I can upgrade through the new GUI but not through the old GUI
The machine was running on FreeNAS 11.0-u4

#8 Updated by Dru Lavigne about 1 year ago

  • Status changed from Unscreened to Investigation
  • Assignee changed from Vaibhav Chauhan to William Grzybowski

#9 Updated by William Grzybowski about 1 year ago

  • Status changed from Investigation to Needs Developer Review
  • Assignee changed from William Grzybowski to Kris Moore
  • Target version changed from Master - FreeNAS Nightlies to 11.1-RC1

#10 Avatar?id=14398&size=24x24 Updated by Kris Moore about 1 year ago

  • Status changed from Needs Developer Review to Reviewed by Developer

#11 Updated by Dru Lavigne about 1 year ago

  • Target version changed from 11.1-RC1 to Master - FreeNAS Nightlies

#12 Updated by Dru Lavigne about 1 year ago

  • Subject changed from 11.1 Prerelease registering as a downgrade to Fix 11.1 Prerelease registering as a downgrade
  • Target version changed from Master - FreeNAS Nightlies to 11.1-RC1

#13 Updated by William Grzybowski about 1 year ago

  • Status changed from Reviewed by Developer to Ready For Release
  • Assignee changed from Kris Moore to William Grzybowski

#14 Updated by Dru Lavigne about 1 year ago

  • Status changed from Ready For Release to Resolved

#15 Updated by Rishabh Chauhan about 1 year ago

12909
12910

I tried to update in the old UI from U4 to pre-release, it gave me the Downgrade error as specified in the image(downgrade)
I tried doing the same from the new UI, it worked as shown in the image(u4toprel)

#16 Updated by Bonnie Follweiler about 1 year ago

This will need to be tested in the next release after FN 11.1-rc1

#17 Updated by Bonnie Follweiler about 1 year ago

  • Target version changed from 11.1-RC1 to 11.1

#18 Updated by Bonnie Follweiler about 1 year ago

  • Status changed from Resolved to Ready For Release

#19 Updated by Dru Lavigne about 1 year ago

  • Status changed from Ready For Release to Resolved
  • Target version changed from 11.1 to 11.1-RC1

#20 Updated by Bonnie Follweiler about 1 year ago

  • Needs QA changed from Yes to No
  • QA Status deleted (Not Tested)

After discussing this with William we came to the conclusion there is no way to test this.

Also available in: Atom PDF