Project

General

Profile

Bug #26365

Ensure uniqueness by combining guest VM name with its ID number

Added by Bonnie Follweiler 12 months ago. Updated 11 months ago.

Status:
Resolved
Priority:
Nice to have
Assignee:
Marcelo Araujo
Category:
Middleware
Target version:
Seen in:
Sprint:
Severity:
New
Backlog Priority:
Reason for Closing:
Reason for Blocked:
Needs QA:
No
Needs Doc:
Yes
Needs Merging:
Yes
Needs Automation:
No
Support Suite Ticket:
n/a
Hardware Configuration:
ChangeLog Required:
No

Description

I can created an exact duplicate VM (not a clone).
Shouldn't this be blocked or at least a warning given?
Screenshot provided

Associated revisions

Revision b836d2ac (diff)
Added by Marcelo Araujo 11 months ago

fix(middlewared/vm): Make guest vm name be unique, now we combine the guest name with its id number. (#488)

Ticket: #26365

History

#1 Updated by Bonnie Follweiler 12 months ago

  • Seen in changed from Master - FreeNAS Nightlies to 11.1-BETA1

#2 Updated by Bonnie Follweiler 12 months ago

  • File deleted (Screen Shot 2017-10-26 at 4.45.39 PM.png)

#4 Updated by Dru Lavigne 11 months ago

  • Assignee changed from Kris Moore to Marcelo Araujo
  • Target version set to 11.1-U1

#5 Updated by Marcelo Araujo 11 months ago

  • Status changed from Unscreened to Screened
  • Priority changed from No priority to Nice to have

It should not be a problem have two VMs with the same name, because every entry in the database has an unique key.
However when I try to launch the vm, I always use its name without associate with the id number, and in this case, you can't launch two bhyve process with the same vm name..

I need to check how much code is necessary to change to support it prior to 11.1-U1.

Thank you!

#6 Updated by Marcelo Araujo 11 months ago

  • Status changed from Screened to Fix In Progress

#7 Updated by Marcelo Araujo 11 months ago

  • Status changed from Fix In Progress to Reviewed by Developer

#8 Updated by Dru Lavigne 11 months ago

  • Subject changed from I am able to create an exact duplicate of an already created VM - Create a warning? to Ensure uniqueness by combining guest VM name with its ID number
  • Target version changed from 11.1-U1 to 11.1-RC2

#9 Updated by Vaibhav Chauhan 11 months ago

  • Status changed from Reviewed by Developer to Ready For Release

#10 Updated by Nick Wolff 11 months ago

  • QA Status Test Fails FreeNAS added
  • QA Status deleted (Not Tested)

We can still have collisions as vm's can end in numbers. Collision are much harder to do though

1. On box with no vm's create vm called "freenas1" .
2. Create 10 more vm's with 10th called "freenas"
3. Start 1st vm
4. You will see "freenas1" and "freenas" marked as running.

#11 Updated by Dru Lavigne 11 months ago

  • Status changed from Ready For Release to Unscreened

#12 Updated by Vaibhav Chauhan 11 months ago

we will have to retest this after I roll a test image as https://github.com/freenas/freenas/pull/517 was merged to freenas/11.1-stable after test ISO was created.

#13 Updated by Dru Lavigne 11 months ago

  • Status changed from Unscreened to 47

#14 Updated by Dru Lavigne 11 months ago

  • Target version changed from 11.1-RC2 to 11.1-RC3

#15 Updated by Dru Lavigne 11 months ago

  • Status changed from 47 to Resolved

#16 Updated by Nick Wolff 11 months ago

  • Needs QA changed from Yes to No
  • QA Status Test Passes FreeNAS added
  • QA Status deleted (Test Fails FreeNAS)

All is good in rc3 test passes

Also available in: Atom PDF