Project

General

Profile

Bug #26374

Make ZSH the default root shell for new installs

Added by William Grzybowski over 1 year ago. Updated 10 months ago.

Status:
Done
Priority:
Nice to have
Assignee:
William Grzybowski
Category:
Middleware
Target version:
Seen in:
Severity:
New
Reason for Closing:
Reason for Blocked:
Needs QA:
No
Needs Doc:
No
Needs Merging:
No
Needs Automation:
No
Support Suite Ticket:
n/a
Hardware Configuration:
ChangeLog Required:
No

example.png (114 KB) example.png Dru Lavigne, 03/26/2018 11:49 AM
15687

Related issues

Related to FreeNAS - Bug #31452: Account -> Add New User -> Shell Default shell shown is csh the actual default shell is ZSHDone2018-04-06

Associated revisions

Revision 813b46a7 (diff)
Added by William Grzybowski about 1 year ago

Update migrate93

Ticket: #26374

Revision b14d2f8c (diff)
Added by William Grzybowski about 1 year ago

Update migrate93

Ticket: #26374

History

#1 Updated by William Grzybowski over 1 year ago

  • Status changed from Screened to Ready For Release

migrate93 repo 756309d1aa18e383047b13c8b1af10199e0fb8f4

#2 Updated by Dru Lavigne about 1 year ago

  • Status changed from Ready For Release to Done
  • Needs Merging changed from Yes to No

#3 Updated by Dru Lavigne about 1 year ago

15687

See attached screenshot for ssh session shell result. This is on FreeNAS-11-MASTER-201803261438.

netcli gives the same result. The webshell within the legacy UI gives bash as the result. I did not try the webshell from the new UI.

#4 Updated by William Grzybowski about 1 year ago

  • Status changed from Broken to In Progress

#5 Updated by William Grzybowski about 1 year ago

  • Status changed from In Progress to Done

#6 Updated by Dru Lavigne about 1 year ago

  • Related to Bug #31452: Account -> Add New User -> Shell Default shell shown is csh the actual default shell is ZSH added

#7 Updated by Dru Lavigne about 1 year ago

  • Needs Doc changed from Yes to No

#8 Updated by Dru Lavigne 12 months ago

  • Status changed from Done to Ready for Testing

#9 Updated by Sean Fagan 12 months ago

  • Severity set to New

This should not have been allowed to go through.

Changing the root shell is not something that should be done without the consent of the administrator. Since it is already in the build, I've filed ticket #33312 to undo it.

#11 Avatar?id=55038&size=24x24 Updated by Zackary Welch 11 months ago

  • Needs QA changed from Yes to No

I can confirm that the root shell is now ZSH (verified by $SHELL and functionality). For non root users I'm getting Bourne shell by default, and I could create a user using another shell, such as csh. I cannot confirm upgrades vs new installs, as all I have is a new install, but it seems this feature/bug has been added/fixed. I didn't look at the old UI either, but in the new UI I can confirm the root shell is now ZSH. The docs mention this change as well.

#12 Updated by Dru Lavigne 11 months ago

  • Status changed from Ready for Testing to Done

#13 Updated by Dru Lavigne 10 months ago

  • Subject changed from Make ZSH the default root shell to Make ZSH the default root shell for new installs

Also available in: Atom PDF