Project

General

Profile

Bug #26393

Properly detect disks and display in View Disks

Added by Jeff Alperin 12 months ago. Updated 11 months ago.

Status:
Resolved
Priority:
No priority
Assignee:
William Grzybowski
Category:
Middleware
Target version:
Seen in:
Sprint:
Severity:
New
Backlog Priority:
Reason for Closing:
Reason for Blocked:
Needs QA:
No
Needs Doc:
Yes
Needs Merging:
Yes
Needs Automation:
No
Support Suite Ticket:
n/a
Hardware Configuration:

Lenove TS140, 16GB memory, two internal drives mirrored, 6 external SAS/sata drives in RAIDZ2. Box has been running for years with FN, months with 11.0. Installed 11.1b yesterday.

ChangeLog Required:
No

Description

Have external SAS expander with 6 sata drives. If drives are powered before boot, FN 11.1beta will show them all in Storage > View Disks.

If drives powered up subsequent to boot, only the first of the six drives is shown. This is so even though the zpool has been imported and "camcontrol devlist" shows all the drives.

26393-1.jpg (297 KB) 26393-1.jpg Jeff Alperin, 10/29/2017 11:28 AM
26393-2.jpg (205 KB) 26393-2.jpg Jeff Alperin, 10/29/2017 11:28 AM
26393-3a.jpg (179 KB) 26393-3a.jpg Jeff Alperin, 10/29/2017 11:28 AM
26393-3b.jpg (245 KB) 26393-3b.jpg Jeff Alperin, 10/29/2017 11:28 AM
26393-3c.jpg (101 KB) 26393-3c.jpg Jeff Alperin, 10/29/2017 11:28 AM
26393-4a.jpg (124 KB) 26393-4a.jpg Jeff Alperin, 10/29/2017 11:28 AM
12833
12835
12837
12839
12840
12841

Associated revisions

Revision d28ff2cb (diff)
Added by William Grzybowski 12 months ago

fix(middlewared/device): a devd message may contain multiple entries

Ticket: #26393

Revision e74b3439 (diff)
Added by William Grzybowski 11 months ago

fix(middlewared/device): a devd message may contain multiple entries

Ticket: #26393
(cherry picked from commit d28ff2cbb91c2455bf2b613a0496cf2dd744ada8)

History

#1 Updated by Jeff Alperin 12 months ago

Also, when the external disks are powered down, the one drive still appears in Storage > Show Disks even though not showing in camcontrol devlist.

#2 Updated by Dru Lavigne 12 months ago

  • Status changed from Unscreened to 15

Jeff: please attach a debug (System -> Advanced -> Save Debug).

#3 Updated by Jeff Alperin 12 months ago

12833
12835
12837
12839
12840
12841

Hi Dru.

Hope this helps. If it is more than wanted/needed, I apologize. I'm trying to reduce your effort.

I have attached a sequence on screenshots and debug files. They are numbered 1 to 4 to relate to the following narrative:

1. Powered on external SAS box. Boot FN 11.1 beta. All disks are seen in Storage > View Disks (two of ten were cutoff in screenshot).
2. Powered off SAS box while FN 11.1 beta running. Storage > View Disks shows four drives (as expected).
3. Powered on SAS box again. Storage > View Disks shows four drives (six are missing). Camcontrol devlist sees all ten devices.
4. Imported the ts140tank volume (on the six drives). Storage > View Disks still shows only four drives.

Please note that yesterday one of the six drives showed. Today none do.

#4 Updated by Dru Lavigne 12 months ago

  • Category changed from 2 to 129
  • Status changed from 15 to Unscreened
  • Assignee changed from Release Council to Alexander Motin
  • Private changed from No to Yes

#5 Updated by Alexander Motin 12 months ago

  • Category changed from 129 to Middleware
  • Assignee changed from Alexander Motin to William Grzybowski

I haven't found anything suspicious from the OS side. The drives are detected properly. It must be something with middleware or UI.

William, could you take a look on this?

#6 Updated by William Grzybowski 12 months ago

  • Status changed from Unscreened to 15
  • Target version set to 11.1

Unfortunately the debug were not helpful to solve the issue. Also its complicated for me because I dont have hardware to try and reproduce it locally.

Would you be open to share screen using TeamViewer and plug/unplug the enclosure multiple times?

#7 Updated by Jeff Alperin 12 months ago

Yes. I am very appreciative of FreeNAS and your team. I will be pleased to help.

Shall we make an appointment for tomorrow morning (Wed, Nov. 1)? I'm on the East coast.

#8 Updated by William Grzybowski 12 months ago

Sure, tomorrow works for me, I am at GMT-2 timezone, available through all my day. Just message me when you're ready (in here or email william at ixsystems com)

#9 Updated by Jeff Alperin 12 months ago

OK. I'm GMT-4 (for another week+). So, please expect my email at 10:30 AM your time (8:30 mine) tomorrow.

#10 Updated by William Grzybowski 12 months ago

  • Status changed from 15 to Needs Developer Review
  • Assignee changed from William Grzybowski to Vladimir Vinogradenko

#11 Updated by Vladimir Vinogradenko 12 months ago

  • Status changed from Needs Developer Review to Reviewed by Developer
  • Assignee changed from Vladimir Vinogradenko to William Grzybowski

#12 Updated by William Grzybowski 11 months ago

  • Status changed from Reviewed by Developer to Ready For Release

#13 Updated by Dru Lavigne 11 months ago

  • File deleted (26393-2-debug-ts140-20171029134821.tgz)

#14 Updated by Dru Lavigne 11 months ago

  • File deleted (26393-1-debug-ts140-20171029134447.tgz)

#15 Updated by Dru Lavigne 11 months ago

  • File deleted (26393-4-debug-ts140-20171029140809.tgz)

#16 Updated by Dru Lavigne 11 months ago

  • Private changed from Yes to No

#17 Updated by Dru Lavigne 11 months ago

  • Subject changed from Storage View Disks Missing Some Disks to Properly detect disks and display in View Disks

#18 Updated by Dru Lavigne 11 months ago

  • File deleted (26393-3-debug-ts140-20171029135350.tgz)

#19 Updated by Dru Lavigne 11 months ago

  • Target version changed from 11.1 to 11.1-RC2

#20 Updated by Nick Wolff 11 months ago

Hello Jeff,

Are you able to test 11.1-rc2 to see if your drives are visible I don't believe we have box available for our qa team to test this at this time.

Thank you for your help on this.

Nick Wolff
QA Tier 2 Engineer

#21 Updated by Jeff Alperin 11 months ago

Hi Nick.

Sorry. I am out of town and neither WOL nor SSH to IPMI address would help me get the box booted.

I will test immediately upon arrival home on or about December 13.

I can report that the code William installed on my system about 28 days ago has worked properly since (through many start/restart boot export/import events).

Thanks for the wonderful system that is FreeNAS!

#22 Updated by Nick Wolff 11 months ago

  • Needs QA changed from Yes to No

Jeff,

Thanks for response. I'm going to unmark Needs QA as we don't have hardware to verify. That will allow this ticket/release to move forward. Feel free to chime in when you have a chance to test with rc2 or release if your willing for the record.

Thanks,

Nick Wolff

#23 Updated by Jeff Alperin 11 months ago

AOK Nick. I'll test and report when I can.

#24 Updated by Dru Lavigne 11 months ago

  • Target version changed from 11.1-RC2 to 11.1-RC3

#25 Updated by Jeff Alperin 11 months ago

  • Target version changed from 11.1-RC3 to 11.1-RC2

Hello again, Nick.

I got the box started remotely and am ready to update to 11.1-RC2. However, it doesn't show in the Prerelease Train (where I previously found 11.1-RC1). I tried download and installing manually, but got this:

Environment: Software Version: FreeNAS-11.1-RC1 (ff06285bd) Request Method: POST Request URL: http://localhost:2280/system/manualupdate/?X-Progress-ID=8ee21279-a3a4-423d-8867-fa1b2440e280 Traceback: File "/usr/local/lib/python3.6/subprocess.py" in check_output 336. **kwargs).stdout File "/usr/local/lib/python3.6/subprocess.py" in run 418. output=stdout, stderr=stderr) File "/usr/local/lib/python3.6/site-packages/django/core/handlers/exception.py" in inner 42. response = get_response(request) File "/usr/local/lib/python3.6/site-packages/django/core/handlers/base.py" in _legacy_get_response 249. response = self._get_response(request) File "/usr/local/lib/python3.6/site-packages/django/core/handlers/base.py" in _get_response 178. response = middleware_method(request, callback, callback_args, callback_kwargs) File "/usr/local/lib/python3.6/site-packages/django/contrib/auth/decorators.py" in _wrapped_view 23. return view_func(request, *args, **kwargs) File "/usr/local/lib/python3.6/site-packages/django/views/generic/base.py" in view 68. return self.dispatch(request, *args, **kwargs) File "/usr/local/lib/python3.6/site-packages/formtools/wizard/views.py" in dispatch 237. response = super(WizardView, self).dispatch(request, *args, **kwargs) File "/usr/local/lib/python3.6/site-packages/django/views/generic/base.py" in dispatch 88. return handler(request, *args, **kwargs) File "/usr/local/lib/python3.6/site-packages/formtools/wizard/views.py" in post 300. return self.render_done(form, **kwargs) File "/usr/local/lib/python3.6/site-packages/formtools/wizard/views.py" in render_done 357. **kwargs) Exception Type: MiddlewareError at /system/manualupdate/ Exception Value: [MiddlewareError: Failed to apply update Command '['/usr/local/bin/freenas-update', '-C', '/var/tmp/firmware', 'update']' returned non-zero exit status 1.: b'']

So, do I go for nightlies and ignore the frightening "One-Way" message?

#26 Updated by Jeff Alperin 11 months ago

If you are changing the target to RC3 then I'm not installing RC2. OK?

#27 Updated by Dru Lavigne 11 months ago

  • Target version changed from 11.1-RC2 to 11.1-RC3

#28 Updated by Nick Wolff 11 months ago

That is correct jeff. You can wait until the rc3 is in the prerelease train. Sorry for any confusion sometimes I forget to check when we get a copy to test internally versus when it's pushed to wider availability.

#29 Updated by Dru Lavigne 11 months ago

  • Status changed from Ready For Release to Resolved

#30 Updated by Jeff Alperin 11 months ago

Tried to manually install FreeNAS-11.1-RC3-manual-update.tar. Got this error:

Environment: Software Version: FreeNAS-11.1-RC1 (ff06285bd) Request Method: POST Request URL: http://localhost:2280/system/manualupdate/?X-Progress-ID=2176e645-7b55-416e-8d7c-e37432dd8b61 Traceback: File "/usr/local/lib/python3.6/subprocess.py" in check_output 336. **kwargs).stdout File "/usr/local/lib/python3.6/subprocess.py" in run 418. output=stdout, stderr=stderr) File "/usr/local/lib/python3.6/site-packages/django/core/handlers/exception.py" in inner 42. response = get_response(request) File "/usr/local/lib/python3.6/site-packages/django/core/handlers/base.py" in _legacy_get_response 249. response = self._get_response(request) File "/usr/local/lib/python3.6/site-packages/django/core/handlers/base.py" in _get_response 178. response = middleware_method(request, callback, callback_args, callback_kwargs) File "/usr/local/lib/python3.6/site-packages/django/contrib/auth/decorators.py" in _wrapped_view 23. return view_func(request, *args, **kwargs) File "/usr/local/lib/python3.6/site-packages/django/views/generic/base.py" in view 68. return self.dispatch(request, *args, **kwargs) File "/usr/local/lib/python3.6/site-packages/formtools/wizard/views.py" in dispatch 237. response = super(WizardView, self).dispatch(request, *args, **kwargs) File "/usr/local/lib/python3.6/site-packages/django/views/generic/base.py" in dispatch 88. return handler(request, *args, **kwargs) File "/usr/local/lib/python3.6/site-packages/formtools/wizard/views.py" in post 300. return self.render_done(form, **kwargs) File "/usr/local/lib/python3.6/site-packages/formtools/wizard/views.py" in render_done 357. **kwargs) Exception Type: MiddlewareError at /system/manualupdate/ Exception Value: [MiddlewareError: Failed to apply update Command '['/usr/local/bin/freenas-update', '-C', '/var/tmp/firmware', 'update']' returned non-zero exit status 1.: b'']

No more manual attempts. Will wait for RC3 in prerelease train (as I was instrucuted).

#31 Updated by Jeff Alperin 11 months ago

Installed FreeNAS-11.1-RC3 from pre-release train. Tested multiple permutations of boot with/without external disks powered and of export/import of volume on external sas/sata device. Storage > View Disks works correctly.

Thanks again for FreeNAS!

Also available in: Atom PDF