Project

General

Profile

Bug #26470

Allow interfaces to be selected from netcli

Added by Joe Maloney about 1 year ago. Updated 12 months ago.

Status:
Resolved
Priority:
Blocks Until Resolved
Assignee:
Vladimir Vinogradenko
Category:
Middleware
Target version:
Seen in:
Severity:
New
Reason for Closing:
Reason for Blocked:
Needs QA:
No
Needs Doc:
Yes
Needs Merging:
Yes
Needs Automation:
No
Support Suite Ticket:
n/a
Hardware Configuration:
ChangeLog Required:
No

Description

The interfaces cannot be selected as shown int he screenshot with FreeNAS 11.1-RC1.

IMAGE 2017-11-01 16_26_40.jpg (142 KB) IMAGE 2017-11-01 16_26_40.jpg Joe Maloney, 11/01/2017 01:26 PM
2017-12-06 10.30.29.jpg (142 KB) 2017-12-06 10.30.29.jpg Selecting an interface for lagg now exits, and lagg is never created. Joe Maloney, 12/06/2017 07:30 AM
12893
13310

Associated revisions

Revision f927912c (diff)
Added by Vladimir Vinogradenko about 1 year ago

Remove broken "remove" method from NICChoices and IPChoices

Ticket: #26470

Revision 0f5ceaeb (diff)
Added by Vladimir Vinogradenko about 1 year ago

Remove broken "remove" method from NICChoices and IPChoices

Ticket: #26470

Revision ed4beb6b (diff)
Added by Vladimir Vinogradenko about 1 year ago

fix(netcli): Fix get_lagg_nics

Ticket: #26470

Revision bf78e000 (diff)
Added by Vladimir Vinogradenko about 1 year ago

fix(netcli): Show "You don't have enough free interfaces to proceed" if there are no interfaces for lagg

Ticket: #26470

Revision 7a9398bf (diff)
Added by Vladimir Vinogradenko about 1 year ago

fix(netcli): Show "All interfaces are already allocated to LAGG or VLAN, cannot proceed."

Ticket: #26470

Revision e0a891ac (diff)
Added by Vladimir Vinogradenko about 1 year ago

fix(netcli): Fix get_lagg_nics

Ticket: #26470

Revision cfe9857f (diff)
Added by Vladimir Vinogradenko about 1 year ago

fix(netcli): Show "All interfaces are already allocated to LAGG or VLAN, cannot proceed."

Ticket: #26470

History

#1 Updated by Dru Lavigne about 1 year ago

  • Status changed from Untriaged to Unscreened
  • Assignee changed from Release Council to William Grzybowski

William: please load balance.

#2 Updated by William Grzybowski about 1 year ago

  • Assignee changed from William Grzybowski to Vladimir Vinogradenko
  • Target version set to 11.1

#3 Updated by Vladimir Vinogradenko about 1 year ago

  • Status changed from Unscreened to Screened

#4 Updated by Vladimir Vinogradenko about 1 year ago

  • Status changed from Screened to Needs Developer Review
  • Assignee changed from Vladimir Vinogradenko to William Grzybowski

#5 Updated by William Grzybowski about 1 year ago

  • Status changed from Needs Developer Review to Reviewed by Developer
  • Assignee changed from William Grzybowski to Vladimir Vinogradenko

#6 Updated by Dru Lavigne about 1 year ago

  • Subject changed from Creating a lagg with netcli is broken to Allow interfaces to be selected from netcli

#7 Updated by Vladimir Vinogradenko about 1 year ago

  • Status changed from Reviewed by Developer to Ready For Release

#8 Updated by Dru Lavigne about 1 year ago

  • Target version changed from 11.1 to 11.1-RC2

#9 Updated by Dru Lavigne about 1 year ago

  • Target version changed from 11.1-RC2 to 11.1-RC3

#10 Updated by Dru Lavigne about 1 year ago

  • Status changed from Ready For Release to Resolved

#11 Updated by Joe Maloney about 1 year ago

  • Status changed from Resolved to Unscreened
  • QA Status Test Fails FreeNAS added
  • QA Status deleted (Not Tested)

This is still not fixed. The problem is worse now that it immediately exits when trying to select an interface. Will attach credentials for ipmi for reproduction shortly.

#12 Updated by Joe Maloney about 1 year ago

13310

To reproduce:

Press option 1 to create a link aggregation.
Press option 2 to use lacp
Press option 1 to select igb0

You will see FreeBSD/amd64 as if the script exited, and Console setup will reappear as shown in the screenshot.

After selecting option 2 to configure link aggregation you can see that the link aggregation was never created at all.

#13 Updated by Joe Maloney about 1 year ago

For ipmi to see the issue:

http://10.231.3.2 admin admin

#14 Updated by Vladimir Vinogradenko about 1 year ago

  • Status changed from Unscreened to 15

Joe, I can't connect to this URL (I am 172.20.20.7)

#15 Updated by Joe Maloney about 1 year ago

Vladimir the IPMI issue should be fixed now. Try http://10.231.3.9 admin admin.

#16 Updated by Joe Maloney about 1 year ago

  • Priority changed from No priority to Blocks Until Resolved

#17 Updated by Dru Lavigne about 1 year ago

  • Target version changed from 11.1-RC3 to 11.1

#18 Updated by Vladimir Vinogradenko about 1 year ago

  • Status changed from 15 to Needs Developer Review
  • Assignee changed from Vladimir Vinogradenko to William Grzybowski

#19 Updated by William Grzybowski about 1 year ago

  • Status changed from Needs Developer Review to Reviewed by Developer
  • Assignee changed from William Grzybowski to Vladimir Vinogradenko

#20 Updated by Dru Lavigne about 1 year ago

  • Status changed from Reviewed by Developer to 47

#21 Updated by Dru Lavigne about 1 year ago

  • Status changed from 47 to 42

#22 Updated by Joe Maloney about 1 year ago

  • Status changed from 42 to Ready For Release
  • Needs QA changed from Yes to No
  • QA Status Test Passes FreeNAS added
  • QA Status deleted (Test Fails FreeNAS)

This works now in INTERNAL4-11.1.

#23 Updated by Dru Lavigne 12 months ago

  • Status changed from Ready For Release to Resolved

Also available in: Atom PDF