Project

General

Profile

Bug #26481

Avatar?id=14398&size=50x50

Saving System-Advanced settings shouldn't validate serial choice if not enabled

Added by Kris Moore almost 4 years ago. Updated over 3 years ago.

Status:
Done
Priority:
Expected
Assignee:
-
Category:
GUI (new)
Severity:
Reason for Closing:
Reason for Blocked:
Needs QA:
Yes
Needs Doc:
Yes
Needs Merging:
No
Needs Automation:
No
Support Suite Ticket:
n/a
Hardware Configuration:
ChangeLog Required:
No

Description

When I go to System -> Advanced and try to save, I shouldn't be getting errors about "Invalid Serial port" choice, when the serial option isn't even selected. Better yet, we should grey-out or disable the serial speed and serial port options if "Enable Serial" isn't checked.

FN-SerialBug.png (287 KB) FN-SerialBug.png Kris Moore, 11/02/2017 07:34 AM
Screen Shot 2018-04-19 at 11.19.56 AM.png (102 KB) Screen Shot 2018-04-19 at 11.19.56 AM.png Bonnie Follweiler, 04/19/2018 08:23 AM
12897
16839

Associated revisions

Revision 2cc6685e (diff)
Added by Erin Clark over 3 years ago

Adjust entity-form to work with the new system-advanced changes Ticket: #26481

Revision 7116194e (diff)
Added by Erin Clark over 3 years ago

Update system advanced to use the websocket calls Also hide serial fields when serial console is disabled Ticket: #26481

History

#1 Updated by Nesma Shah almost 4 years ago

  • Status changed from Unscreened to Screened

#2 Updated by Nesma Shah almost 4 years ago

What should be the valid choices for the serial port?

Also in my machine the drop down list for serial port shows empty...

#3 Updated by Dru Lavigne almost 4 years ago

  • Status changed from Screened to 15

#4 Avatar?id=14398&size=24x24 Updated by Kris Moore almost 4 years ago

  • Status changed from 15 to Screened

In the websocket calls you should be able to do the following to see what Serial ports are available:

device.get_info SERIAL

If there are NONE then perhaps we disable the serial option entirely as well.

#5 Updated by Nesma Shah almost 4 years ago

  • Status changed from Screened to Fix In Progress

#6 Updated by Nesma Shah almost 4 years ago

what should I do in order to receive those serial ports.. ?

#7 Updated by Dru Lavigne almost 4 years ago

  • Status changed from Fix In Progress to 15
  • Assignee changed from Nesma Shah to Kris Moore

#8 Avatar?id=14398&size=24x24 Updated by Kris Moore almost 4 years ago

  • Status changed from 15 to Screened
  • Assignee changed from Kris Moore to Nesma Shah

Discussed offline. She will need to enable a serial port on the VM running freenas, otherwise it will indeed return nothing ;)

#9 Updated by Nesma Shah almost 4 years ago

  • Status changed from Screened to Fix In Progress

#10 Updated by Nesma Shah almost 4 years ago

  • Status changed from Fix In Progress to Needs Developer Review
  • Assignee changed from Nesma Shah to Lola Yang

#12 Updated by Nesma Shah almost 4 years ago

  • Assignee changed from Lola Yang to Daisuke Imai

#13 Updated by Vaibhav Chauhan almost 4 years ago

  • Status changed from Needs Developer Review to Reviewed by Developer
  • Assignee changed from Daisuke Imai to Xin Tan

#14 Updated by Vaibhav Chauhan almost 4 years ago

  • Status changed from Reviewed by Developer to Resolved
  • Assignee changed from Xin Tan to Nesma Shah
  • Target version changed from 11.2-BETA1 to 11.1

#15 Updated by Dru Lavigne almost 4 years ago

  • Target version changed from 11.1 to Master - FreeNAS Nightlies

#16 Updated by Bonnie Follweiler over 3 years ago

16839

This is happening after I updated to the latest FreeNAS Nightly - FreeNAS-11-MASTER-201804190410
I tried to turn on "show Console Message" and when I clciked save I got the error message "Select a valid choice. 0x2f8 is not one of the available choices. "
Enable Serial Console is not checked. The Serial Speed is non-enterable.
(screen shot provided

#17 Updated by Bonnie Follweiler over 3 years ago

  • Status changed from In Progress to Unscreened

#18 Updated by Anonymous over 3 years ago

This isn't reproducing on either of my boxen, but I also do not have a serial port to select. Could I possibly borrow your box to see this in action?

#20 Updated by Anonymous over 3 years ago

  • Assignee changed from Anonymous to William Grzybowski

This error appears to be coming from the middleware, the payload I am seeing is:

adv_advancedmode: false
​adv_autotune: false
​adv_consolemenu: true
​adv_consolemsg: false
​adv_consolescreensaver: false
​adv_cpu_in_percentage: false
​adv_debugkernel: false
​adv_fqdn_syslog: false
​adv_graphite: ""
​adv_motd: "Welcome to FreeNAS"
​adv_periodic_notifyuser: "root"
​adv_powerdaemon: false
​adv_serialconsole: false
​adv_swapondrive: 2
​adv_traceback: true
​adv_uploadcrash: true

since serialconsole is false the other fields are disabled and thus not even populated with a value, can this be fixed on the middleware side or is there something else we need to do on the UI side, William?

#21 Updated by William Grzybowski over 3 years ago

  • Assignee changed from William Grzybowski to Anonymous

The REST 1.0 API cannot just not received the serialport attribute, it needs to be set regardless of serial enable or not.

You can

1) Switch to use websocket system.advanced.config and system.advanced.update

or

2) Always provide adv_serialport

#22 Updated by Anonymous over 3 years ago

  • Status changed from Unscreened to In Progress
  • Assignee changed from Anonymous to Lola Yang

#23 Updated by Lola Yang over 3 years ago

  • Status changed from In Progress to Done
  • Assignee changed from Lola Yang to Anonymous

#24 Updated by Dru Lavigne over 3 years ago

  • Target version changed from 11.2-BETA1 to Master - FreeNAS Nightlies
  • Needs Merging changed from Yes to No

Also available in: Atom PDF