Project

General

Profile

Bug #26545

Blacklist mrsas(4) as it is currently unsupported by FreeBSD smartd

Added by Gagandeep Arora over 1 year ago. Updated 10 months ago.

Status:
Done
Priority:
No priority
Assignee:
Vladimir Vinogradenko
Category:
OS
Target version:
Seen in:
Severity:
New
Reason for Closing:
Reason for Blocked:
Needs QA:
No
Needs Doc:
No
Needs Merging:
No
Needs Automation:
No
Support Suite Ticket:
n/a
Hardware Configuration:

Dell Poweredge R630 with PERC H730 controller.

ChangeLog Required:
Yes

Description

Build: FreeNAS-11.0-U4 (54848d13b)
Machine: Dell R630 with PERC H730 mini controller.

The smartd service is failing with the following messages:
Nov 8 10:04:54 freenas2 smartd31504: Unable to register SCSI device /dev/da0 at line 5 of file /usr/local/etc/smartd.conf
Nov 8 10:04:54 freenas2 smartd31504: Unable to register device /dev/da0 (no Directive -d removable). Exiting.

I can monitor the disks on a similar server running centos-7.2 with the 'smartctl -d megaraid,0 -a /dev/sda'. However, the -d megaraid option does not work on freenas.

smartd.conf:
root@freenas2:/ # cat /usr/local/etc/smartd.conf ################################################
  1. smartd.conf generated by /etc/ix.rc.d/ix-smartd ################################################
    /dev/nvd0 -a -n never -W 0,0,0 -m root -M exec /usr/local/www/freenasUI/tools/smart_alert.py
    /dev/da0 -a -n never -W 0,0,0 -m root -M exec /usr/local/www/freenasUI/tools/smart_alert.py
    /dev/da1 -a -n never -W 0,0,0 -m root -M exec /usr/local/www/freenasUI/tools/smart_alert.py
    /dev/da2 -a -n never -W 0,0,0 -m root -M exec /usr/local/www/freenasUI/tools/smart_alert.py
    /dev/da3 -a -n never -W 0,0,0 -m root -M exec /usr/local/www/freenasUI/tools/smart_alert.py
    /dev/da4 -a -n never -W 0,0,0 -m root -M exec /usr/local/www/freenasUI/tools/smart_alert.py
    /dev/da5 -a -n never -W 0,0,0 -m root -M exec /usr/local/www/freenasUI/tools/smart_alert.py
    /dev/da6 -a -n never -W 0,0,0 -m root -M exec /usr/local/www/freenasUI/tools/smart_alert.py
    /dev/da7 -a -n never -W 0,0,0 -m root -M exec /usr/local/www/freenasUI/tools/smart_alert.py

Related issues

Is duplicate of FreeNAS - Bug #26646: Cannot start smart serviceClosed: Duplicate2017-11-14

Associated revisions

Revision 9819f7ff (diff)
Added by Vladimir Vinogradenko over 1 year ago

fix(smart): blacklist mrsas as it is not currently supported by FreeBSD smartd

TIcket: #26545

Revision 0cdb9ecb (diff)
Added by Vladimir Vinogradenko about 1 year ago

fix(smart): blacklist mrsas as it is not currently supported by FreeBSD smartd

TIcket: #26545
(cherry picked from commit 9819f7ff339d3fbf454508212281f9b7a5bc7d1b)

Revision c3b42888 (diff)
Added by Vladimir Vinogradenko about 1 year ago

fix(smart): blacklist mrsas as it is not currently supported by FreeBSD smartd

TIcket: #26545
(cherry picked from commit 9819f7ff339d3fbf454508212281f9b7a5bc7d1b)

History

#1 Updated by Bonnie Follweiler over 1 year ago

Would you please attach a debug (System -> Advanced -> Save Debug)?

#2 Updated by Bonnie Follweiler over 1 year ago

  • Status changed from Unscreened to 15

#3 Updated by Gagandeep Arora over 1 year ago

  • File debug-freenas2-20171108123158.tgz added

Please see the attached debug as requested.

#4 Updated by Dru Lavigne over 1 year ago

  • Private changed from No to Yes

#5 Updated by Dru Lavigne over 1 year ago

  • Assignee changed from Release Council to William Grzybowski

William: please load balance.

#6 Updated by William Grzybowski over 1 year ago

  • Status changed from 15 to Unscreened
  • Assignee changed from William Grzybowski to Vladimir Vinogradenko

Vladimir, could you take a look at this, please?

We have logic on ix-smartd to map disks on controllers to smartd params. We probably need to add an exception for his card.

#7 Updated by Vladimir Vinogradenko over 1 year ago

  • Status changed from Unscreened to Screened

#8 Updated by Vladimir Vinogradenko over 1 year ago

Gagandeep Arora, please attach the output of the following command:

# camcontrol devlist -v

Our debug has only camcontrol devlist which does not contain all the necessary information.

I guess we'll see something like

scbus0 on mrsas0 bus 0:

And then we'll be able to exclude mrsas devices from smartd as this is not currently supported on FreeBSD.

#9 Updated by Vladimir Vinogradenko over 1 year ago

  • Status changed from Screened to 15

#10 Updated by Gagandeep Arora over 1 year ago

Hi Viladmir,

Please see below the output of camcontrol devlist -v:

root@freenas2:~ # camcontrol devlist -v
scbus0 on mrsas0 bus 0:
<DELL PERC H730 Mini 4.25> at scbus0 target 0 lun 0 (pass0,da0)
<DELL PERC H730 Mini 4.25> at scbus0 target 1 lun 0 (pass1,da1)
<DELL PERC H730 Mini 4.25> at scbus0 target 2 lun 0 (pass2,da2)
<DELL PERC H730 Mini 4.25> at scbus0 target 3 lun 0 (pass3,da3)
<DELL PERC H730 Mini 4.25> at scbus0 target 4 lun 0 (pass4,da4)
<DELL PERC H730 Mini 4.25> at scbus0 target 5 lun 0 (pass5,da5)
<DELL PERC H730 Mini 4.25> at scbus0 target 6 lun 0 (pass6,da6)
<DELL PERC H730 Mini 4.25> at scbus0 target 7 lun 0 (pass7,da7)
<> at scbus0 target -1 lun ffffffff ()
scbus1 on mrsas0 bus 1:
<> at scbus1 target -1 lun ffffffff ()
scbus2 on ahcich0 bus 0:
<> at scbus2 target -1 lun ffffffff ()
scbus3 on ahcich1 bus 0:
<> at scbus3 target -1 lun ffffffff ()
scbus4 on ahcich2 bus 0:
<> at scbus4 target -1 lun ffffffff ()
scbus5 on ahcich3 bus 0:
<> at scbus5 target -1 lun ffffffff ()
scbus6 on ahcich4 bus 0:
<> at scbus6 target -1 lun ffffffff ()
scbus7 on ahcich5 bus 0:
<> at scbus7 target -1 lun ffffffff ()
scbus8 on ahcich6 bus 0:
<> at scbus8 target -1 lun ffffffff ()
scbus9 on ahcich7 bus 0:
<> at scbus9 target -1 lun ffffffff ()
scbus10 on ahcich8 bus 0:
<> at scbus10 target -1 lun ffffffff ()
scbus11 on ahcich9 bus 0:
<HL-DT-ST DVD+-RW GU90N A3C0> at scbus11 target 0 lun 0 (pass8,cd0)
<> at scbus11 target -1 lun ffffffff ()
scbus12 on camsim0 bus 0:
<> at scbus12 target -1 lun ffffffff ()
scbus13 on umass-sim0 bus 0:
<SanDisk Cruzer Edge 1.00> at scbus13 target 0 lun 0 (pass9,da8)
scbus14 on umass-sim1 bus 1:
<SanDisk Cruzer Edge 1.00> at scbus14 target 0 lun 0 (pass10,da9)
scbus-1 on xpt0 bus 0:
<> at scbus-1 target -1 lun ffffffff (xpt0)

#11 Updated by Vladimir Vinogradenko over 1 year ago

  • Status changed from 15 to Needs Developer Review
  • Assignee changed from Vladimir Vinogradenko to William Grzybowski

#12 Updated by William Grzybowski over 1 year ago

  • Status changed from Needs Developer Review to Reviewed by Developer
  • Assignee changed from William Grzybowski to Vladimir Vinogradenko

#13 Updated by Vladimir Vinogradenko over 1 year ago

  • Status changed from Reviewed by Developer to Ready For Release
  • Target version set to 11.2-BETA1
  • Seen in changed from 11.0-U4 to N/A
  • ChangeLog Required changed from No to Yes

#14 Updated by Dru Lavigne over 1 year ago

  • Is duplicate of Bug #26646: Cannot start smart service added

#15 Updated by Dru Lavigne over 1 year ago

  • File deleted (debug-freenas2-20171108123158.tgz)

#16 Updated by Dru Lavigne over 1 year ago

  • Private changed from Yes to No

#17 Updated by Dru Lavigne about 1 year ago

  • Subject changed from Unable to start smartd service to Blacklist mrsas(4) as it is currently unsupported by FreeBSD smartd
  • Needs Doc changed from Yes to No
  • Needs Merging changed from Yes to No

#18 Updated by Dru Lavigne about 1 year ago

  • Status changed from Ready For Release to Done

#19 Updated by Dru Lavigne 12 months ago

  • Status changed from Done to Ready for Testing

#20 Updated by Eric Turgeon 10 months ago

  • Status changed from Ready for Testing to Passed Testing
  • Severity set to New
  • Needs QA changed from Yes to No

Looks to work fine on FreeNAS-11.2-MASTER-201806191350 (4d34a765b)

#21 Updated by Dru Lavigne 10 months ago

  • Status changed from Passed Testing to Done

Also available in: Atom PDF