Project

General

Profile

Bug #26575

Sudden reboot

Added by Tino Zidore almost 3 years ago. Updated almost 3 years ago.

Status:
Closed: Cannot reproduce
Priority:
No priority
Assignee:
Alexander Motin
Category:
OS
Target version:
Seen in:
Severity:
New
Reason for Closing:
Reason for Blocked:
Needs QA:
Yes
Needs Doc:
Yes
Needs Merging:
Yes
Needs Automation:
No
Support Suite Ticket:
n/a
Hardware Configuration:
ChangeLog Required:
No

Description

Hi

I have 2 Freenas Servers that has run fine for a long time. I am on holiday right now, and suddenly the servers has restarted itself 3 times within the last 28 hours without me being at work and noone else knows how to manage the servers.

I have not been able to find a reason in the logs, it seems like they shutdown at the same time and gentle, not forced.
Attached are debug logs for both servers.

last reboot gives this:
boot time Thu Nov 9 16:44
shutdown time Thu Nov 9 16:37
boot time Wed Nov 8 13:34
shutdown time Wed Nov 8 12:54
boot time Wed Nov 8 11:43
shutdown time Wed Nov 8 11:37
boot time Wed Nov 8 11:02
shutdown time Wed Nov 8 10:55

History

#1 Updated by Tino Zidore almost 3 years ago

  • File debug-raw-20171109172159.txz added

#2 Updated by Tino Zidore almost 3 years ago

  • File debug-vfx-20171109171934.tgz added

#3 Updated by Tino Zidore almost 3 years ago

Are you guys able to see why it reboots?

#4 Updated by Dru Lavigne almost 3 years ago

  • Status changed from Unscreened to 15

That sounds like a heat issue, if 2 servers all of a sudden start rebooting. Can someone check the temperature of the server room?

#5 Updated by Tino Zidore almost 3 years ago

It is at a max of 50 degrees celsius on the CPU, so I don't think that is the reason.
And it hasn't been mentioned as a reason when I talked to the employees on location.
they use the serverroom every time they print A4, so they would know and tell me if it was warmer than normal.

#6 Updated by Tino Zidore almost 3 years ago

Even though it was warmth it is still weird they reboot within the same minute.

#7 Updated by Dru Lavigne almost 3 years ago

  • Status changed from 15 to Unscreened
  • Assignee changed from Release Council to William Grzybowski

William: any culprits stick out in the logs to you?

#8 Updated by William Grzybowski almost 3 years ago

  • Assignee changed from William Grzybowski to Alexander Motin

Alexandeer, do you think we can do anything here? I dont see panics registered (perhaps thats broken on 11.0)?

#9 Updated by Alexander Motin almost 3 years ago

  • Status changed from Unscreened to 15
  • Seen in changed from Unspecified to 11.0-U4

There are no panics because servers indeed seem to shutdown orderly. At least on one of servers I see APC UPS connected via USB, so my only guess is that shutdown may be caused by some power fluctuation, that pushed UPS to battery, and triggered servers shutdown.

Tino, do you have the UPS service enabled on those servers? I don't see any respective logs there, but I am not sure whether they should be.

#10 Updated by Tino Zidore almost 3 years ago

Hi

Ups hasn't been turned on but it haven't rebooted since I pulled out the cables.
It was only one of the freenas servers that were connected to the UPS.

#11 Updated by Alexander Motin almost 3 years ago

  • Status changed from 15 to Closed: Cannot reproduce

I don't have other ideas. If you have more observations, let us know.

#12 Updated by Dru Lavigne almost 3 years ago

  • File deleted (debug-raw-20171109172159.txz)

#13 Updated by Dru Lavigne almost 3 years ago

  • File deleted (debug-vfx-20171109171934.tgz)

#14 Updated by Dru Lavigne almost 3 years ago

  • Target version set to N/A
  • Private changed from Yes to No

#15 Updated by Tino Zidore almost 3 years ago

Hi

I found the reason for reboots, and believe me you wouldn't have thought of this:-)

While setting up the 2 freenas servers I have attached them to KVM switch.

When a colleague was entering a windows server connected to the same KVM and pushed Ctrl+Alt+Delete to log in then the servers rebooted.
So I think the KVM sends out the command to all channels and therefore reboots the freenas servers.
Is that a possible explanation?
Is it possible to execute Ctrl+Alt+Delete without being logged in as root?

I have now unplug the USB cables connected to the KVM switch and it hasn't happened since then.

#16 Updated by Alexander Motin almost 3 years ago

Tino Zidore wrote:

When a colleague was entering a windows server connected to the same KVM and pushed Ctrl+Alt+Delete to log in then the servers rebooted.
So I think the KVM sends out the command to all channels and therefore reboots the freenas servers.
Is that a possible explanation?

That is not impossible, but such KVM would be odd and not very useful.

Is it possible to execute Ctrl+Alt+Delete without being logged in as root?

Yes, by default reboot does not require login. It usually makes no sense to limit it, since somebody having physical access to the server can always press the reset or power button, or pull the plug.

I have now unplug the USB cables connected to the KVM switch and it hasn't happened since then.

OK.

Also available in: Atom PDF