Project

General

Profile

Bug #26600

Clicking on the smartctl(8) link in the Guide produces a blank page in the Documents window

Added by Bonnie Follweiler almost 4 years ago. Updated over 3 years ago.

Status:
Done
Priority:
Expected
Assignee:
Timothy Moore II
Category:
GUI (new)
Seen in:
Severity:
New
Reason for Closing:
Reason for Blocked:
Dependent on a related task to be completed
Needs QA:
No
Needs Doc:
Yes
Needs Merging:
Yes
Needs Automation:
No
Support Suite Ticket:
n/a
Hardware Configuration:
ChangeLog Required:
No

Description

Clicking on the link in the Guide, Tasks ->S.M.A.R.T. Tests ->Table 6.5.1 link for smartctl(8), produces a blank page in the Documents window (screenshot provided)

History

#1 Updated by Bonnie Follweiler almost 4 years ago

I was using Firefox 56.0.2

#2 Updated by Dru Lavigne almost 4 years ago

  • Category changed from Documentation to 2
  • Assignee changed from Dru Lavigne to Vaibhav Chauhan

As per discussion with Bonnie, the link works fine in the HTML. For some reason, the UI is not opening a tab for external links. Not sure if that is a firefox issue or a UI issue.

#3 Updated by Dru Lavigne almost 4 years ago

  • Priority changed from No priority to Expected
  • Target version set to 11.1

#4 Avatar?id=14398&size=24x24 Updated by Kris Moore almost 4 years ago

  • Target version changed from 11.1 to 11.1-U1

Is this still reproducible? How about with another browser?

#5 Updated by Eric Loewenthal almost 4 years ago

Happens to me in Firefox 57.0, with 11.0-U4. Edge is too broken to even be able to use the UI to reach the manual, due to dojo brokenness due to be fixed in 11.1.

#6 Updated by Dru Lavigne almost 4 years ago

  • Assignee changed from Vaibhav Chauhan to Anonymous

#7 Updated by Anonymous almost 4 years ago

  • Assignee changed from Anonymous to William Grzybowski

I don't really know much about this piece of UI, perhaps William would know who better to give this to?

#8 Updated by William Grzybowski almost 4 years ago

  • Assignee changed from William Grzybowski to Warren Block

External links need to open in a new tab. This isnt something that can be done from freenas UI since thats just an iframe.

The <a> tag needs a target="_blank" in HTML.

#9 Updated by Dru Lavigne almost 4 years ago

  • Status changed from Unscreened to Investigation

#10 Updated by Warren Block almost 4 years ago

These links are generated by the doc toolchain (Sphinx) and that has not changed in years. When did they stop working in the old GUI?

#11 Updated by William Grzybowski almost 4 years ago

Because the external URL can set headers to prevent it opening in HTML frame:

Refused to display 'https://www.smartmontools.org/browser/trunk/smartmontools/smartctl.8.in' in a frame because it set 'X-Frame-Options' to 'sameorigin'.

#12 Updated by Dru Lavigne almost 4 years ago

  • Target version changed from 11.1-U1 to 11.2-BETA1

#13 Updated by Dru Lavigne over 3 years ago

  • Status changed from Investigation to In Progress
  • Assignee changed from Warren Block to Timothy Moore II

Tim: please update me tomorrow on where you are in your investigation.

#14 Updated by Timothy Moore II over 3 years ago

  • Status changed from In Progress to Blocked
  • Reason for Blocked set to Need additional information

Investigation shows what was said above is correct - there is an issue with specific websites blocking the use of the embedded window to open the external links. I experimented with about 20 different external links and discovered that while the vast majority open properly in the embedded window, a few did not. However, right clicking the non-functional links and choosing to "open in a new tab" resulted in proper functionality. I'm not sure as to the next step to take, maybe we need to review each external link and find a way to force the non-functional ones to open in a new tab, as William suggested
?

#15 Updated by Dru Lavigne over 3 years ago

  • Target version changed from 11.2-BETA1 to 11.2-RC2
  • Reason for Blocked changed from Need additional information to Dependent on a related task to be completed

Let's see if the updated version of Sphinx resolves it.

#16 Updated by Timothy Moore II over 3 years ago

I'm working with Warren on some unrelated testing (latest FN-11-Nightly version) of the embedded Guide and it appears this issue may be resolved. External links seem to be properly opening in a new browser tab outside of the embedded guide window (old and new UI). I will continue to test to confirm this.

#17 Updated by Bonnie Follweiler over 3 years ago

  • Needs QA changed from Yes to No
  • QA Status Test Passes FreeNAS added
  • QA Status deleted (Not Tested)

It is working in FreeNAS-11-MASTER-201804300407 so I'm going to mark it FreeNAS passes

#18 Updated by Dru Lavigne over 3 years ago

  • Status changed from Blocked to Passed Testing
  • Target version changed from 11.2-RC2 to Master - FreeNAS Nightlies

#19 Updated by Dru Lavigne over 3 years ago

  • Status changed from Passed Testing to Done
  • Severity set to New

Also available in: Atom PDF