Project

General

Profile

Bug #26616

Bug #26704: Removing CD-ROM breaks UEFI boot

Cannot install Live CD turnkey-mediawiki-14.2-jessie-amd64.iso in VM

Added by Jean Aumont over 1 year ago. Updated about 1 year ago.

Status:
Closed
Priority:
No priority
Assignee:
Marcelo Araujo
Category:
OS
Target version:
Seen in:
Severity:
Low
Reason for Closing:
Duplicate Issue
Reason for Blocked:
Needs QA:
Yes
Needs Doc:
No
Needs Merging:
No
Needs Automation:
No
Support Suite Ticket:
n/a
Hardware Configuration:
ChangeLog Required:
No

Description

Hi,
I am running FreeNas 11.1-PRERELEASE.

I downloaded the iso turnkey-mediawiki-14.2-jessie-amd64.iso from
https://www.turnkeylinux.org/download?file=turnkey-mediawiki-14.2-jessie-amd64.iso
and tried to install it in a VM.

I added a CDROM device to the new VM attaching the iso to the cdrom.
When I tried to boot, I see the UEFI Interactive Shell v2.1, a few message and the prompt "Shell>"

After reading on the problem (https://forums.freenas.org/index.php?threads/how-to-how-to-boot-linux-vms-using-uefi.54039/)
It seems that the ISO is missing something like the grubx64.efi file .... not sure of that...

It is mentioned, "Just type exit at the shell prompt, and in the EFI menu system navigate to "Boot Maintenance Manager" and then select "Boot from file" to locate and select your grubx64.efi file."

After selecting the "Boot from file" a "File Explorer", the page opens, but there is nothing to select, there is nothing in the page ....

I also tried to boot using UEFI-CSM method and nothing appears in the console.

The iso image is valid since I installed it under "virtualbox" without any problem.
Thanks,

Jean Aumont


Related issues

Is duplicate of FreeNAS - Bug #26708: Fix UEFI boot menu to allow Linux kernels 4.15 and higher to boot properly in bhyve VMsDone

History

#1 Updated by Dru Lavigne over 1 year ago

  • Assignee changed from Release Council to Marcelo Araujo

#2 Updated by Dru Lavigne over 1 year ago

  • Target version set to 11.2-BETA1

#3 Updated by Marcelo Araujo over 1 year ago

  • Status changed from Unscreened to Screened
  • Parent task set to #26704

Hi,

We are aware of this issue, however it needs to be fixed in bhyve first.
I will set this ticket to 11.2-RELEASE till I can get a proper resolution for this problem.

Thanks.

#4 Avatar?id=14398&size=24x24 Updated by Kris Moore over 1 year ago

  • Target version changed from 11.2-BETA1 to 11.3

#5 Avatar?id=14398&size=24x24 Updated by Kris Moore over 1 year ago

  • Status changed from Screened to Not Started

#6 Avatar?id=13649&size=24x24 Updated by Ben Gadd over 1 year ago

  • Due date set to 07/23/2018

#7 Avatar?id=13649&size=24x24 Updated by Ben Gadd over 1 year ago

  • Due date changed from 07/23/2018 to 03/09/2018
  • Target version changed from 11.3 to 11.2-BETA1

#8 Updated by Dru Lavigne over 1 year ago

  • Target version changed from 11.2-BETA1 to 11.2-RC2

#9 Avatar?id=13649&size=24x24 Updated by Ben Gadd over 1 year ago

  • Category changed from Middleware to OS

#10 Updated by Nick Wolff about 1 year ago

  • Severity set to Low

#11 Updated by Marcelo Araujo about 1 year ago

  • Status changed from Not Started to Ready for Testing
  • Needs Doc changed from Yes to No
  • Needs Merging changed from Yes to No

This issue was fixed upstream on uefi-edk2-bhyve.

#12 Updated by Dru Lavigne about 1 year ago

  • Is duplicate of Bug #26708: Fix UEFI boot menu to allow Linux kernels 4.15 and higher to boot properly in bhyve VMs added

#13 Updated by Dru Lavigne about 1 year ago

  • Status changed from Ready for Testing to Closed
  • Target version changed from 11.2-RC2 to N/A
  • Reason for Closing set to Duplicate Issue

Also available in: Atom PDF