Project

General

Profile

Bug #26643

NFS

Added by Simon Mackenzie almost 3 years ago. Updated almost 3 years ago.

Status:
Closed: Insufficient Info
Priority:
No priority
Assignee:
William Grzybowski
Category:
Middleware
Target version:
Seen in:
Severity:
New
Reason for Closing:
Reason for Blocked:
Needs QA:
Yes
Needs Doc:
Yes
Needs Merging:
Yes
Needs Automation:
No
Support Suite Ticket:
n/a
Hardware Configuration:
ChangeLog Required:
No

Description

NFS
Request Method: POST
Request URL: http://192.168.1.166/admin/services/nfs/edit/1/
Software Version: FreeNAS-11.0-U4 (54848d13b)
Exception Type: CallTimeout
Exception Value:
Call timeout
Exception Location: /usr/local/lib/python3.6/site-packages/middlewared/client/client.py in call, line 233
Server time: Tue, 14 Nov 2017 12:42:18 +1100
Traceback

Environment:

Software Version: FreeNAS-11.0-U4 (54848d13b)
Request Method: POST
Request URL: http://192.168.1.166/admin/services/nfs/edit/1/

Traceback:
File "/usr/local/lib/python3.6/site-packages/django/core/handlers/exception.py" in inner
39. response = get_response(request)
File "/usr/local/lib/python3.6/site-packages/django/core/handlers/base.py" in _legacy_get_response
249. response = self._get_response(request)
File "/usr/local/lib/python3.6/site-packages/django/core/handlers/base.py" in _get_response
178. response = middleware_method(request, callback, callback_args, callback_kwargs)
File "./freenasUI/freeadmin/middleware.py" in process_view
162. return login_required(view_func)(request, *view_args, **view_kwargs)
File "/usr/local/lib/python3.6/site-packages/django/contrib/auth/decorators.py" in _wrapped_view
23. return view_func(request, *args, **kwargs)
File "./freenasUI/freeadmin/options.py" in wrapper
208. return self._admin.admin_view(view)(*args, **kwargs)
File "/usr/local/lib/python3.6/site-packages/django/utils/decorators.py" in _wrapped_view
149. response = view_func(request, *args, **kwargs)
File "/usr/local/lib/python3.6/site-packages/django/views/decorators/cache.py" in _wrapped_view_func
57. response = view_func(request, *args, **kwargs)
File "./freenasUI/freeadmin/site.py" in inner
142. return view(request, *args, **kwargs)
File "./freenasUI/freeadmin/options.py" in edit
566. mf.save()
File "./freenasUI/services/forms.py" in save
439. started = notifier().restart("nfs")
File "./freenasUI/middleware/notifier.py" in restart
274. return c.call('service.restart', what, {'onetime': onetime}, **kwargs)
File "./freenasUI/middleware/notifier.py" in restart
274. return c.call('service.restart', what, {'onetime': onetime}, **kwargs)
File "/usr/local/lib/python3.6/site-packages/middlewared/client/client.py" in call
233. raise CallTimeout("Call timeout")

Exception Type: CallTimeout at /admin/services/nfs/edit/1/
Exception Value: Call timeout

Request information

GET

No GET data
POST

Variable Value
all ''
nfs_srv_servers '4'
nfs_srv_bindip '192.168.1.166'
nfs_srv_v4 'on'
nfs_srv_mountd_port ''
nfs_srv_rpcstatd_port ''
nfs_srv_rpclockd_port ''
__form_id 'dialogForm_nfs'
FILES

No FILES data
COOKIES

Variable Value
sessionid 'nml590ptcjymqf5n90xavm4j7ppqk5ct'
csrftoken 'd5Dri72rE8fgPjdnd03sP9ZCQeyHI32yPi8ijgHKJi7WKMslITHjjZogViBKlCu5'
META

Variable Value

History

#1 Updated by Dru Lavigne almost 3 years ago

  • Assignee changed from Release Council to William Grzybowski
  • Seen in changed from Unspecified to 11.0-U4

#2 Updated by William Grzybowski almost 3 years ago

  • Status changed from Unscreened to 15

I cant really reproduce that.

Does that happen every time? Can you attach Save Debug (System - Advanced)?

#3 Updated by Dru Lavigne almost 3 years ago

  • Status changed from 15 to Closed: Insufficient Info
  • Target version set to N/A
  • Private changed from Yes to No

#4 Updated by Stefan Code almost 3 years ago

  • File debug-freenas-20171129101404.tgz added

I'm able to reproduce this on a fresh install.


Environment:

Software Version: FreeNAS-11.0-U4 (54848d13b)
Request Method: POST
Request URL: http://10.222.120.5/admin/services/nfs/edit/1/

Traceback:
File "/usr/local/lib/python3.6/site-packages/django/core/handlers/exception.py" in inner
  39.             response = get_response(request)
File "/usr/local/lib/python3.6/site-packages/django/core/handlers/base.py" in _legacy_get_response
  249.             response = self._get_response(request)
File "/usr/local/lib/python3.6/site-packages/django/core/handlers/base.py" in _get_response
  178.             response = middleware_method(request, callback, callback_args, callback_kwargs)
File "./freenasUI/freeadmin/middleware.py" in process_view
  162.         return login_required(view_func)(request, *view_args, **view_kwargs)
File "/usr/local/lib/python3.6/site-packages/django/contrib/auth/decorators.py" in _wrapped_view
  23.                 return view_func(request, *args, **kwargs)
File "./freenasUI/freeadmin/options.py" in wrapper
  208.                 return self._admin.admin_view(view)(*args, **kwargs)
File "/usr/local/lib/python3.6/site-packages/django/utils/decorators.py" in _wrapped_view
  149.                     response = view_func(request, *args, **kwargs)
File "/usr/local/lib/python3.6/site-packages/django/views/decorators/cache.py" in _wrapped_view_func
  57.         response = view_func(request, *args, **kwargs)
File "./freenasUI/freeadmin/site.py" in inner
  142.             return view(request, *args, **kwargs)
File "./freenasUI/freeadmin/options.py" in edit
  566.                     mf.save()
File "./freenasUI/services/forms.py" in save
  439.         started = notifier().restart("nfs")
File "./freenasUI/middleware/notifier.py" in restart
  274.             return c.call('service.restart', what, {'onetime': onetime}, **kwargs)
File "./freenasUI/middleware/notifier.py" in restart
  274.             return c.call('service.restart', what, {'onetime': onetime}, **kwargs)
File "/usr/local/lib/python3.6/site-packages/middlewared/client/client.py" in call
  233.             raise CallTimeout("Call timeout")

Exception Type: CallTimeout at /admin/services/nfs/edit/1/
Exception Value: Call timeout

Even service stop nfsd hangs.

Debug Log attached.

#5 Updated by William Grzybowski almost 3 years ago

Please give it a try on latest 11.1 RC

#6 Updated by Stefan Code almost 3 years ago

NFS seems to be working on 11RC2, although I cannot even import my pool on 11RC2:

Environment:

Software Version: FreeNAS-11.1-RC2 (f22406524)
Request Method: POST
Request URL: http://10.222.120.5/storage/auto-import/

Traceback:
File "/usr/local/lib/python3.6/site-packages/django/core/handlers/exception.py" in inner
  42.             response = get_response(request)
File "/usr/local/lib/python3.6/site-packages/django/core/handlers/base.py" in _legacy_get_response
  249.             response = self._get_response(request)
File "/usr/local/lib/python3.6/site-packages/django/core/handlers/base.py" in _get_response
  178.             response = middleware_method(request, callback, callback_args, callback_kwargs)
File "./freenasUI/freeadmin/middleware.py" in process_view
  162.         return login_required(view_func)(request, *view_args, **view_kwargs)
File "/usr/local/lib/python3.6/site-packages/django/contrib/auth/decorators.py" in _wrapped_view
  23.                 return view_func(request, *args, **kwargs)
File "/usr/local/lib/python3.6/site-packages/django/views/generic/base.py" in view
  68.             return self.dispatch(request, *args, **kwargs)
File "/usr/local/lib/python3.6/site-packages/formtools/wizard/views.py" in dispatch
  237.         response = super(WizardView, self).dispatch(request, *args, **kwargs)
File "/usr/local/lib/python3.6/site-packages/django/views/generic/base.py" in dispatch
  88.         return handler(request, *args, **kwargs)
File "/usr/local/lib/python3.6/site-packages/formtools/wizard/views.py" in post
  300.                 return self.render_done(form, **kwargs)
File "/usr/local/lib/python3.6/site-packages/formtools/wizard/views.py" in render_done
  357.                                   **kwargs)
File "./freenasUI/storage/forms.py" in done
  881.         self.volume = notifier().volume_import(vol['label'], vol['id'], key, passphrase, enc_disks)
File "./freenasUI/middleware/notifier.py" in volume_import
  2671.                 )[0]
File "/usr/local/lib/python3.6/site-packages/django/db/models/query.py" in __getitem__
  295.         return list(qs)[0]

Exception Type: IndexError at /storage/auto-import/
Exception Value: list index out of range

But that is for another issue I guess...

#7 Updated by William Grzybowski almost 3 years ago

Stefan Code wrote:

NFS seems to be working on 11RC2, although I cannot even import my pool on 11RC2:
[...]
But that is for another issue I guess...

Yes, unfortunately RC2 was released too soon. You will have better luck with RC1.

#8 Updated by William Grzybowski almost 3 years ago

Thanks for the quick update, by the way.

#9 Updated by Dru Lavigne almost 3 years ago

  • File deleted (debug-freenas-20171129101404.tgz)

Also available in: Atom PDF