Project

General

Profile

Bug #26689

smb will not start

Added by Jay Rich almost 3 years ago. Updated almost 3 years ago.

Status:
Closed: Insufficient Info
Priority:
No priority
Assignee:
John Hixson
Category:
OS
Target version:
Seen in:
Severity:
New
Reason for Closing:
Reason for Blocked:
Needs QA:
Yes
Needs Doc:
Yes
Needs Merging:
Yes
Needs Automation:
No
Support Suite Ticket:
n/a
Hardware Configuration:

FreeNAS-11.0-U4 (54848d13b)
Platform Intel(R) Xeon(R) CPU E3-1231 v3 @ 3.40GHz
Memory 16306MB

ChangeLog Required:
No

Description

i had smb service running but received an error that i could not connect from other clients on network i checked services and noticed smb was turned off. I click to turn back on and i get the spinning when only to still be turned off. I check the setting for smb and when i close dialog box i receive and error. I am still able to share via afp and nfs. I have tried rebooting, reverting toprevious version 11.2u and a complete reinstall 11 then uploaded config. The issue is still persistent.

error received after closing smb setting dialog box.

=========================

Request Method: POST
Request URL: https://192.168.0.240/services/cifs/
Software Version: FreeNAS-11.0-U2 (e417d8aa5)
Exception Type: ServiceFailed
Exception Value:

<django.utils.functional.lazy.<locals>.__proxy__ object at 0x81bd99128>

Exception Location: ./freenasUI/services/forms.py in save, line 265
Server time: Wed, 15 Nov 2017 10:45:54 -0500
Traceback
Environment:

Software Version: FreeNAS-11.0-U2 (e417d8aa5)
Request Method: POST
Request URL: https://192.168.0.240/services/cifs/

Traceback:
File "/usr/local/lib/python3.6/site-packages/django/core/handlers/exception.py" in inner
39. response = get_response(request)
File "/usr/local/lib/python3.6/site-packages/django/core/handlers/base.py" in _legacy_get_response
249. response = self._get_response(request)
File "/usr/local/lib/python3.6/site-packages/django/core/handlers/base.py" in _get_response
178. response = middleware_method(request, callback, callback_args, callback_kwargs)
File "./freenasUI/freeadmin/middleware.py" in process_view
162. return login_required(view_func)(request, *view_args, **view_kwargs)
File "/usr/local/lib/python3.6/site-packages/django/contrib/auth/decorators.py" in _wrapped_view
23. return view_func(request, *args, **kwargs)
File "./freenasUI/services/views.py" in services_cifs
208. form.save()
File "./freenasUI/services/forms.py" in save
265. "cifs", _("The SMB service failed to reload.")

Exception Type: ServiceFailed at /services/cifs/
Exception Value: <django.utils.functional.lazy.<locals>.__proxy__ object at 0x81bd99128>

Request information
GET

No GET data
POST
Variable Value
all ''
cifs_srv_netbiosname 'MediaNas'
cifs_srv_netbiosalias ''
cifs_srv_workgroup 'workgroup'
cifs_srv_description 'MediaNas Server'
cifs_srv_doscharset 'CP437'
cifs_srv_unixcharset 'UTF-8'
cifs_srv_loglevel '1'
cifs_srv_localmaster 'on'
cifs_srv_timeserver 'on'
cifs_srv_guest 'nobody'
cifs_srv_filemask ''
cifs_srv_dirmask ''
cifs_srv_smb_options ''
cifs_srv_unixext 'on'
cifs_srv_zeroconf 'on'
cifs_srv_hostlookup 'on'
cifs_srv_min_protocol ''
cifs_srv_max_protocol 'SMB3'
cifs_srv_allow_execute_always 'on'
cifs_srv_obey_pam_restrictions 'on'
idmap_tdb_range_low '90000001'
idmap_tdb_range_high '100000000'
_form_id 'dialogForm'
FILES

No FILES data
COOKIES
Variable Value
csrftoken 'pdAu3tRkgF7mUNdaeIlWUs22eVapvBqGV2sXFxKvsYhn476wuuVAK6UrtarIlqIT'
fntreeSaveStateCookie 'root%2Croot%2F169%2Croot%2F169%2F175%2Croot%2F169%2F175%2F177'
sessionid 'o0jk49bdatdvz47udortq4hphcmzxsi1'
META
Variable Value

History

#1 Updated by Dru Lavigne almost 3 years ago

  • Status changed from Unscreened to 15

Jay: does updating to U4 resolve the issue?

If not, please attach a debug (System -> Advanced -> Save Debug) from the updated system.

#2 Updated by Jay Rich almost 3 years ago

  • File debug-MediaNas-20171116153533.tgz added

Started with u4, went back to u2 with no success. here is debug.

#3 Updated by Dru Lavigne almost 3 years ago

  • Status changed from 15 to Unscreened
  • Assignee changed from Release Council to John Hixson
  • Private changed from No to Yes

#4 Updated by John Hixson almost 3 years ago

  • Status changed from Unscreened to Screened
  • Target version set to 11.1

#5 Updated by Jay Rich almost 3 years ago

Something odd I noticed over the weekend:

I removed all drives from freenas and rebooted. SMB started but gave me an error that smartd did not start. I added 2 drives back that held one dataset and smb would not start again.

What would make dataset refuse smb service but not nfs or afp? If I add the disk and dataset to another freenas, it works as expected.

I have a larger disk on order and currently backing up data.

#6 Avatar?id=14398&size=24x24 Updated by Kris Moore almost 3 years ago

  • Target version changed from 11.1 to 11.1-U1

#7 Updated by John Hixson almost 3 years ago

  • Status changed from Screened to 15

I don't see anything in the Samba logs, but need debugging turned up for anything useful. I see SMART problems and disk problems all over , however. I suspect this is the issue. Can you confirm you have problematic disks? Otherwise, I need the samba debugging cranked up, this problem reproduced, and another debug attached to the ticket.

#8 Updated by Dru Lavigne almost 3 years ago

  • Status changed from 15 to Closed: Insufficient Info
  • Target version changed from 11.1-U1 to N/A
  • Private changed from Yes to No

Jay: closing for now. If you're able to rule out the disks, increase debugging and attach a new debug after reproducing the issue.

#9 Updated by Dru Lavigne almost 3 years ago

  • File deleted (debug-MediaNas-20171116153533.tgz)

Also available in: Atom PDF