Project

General

Profile

Bug #26699

Account/Groups: missing checkbox

Added by Timothy Moore II almost 3 years ago. Updated almost 3 years ago.

Status:
Resolved
Priority:
Nice to have
Assignee:
Vaibhav Chauhan
Category:
GUI (new)
Severity:
New
Reason for Closing:
Reason for Blocked:
Needs QA:
No
Needs Doc:
Yes
Needs Merging:
Yes
Needs Automation:
No
Support Suite Ticket:
n/a
Hardware Configuration:

TrueOS UNSTABLE (Updated 11/16/17) with Firefox browser.

I followed the instructions at https://github.com/freenas/webui/blob/master/README.md to build the UI, but had to install npm4 to fix a build error. All other instructions were followed exactly.

Also using a stock FreeNAS Mini:
Hostname freenas.local
Build FreeNAS-11-MASTER-201711160405
Platform Intel(R) Atom(TM) CPU C2750 @ 2.40GHz
Memory 32703MB
System Time Thu, 16 Nov 2017 11:04:08 -0800
Uptime 11:04AM up 4:29, 0 users
Load Average 0.19, 0.19, 0.17

ChangeLog Required:
No

Description

In the new UI Accounts/Groups/Create new Group section, there should a checkbox to "Allow repeated GIDs", but it isn't visible. I checked group-form/group-form.component.ts; there is an entry for this checkbox. I cleaned it up a bit and added a tooltip, but it still doesn't appear when I build fresh.

History

#1 Updated by Dru Lavigne almost 3 years ago

  • Status changed from Untriaged to Unscreened
  • Assignee changed from Release Council to Lola Yang

#2 Updated by Lola Yang almost 3 years ago

  • Assignee changed from Lola Yang to Vaibhav Chauhan

Giving this ticket to VB since he worked on this page before

#3 Updated by Vaibhav Chauhan almost 3 years ago

  • Status changed from Unscreened to Needs Developer Review
  • Assignee changed from Vaibhav Chauhan to Lola Yang
  • Priority changed from No priority to Nice to have

#4 Updated by Vaibhav Chauhan almost 3 years ago

  • Assignee changed from Lola Yang to Xin Tan

#5 Updated by Xin Tan almost 3 years ago

  • Status changed from Needs Developer Review to Reviewed by Developer

LGTM.
Merged to master

#6 Updated by Dru Lavigne almost 3 years ago

  • Status changed from Reviewed by Developer to Resolved
  • Target version set to Master - FreeNAS Nightlies

#7 Updated by Vaibhav Chauhan almost 3 years ago

  • Assignee changed from Xin Tan to Vaibhav Chauhan

#8 Updated by Bonnie Follweiler almost 3 years ago

  • Needs QA changed from Yes to No
  • QA Status Test Passes FreeNAS added
  • QA Status deleted (Not Tested)

Confirmed in FreeNAS-11-MASTER-201712220614

Also available in: Atom PDF