Project

General

Profile

Bug #26704

Removing CD-ROM breaks UEFI boot

Added by BloodyIron - about 2 years ago. Updated 8 months ago.

Status:
Closed
Priority:
No priority
Assignee:
Marcelo Araujo
Category:
OS
Target version:
Seen in:
Severity:
Medium
Reason for Closing:
Duplicate Issue
Reason for Blocked:
Needs QA:
Yes
Needs Doc:
No
Needs Merging:
No
Needs Automation:
No
Support Suite Ticket:
n/a
Hardware Configuration:
ChangeLog Required:
No

Description

FreeNAS 11-U4, created a VM, installed Ubuntu 16.04 onto it, and wanted to remove the CD-ROM so it would stop booting from that device.

Except after removing the CD-ROM device, the VM (when VNC'd into) kicks to a UEFI recovery console.

Looks like the boot order isn't getting updated, and since we have no controls over such things, I can't correct this myself.

ARGH!


Subtasks

Bug #26616: Cannot install Live CD turnkey-mediawiki-14.2-jessie-amd64.iso in VMClosedMarcelo Araujo

Related issues

Related to FreeNAS - Bug #26708: Fix UEFI boot menu to allow Linux kernels 4.15 and higher to boot properly in bhyve VMsDone

History

#1 Updated by Dru Lavigne about 2 years ago

  • Assignee changed from Release Council to Marcelo Araujo

Marcelo: would this still be an issue on 11.1?

#2 Updated by BloodyIron - about 2 years ago

Solution found in : https://forums.freenas.org/index.php?threads/how-to-how-to-boot-linux-vms-using-uefi.54039/

But I'm still hoping we can get something baked into FreeNAS to smooth these things over. Not sure what that would look like.

(sorry not sure how to correctly close tickets in this system)

Also, not sure if this is relevant in 11.1

#3 Updated by Marcelo Araujo about 2 years ago

Dru Lavigne wrote:

Marcelo: would this still be an issue on 11.1?

It is an issue on bhyve, need to be fixed upstream.
I'm inclined to close this as a third part issue to be solved.

Thoughts?

#4 Updated by BloodyIron - about 2 years ago

I just want to make sure it's tracked until resolution. if there's another ticket open, go ahead. If not, seems prudent to keep this open.

Marcelo Araujo wrote:

Dru Lavigne wrote:

Marcelo: would this still be an issue on 11.1?

It is an issue on bhyve, need to be fixed upstream.
I'm inclined to close this as a third part issue to be solved.

Thoughts?

#5 Updated by Marcelo Araujo about 2 years ago

  • Status changed from Unscreened to Screened
  • Priority changed from No priority to Important
  • Seen in changed from 11.0-U4 to 11.2-BETA1

BloodyIron - wrote:

I just want to make sure it's tracked until resolution. if there's another ticket open, go ahead. If not, seems prudent to keep this open.

Marcelo Araujo wrote:

Dru Lavigne wrote:

Marcelo: would this still be an issue on 11.1?

It is an issue on bhyve, need to be fixed upstream.
I'm inclined to close this as a third part issue to be solved.

Thoughts?

OK, lets keep it Open till we have a proper fix in bhyve.

Br,

#6 Updated by Dru Lavigne about 2 years ago

  • Target version set to 11.2-BETA1
  • Seen in changed from 11.2-BETA1 to 11.0-U4

#7 Updated by Dru Lavigne about 2 years ago

  • Related to Bug #26708: Fix UEFI boot menu to allow Linux kernels 4.15 and higher to boot properly in bhyve VMs added

#8 Updated by Dru Lavigne almost 2 years ago

  • Status changed from Screened to Not Started

#9 Updated by Dru Lavigne over 1 year ago

  • Target version changed from 11.2-BETA1 to 11.2-RC2

#10 Avatar?id=13649&size=24x24 Updated by Ben Gadd over 1 year ago

  • Category changed from Middleware to OS

#11 Updated by Nick Wolff over 1 year ago

  • Severity set to Medium

#12 Updated by Marcelo Araujo over 1 year ago

  • Status changed from Not Started to Screened

#13 Updated by Marcelo Araujo over 1 year ago

  • Needs Doc changed from Yes to No
  • Needs Merging changed from Yes to No

It was fixed already on sysutils/uefi-edk2-bhyve.

#14 Updated by Marcelo Araujo over 1 year ago

  • Status changed from Screened to Closed

#15 Updated by Dru Lavigne over 1 year ago

  • Target version changed from 11.2-RC2 to N/A
  • Reason for Closing set to Not Applicable

#16 Updated by Dru Lavigne over 1 year ago

  • Reason for Closing changed from Not Applicable to Duplicate Issue

#17 Updated by Thomas Le Gentil 9 months ago

Just had the issue with 11.2-STABLE and debian

is this the main bug of all the duplicates ?

#18 Updated by Dru Lavigne 8 months ago

Thomas: this should have been fixed for 11.2-BETA1 on #26708. If the issue persists for you, please create a new ticket that includes your debug, created using System -> Advanced -> Save debug after reproducing the issue.

Also available in: Atom PDF