Project

General

Profile

Bug #26774

Fix middlewared segfault due to libzfs not being thread safe

Added by William Grzybowski 11 months ago. Updated 10 months ago.

Status:
Resolved
Priority:
Blocks Until Resolved
Assignee:
William Grzybowski
Category:
Middleware
Target version:
Seen in:
11.0
Sprint:
Severity:
New
Backlog Priority:
Reason for Closing:
Reason for Blocked:
Needs QA:
No
Needs Doc:
Yes
Needs Merging:
Yes
Needs Automation:
No
Support Suite Ticket:
Migration Needed:
Yes
Hide from ChangeLog:
No
ChangeLog Required:
No
Support Department Priority:
0

Related projects 1 project

Description

This might also be the cause of 100% CPU usage.

History

#1 Updated by William Grzybowski 11 months ago

  • Subject changed from Middlewared segfault due to libzfs thread safety to Middlewared segfault due to libzfs not being thread safe

#2 Updated by William Grzybowski 11 months ago

  • Status changed from Screened to Reviewed by Developer

#3 Updated by William Grzybowski 11 months ago

  • Status changed from Reviewed by Developer to Ready For Release

#4 Updated by Dru Lavigne 11 months ago

  • Subject changed from Middlewared segfault due to libzfs not being thread safe to Fix middlewared segfault due to libzfs not being thread safe

#5 Updated by Dru Lavigne 11 months ago

  • 1 added project (FreeNAS)
  • Target version changed from TrueNAS 11.1-U1 to 11.1-RC3

#6 Updated by Dru Lavigne 11 months ago

  • Status changed from Ready For Release to Resolved

#7 Updated by Nick Wolff 11 months ago

  • Migration Needed changed from No to Yes

Is there a reproduction case here or is that something that won't be easy to QA?

#8 Updated by William Grzybowski 11 months ago

Nick Wolff wrote:

Is there a reproduction case here or is that something that won't be easy to QA?

Prior to these fixes, if you had multiple shells running "midclt call zfs.pool.query" in a loop, middlewared would eventually crash/restart.

#9 Updated by Nick Wolff 10 months ago

  • Needs QA changed from Yes to No
  • QA Status Test Passes FreeNAS added
  • QA Status deleted (Not Tested)

Test Passes
Looped 20 shells for ~15 minutes with no issues

Also available in: Atom PDF