Project

General

Profile

Bug #26898

Don't require a reboot when entering a static IPv6 default route

Added by Marc Haber over 1 year ago. Updated about 1 year ago.

Status:
Done
Priority:
No priority
Assignee:
Vladimir Vinogradenko
Category:
Middleware
Target version:
Seen in:
Severity:
New
Reason for Closing:
Reason for Blocked:
Needs QA:
No
Needs Doc:
No
Needs Merging:
No
Needs Automation:
No
Support Suite Ticket:
n/a
Hardware Configuration:
ChangeLog Required:
No

Description

Hi,

when I enter a static IPv6 default route (for example, because SLAAC doesn't work and there is no DHCPv6 client), the system loses the IPv4 default route that was learned via DHCP. After a reboot, everthing is fine.

Greetings
Marc

ipv6default.png (33.6 KB) ipv6default.png Rishabh Chauhan, 06/18/2018 09:21 AM
ipv6shell.png (86.7 KB) ipv6shell.png Rishabh Chauhan, 06/18/2018 09:21 AM
i[pv6traceback.png (156 KB) i[pv6traceback.png Rishabh Chauhan, 06/18/2018 09:21 AM
18775
18778
18781

Associated revisions

Revision 31e082fa (diff)
Added by Vladimir Vinogradenko over 1 year ago

fix(network): Pick up DHCP route when there is no network interface configuration present using the same logic as in rc.conf.local

Ticket: #26898

Revision 2f152cf3 (diff)
Added by Vladimir Vinogradenko over 1 year ago

fix(network): Pick up DHCP route when there is no network interface configuration present using the same logic as in rc.conf.local

Ticket: #26898

History

#1 Updated by Dru Lavigne over 1 year ago

  • Status changed from Unscreened to 15
  • Assignee changed from Release Council to Vladimir Vinogradenko

Marc: can you recreate (before the reboot) and attach a debug (System -> Advanced -> Save Debug)?

#2 Updated by Marc Haber over 1 year ago

Is there a way to create the debug log from the shell? Between the change and the reboot, the GUI is inaccessible.

#3 Updated by Dru Lavigne over 1 year ago

Marc: run freenas-debug -A which will save the debug to /var/tmp/fndebug.

#4 Updated by Marc Haber over 1 year ago

  • File debug.tar.gz added

here we go.

#5 Updated by Dru Lavigne over 1 year ago

  • Status changed from 15 to Screened
  • Private changed from No to Yes

#6 Updated by Dru Lavigne over 1 year ago

  • Target version set to 11.2-BETA1

#7 Updated by Dru Lavigne over 1 year ago

  • Status changed from Screened to Not Started
  • Target version changed from 11.2-BETA1 to 11.2-RC2

#8 Updated by William Grzybowski over 1 year ago

  • Category changed from GUI (new) to Middleware

#9 Updated by Vladimir Vinogradenko over 1 year ago

  • Status changed from Not Started to In Progress

#10 Updated by Vladimir Vinogradenko over 1 year ago

  • Status changed from In Progress to Done

#11 Updated by Dru Lavigne over 1 year ago

  • Subject changed from Entering a static IPv6 default route removes DHCP IPv4 default route until reboot to Don't require a reboot when entering a static IPv6 default route
  • Target version changed from 11.2-RC2 to 11.2-BETA1
  • Needs Doc changed from Yes to No
  • Needs Merging changed from Yes to No

#12 Updated by Dru Lavigne over 1 year ago

  • File deleted (debug.tar.gz)

#13 Updated by Dru Lavigne over 1 year ago

  • Private changed from Yes to No

#14 Updated by Dru Lavigne over 1 year ago

  • Status changed from Done to Ready for Testing

#15 Updated by Rishabh Chauhan about 1 year ago

18775
18778
18781

After discussing with Vladimir, we went through a few steps to reproduce and see if it is working. Since we don't have a way of obtaining a valid ipv6 default route at the moment, I went with a random ipv6(correct format) to see if it responds as expected: 2001:db8:85a3::8a2e:370:7334
After updating ipv6 in Netweork> Global Configuration>Ipv6 Default Gateway I got a traceback saying network is unreachable which was expected(Refer screenshot: ipv6traceback.png)
but after navigating to some other tab and back to global configuration I was able to see the updated ipv6 default gateway(refer screenshot: ipv6default.png)
then in the shell, we tried the following commands(refer screenshot: ipv6shell.png for results):
1. netstat -rn
2. midclt call network.configuration.config
3. midclt call routes.sync

So this comment is just to update what all is testable as of now..., we were not 100% if the test passed/failed

#16 Updated by Dru Lavigne about 1 year ago

  • Status changed from Ready for Testing to Done

#17 Updated by Dru Lavigne about 1 year ago

  • Needs QA changed from Yes to No

Also available in: Atom PDF