Project

General

Profile

Bug #26969

Avatar?id=14398&size=22x22

Fix an issue with upgrading into an existing boot pool

Added by Nick Wolff over 1 year ago. Updated about 1 year ago.

Status:
Done
Priority:
Nice to have
Assignee:
Kris Moore
Category:
OS
Target version:
Seen in:
Severity:
New
Reason for Closing:
Reason for Blocked:
Needs QA:
No
Needs Doc:
No
Needs Merging:
No
Needs Automation:
No
Support Suite Ticket:
n/a
Hardware Configuration:
ChangeLog Required:
No

Description

Grub install fails on upgrade via iso while trying to embedded into bios boot partition. Error show in attached image.

Discovered in 11.1 and traced back to at least 11.0.

Reproduction

Install some version via iso as uefi.
Boot ISO of newer version and selected upgrade and install into new boot environment.
Install fails as seen below

photo4972203370391644201.jpg (138 KB) photo4972203370391644201.jpg Nick Wolff, 11/30/2017 07:40 PM
13260

Associated revisions

Revision 3f0899ad (diff)
Added by Kris Moore over 1 year ago

Fix an issue with inplace upgrades (Installing into an existing
boot pool)

When we do this, default to restamping EFI/BIOS based upon what
the existing install was setup to use, not how the installer
was booted. It is possible that a boot may be done on EFI or
BIOS when the installed disks were setup with the other.

Ticket: #26969

Revision 671baf01 (diff)
Added by Kris Moore over 1 year ago

Fix 26969 inplace upgrade (#668)

  • Update readme with info on PROFILE: tag for PRs
  • Fix an issue with inplace upgrades (Installing into an existing
    boot pool)

When we do this, default to restamping EFI/BIOS based upon what
the existing install was setup to use, not how the installer
was booted. It is possible that a boot may be done on EFI or
BIOS when the installed disks were setup with the other.

Ticket: #26969

History

#1 Updated by Dru Lavigne over 1 year ago

  • Status changed from Untriaged to Unscreened
  • Assignee changed from Release Council to Kris Moore

Kris: have you encountered that error before?

#2 Avatar?id=14398&size=24x24 Updated by Kris Moore over 1 year ago

  • Status changed from Unscreened to Screened
  • Priority changed from No priority to Nice to have
  • Target version set to 11.1-U1

Nope, but I think I can figure out the cause. Its trying to do a BIOS stamp on EFI boot, probably bug in installer shell somewhere. Not super critical, but I'll work on it for 11.0-U1

#3 Avatar?id=14398&size=24x24 Updated by Kris Moore over 1 year ago

  • Status changed from Screened to Needs Developer Review
  • Assignee changed from Kris Moore to Sean Fagan
  • Target version changed from 11.1-U1 to 11.2-BETA1

#4 Updated by Sean Fagan over 1 year ago

  • Status changed from Needs Developer Review to Reviewed by Developer
  • Assignee changed from Sean Fagan to Kris Moore

#5 Avatar?id=14398&size=24x24 Updated by Kris Moore over 1 year ago

  • Status changed from Reviewed by Developer to Ready For Release

#6 Updated by Dru Lavigne over 1 year ago

  • Subject changed from Upgrade via iso into new boot environment fails to Fix an issue with upgrading into an existing boot pool
  • Status changed from Ready For Release to Done
  • Needs Doc changed from Yes to No
  • Needs Merging changed from Yes to No

#7 Updated by Dru Lavigne about 1 year ago

  • Status changed from Done to Ready for Testing

#8 Updated by Eric Turgeon about 1 year ago

  • Status changed from Ready for Testing to Passed Testing
  • Severity set to New
  • Needs QA changed from Yes to No

Looks to work if in FreeNAS-11.2-MASTER-201806191350 (4d34a765b)

#9 Updated by Dru Lavigne about 1 year ago

  • Status changed from Passed Testing to Done

Also available in: Atom PDF