Project

General

Profile

Bug #26983

Avatar?id=14398&size=22x22

11-stable mistaken for 11-nightlies by updater

Added by Michael Dexter almost 3 years ago. Updated almost 3 years ago.

Status:
Closed: Duplicate
Priority:
Important
Assignee:
Kris Moore
Category:
OS
Target version:
Seen in:
Severity:
New
Reason for Closing:
Reason for Blocked:
Needs QA:
Yes
Needs Doc:
Yes
Needs Merging:
Yes
Needs Automation:
No
Support Suite Ticket:
n/a
Hardware Configuration:
ChangeLog Required:
No

Description

See the attached screen shot.

Sequence: 11-stable to 11-nightlies and back to 11-stable. Attempting to choose 11.1-prerelease warns that 11-nightlies cannot be updated, despite being on 11-stable.

Nightliesmare.jpg (63.6 KB) Nightliesmare.jpg Michael Dexter, 12/01/2017 02:10 PM
ListofBEs.jpg (83.9 KB) ListofBEs.jpg Michael Dexter, 12/01/2017 02:25 PM
13273
13275

Related issues

Is duplicate of FreeNAS - Bug #26984: Resign Manifest so updates workResolved2017-12-01

History

#1 Updated by Dru Lavigne almost 3 years ago

  • Status changed from Unscreened to 15

How did you go back to 11 stable?

#2 Updated by Michael Dexter almost 3 years ago

By choosing a previous boot environment, such as 11.0-U2

#3 Updated by Dru Lavigne almost 3 years ago

  • Status changed from 15 to Unscreened
  • Assignee changed from Release Council to Kris Moore
  • Priority changed from No priority to Important
  • Target version set to 11.1

#4 Updated by Michael Dexter almost 3 years ago

13275

Trying a manual update gives this traceback:

Environment: Software Version: FreeNAS-11.0-U4 (54848d13b) Request Method: POST Request URL: http://10.0.0.185/system/manualupdate/?X-Progress-ID=28eb968d-ceee-4b6f-8207-6b1c3db5c33a Traceback: File "/usr/local/lib/python3.6/subprocess.py" in check_output 336. **kwargs).stdout File "/usr/local/lib/python3.6/subprocess.py" in run 418. output=stdout, stderr=stderr) File "/usr/local/lib/python3.6/site-packages/django/core/handlers/exception.py" in inner 39. response = get_response(request) File "/usr/local/lib/python3.6/site-packages/django/core/handlers/base.py" in _legacy_get_response 249. response = self._get_response(request) File "/usr/local/lib/python3.6/site-packages/django/core/handlers/base.py" in _get_response 178. response = middleware_method(request, callback, callback_args, callback_kwargs) File "/usr/local/lib/python3.6/site-packages/django/contrib/auth/decorators.py" in _wrapped_view 23. return view_func(request, *args, **kwargs) File "/usr/local/lib/python3.6/site-packages/django/views/generic/base.py" in view 68. return self.dispatch(request, *args, **kwargs) File "/usr/local/lib/python3.6/site-packages/formtools/wizard/views.py" in dispatch 237. response = super(WizardView, self).dispatch(request, *args, **kwargs) File "/usr/local/lib/python3.6/site-packages/django/views/generic/base.py" in dispatch 88. return handler(request, *args, **kwargs) File "/usr/local/lib/python3.6/site-packages/formtools/wizard/views.py" in post 300. return self.render_done(form, **kwargs) File "/usr/local/lib/python3.6/site-packages/formtools/wizard/views.py" in render_done 357. **kwargs) Exception Type: MiddlewareError at /system/manualupdate/ Exception Value: [MiddlewareError: b"Failed to apply update Command '['/usr/local/bin/freenas-update', '-C', '/var/tmp/firmware', 'update']' returned non-zero exit status 1.: b''"]

See the attached list of my existing boot environments. I previously deleted all "Nightly" ones and booted to a stable one before performing any update to -stable.

At this point, I am not sure how to install 11.1-RC3

#5 Updated by Michael Dexter almost 3 years ago

Need any more data from me? I am thinking to go to a yet-earlier boot environment and seeing if it will stick.

#6 Updated by Tobias Müllauer almost 3 years ago

I have the same thing. I can't chose beta. When I do I get that window to. I am in u4 and never install nightly

#7 Updated by Michael Dexter almost 3 years ago

I have booted to an 11.0-U2 boot environment and begun a manual upgrade to 11.1-RC3. The process started, showing two active progress bars but ended up with what is likely the same traceback:

Environment: Software Version: FreeNAS-11.0-U2 (e417d8aa5) Request Method: POST Request URL: http://10.0.0.185/system/manualupdate/?X-Progress-ID=4e79af67-1c30-44e6-87b6-757088d09462 Traceback: File "/usr/local/lib/python3.6/subprocess.py" in check_output 336. **kwargs).stdout File "/usr/local/lib/python3.6/subprocess.py" in run 418. output=stdout, stderr=stderr) File "/usr/local/lib/python3.6/site-packages/django/core/handlers/exception.py" in inner 39. response = get_response(request) File "/usr/local/lib/python3.6/site-packages/django/core/handlers/base.py" in _legacy_get_response 249. response = self._get_response(request) File "/usr/local/lib/python3.6/site-packages/django/core/handlers/base.py" in _get_response 178. response = middleware_method(request, callback, callback_args, callback_kwargs) File "/usr/local/lib/python3.6/site-packages/django/contrib/auth/decorators.py" in _wrapped_view 23. return view_func(request, *args, **kwargs) File "/usr/local/lib/python3.6/site-packages/django/views/generic/base.py" in view 68. return self.dispatch(request, *args, **kwargs) File "/usr/local/lib/python3.6/site-packages/formtools/wizard/views.py" in dispatch 237. response = super(WizardView, self).dispatch(request, *args, **kwargs) File "/usr/local/lib/python3.6/site-packages/django/views/generic/base.py" in dispatch 88. return handler(request, *args, **kwargs) File "/usr/local/lib/python3.6/site-packages/formtools/wizard/views.py" in post 300. return self.render_done(form, **kwargs) File "/usr/local/lib/python3.6/site-packages/formtools/wizard/views.py" in render_done 357. **kwargs) Exception Type: MiddlewareError at /system/manualupdate/ Exception Value: [MiddlewareError: b"Failed to apply update Command '['/usr/local/bin/freenas-update', '-C', '/var/tmp/firmware', 'update']' returned non-zero exit status 1.: b''"]

#8 Updated by Michael Dexter almost 3 years ago

Downgrading to 11.0-RELEASE prevents me from changing trains to 11.1-PRERELEASE and a manual update simply gives "An Error Occurred" in the green alert zone at the top of the screen.

#9 Updated by Michael Dexter almost 3 years ago

Downgrading to Initial-Install results in the system booting to a FreeBSD login prompt with no FreeNAS services running.
Choosing "default" in GRUB will give an unconfigured system with DHCP etc.

#10 Updated by Michael Dexter almost 3 years ago

"default" gives the same "An Error Occurred"

I have no idea how to update my running 11-stable system to 11.1-RC3 via the GUI.

#11 Updated by Michael Dexter almost 3 years ago

Updating via the Console Setup Menu also fails. Starting a fresh install to a USB device.

#12 Updated by Tobias Müllauer almost 3 years ago

Michael Dexter wrote:

Updating via the Console Setup Menu also fails. Starting a fresh install to a USB device.

I am really hope that i don't have to reinstall freenas for this.

#13 Updated by Nick Wolff almost 3 years ago

This is likely related to a signing issue of rc3 that has been reported.

https://redmine.ixsystems.com/issues/26984

#14 Avatar?id=14398&size=24x24 Updated by Kris Moore almost 3 years ago

  • Status changed from Unscreened to Closed: Duplicate
  • Target version changed from 11.1 to N/A

#15 Avatar?id=14398&size=24x24 Updated by Kris Moore almost 3 years ago

  • Is duplicate of Bug #26984: Resign Manifest so updates work added

Also available in: Atom PDF