Project

General

Profile

Bug #26995

Permission not inherited and Owner of folder removed from permissions

Added by Adarsh Madrecha almost 3 years ago. Updated almost 3 years ago.

Status:
Closed: Duplicate
Priority:
No priority
Assignee:
Release Council
Category:
OS
Target version:
Seen in:
Severity:
New
Reason for Closing:
Reason for Blocked:
Needs QA:
Yes
Needs Doc:
Yes
Needs Merging:
Yes
Needs Automation:
No
Support Suite Ticket:
n/a
Hardware Configuration:

RAM:16GB
CPU: i3 4th gen 3.6 ghz
HDD: 3 X 2TB HDD in Raid Z

ChangeLog Required:
No

Description

Scenario:
user1 is the owner of a folderA, and user2 creates a subfolder called folderB

Expected behaviour:
1. Permissions for folderB should be inherited from folderA

Actual behaviour:
1. Permissions for folderB is copied (instead of inheriting) from folderA
2. Permissions copied from folderA does not contain user1.

For detailed screenshots ( and my explanation of the screenshots), please refer attached excel file.


Related issues

Is duplicate of TrueNAS - Bug #26765: Samba -when nfs4:mode=special, changing owner breaks permissions inheritanceClosed2017-11-20

History

#1 Updated by Dru Lavigne almost 3 years ago

  • Status changed from Unscreened to 15
  • Private changed from No to Yes

Adarsh: please attach a debug (System -> Advanced -> Save Debug).

#2 Updated by Andrew Walker almost 3 years ago

This is same issue as described in TrueNAS bug 26765. Patching libsunacl to understand "inherited" flag resolves the issue in my testing environment. Github PR here: https://github.com/freenas/ports/pull/40

Potential workaround: in my limited testing, it appears that nfs4:mode=simple may follow different code path for determining control flags in security descriptor.

Adarsh: try adding following auxiliary parameter to a test share and verify that it resolves the issue:
nfs4:mode=simple

Once you have added the parameter, restart the SMB service.

#3 Updated by Dru Lavigne almost 3 years ago

  • Is duplicate of Issue #26765 added

#4 Updated by Dru Lavigne almost 3 years ago

  • Status changed from 15 to Closed: Duplicate
  • Target version set to N/A

#5 Updated by Dru Lavigne almost 3 years ago

  • File deleted (Freenas Analysis.xlsx)

#6 Updated by Dru Lavigne almost 3 years ago

  • Private changed from Yes to No

Also available in: Atom PDF