Project

General

Profile

Bug #27001

Fix mDNS traceback

Added by William Grzybowski almost 3 years ago. Updated almost 3 years ago.

Status:
Resolved
Priority:
Expected
Assignee:
John Hixson
Category:
Middleware
Target version:
Severity:
New
Reason for Closing:
Reason for Blocked:
Needs QA:
No
Needs Doc:
Yes
Needs Merging:
Yes
Needs Automation:
No
Support Suite Ticket:
n/a
Hardware Configuration:
ChangeLog Required:
No

Description

# cat /etc/version 
FreeNAS-11-MASTER-201712012012 (1d3f3dd32)
Exception in thread Thread-6:                                                                       
Traceback (most recent call last):                
  File "/usr/local/lib/python3.6/threading.py", line 916, in _bootstrap_inner                       
    self.run()           
  File "/usr/local/lib/python3.6/site-packages/middlewared/plugins/mdns.py", line 476, in run       
    self.register()      
  File "/usr/local/lib/python3.6/site-packages/middlewared/plugins/mdns.py", line 473, in register  
    self._register(self.hostname, self.regtype, self.port)                                          
  File "/usr/local/lib/python3.6/site-packages/middlewared/plugins/mdns.py", line 455, in _register 
    sdRef = pybonjour.DNSServiceRegister(name=name, regtype=regtype, port=port, callBack=None)      
  File "/usr/local/lib/python3.6/site-packages/pybonjour.py", line 1141, in DNSServiceRegister      
    None)                
ctypes.ArgumentError: argument 10: <class 'ValueError'>: embedded null character  

Associated revisions

Revision 80d163e1 (diff)
Added by John Hixson almost 3 years ago

Fix py-bonjour port Ticket: #27001

Revision d5892e1e (diff)
Added by John Hixson almost 3 years ago

Fix py-bonjour port Ticket: #27001 (cherry picked from commit 80d163e1779fb247c7719c498d3c98d3df2a96b9)

Revision d327f90a (diff)
Added by John Hixson over 2 years ago

Fix py-bonjour port Ticket: #27001

Revision 5ae4b5fe (diff)
Added by John Hixson about 2 years ago

Fix py-bonjour port Ticket: #27001

Revision a29dcf75 (diff)
Added by John Hixson about 2 years ago

Fix py-bonjour port Ticket: #27001

Revision b109985a (diff)
Added by John Hixson about 2 years ago

Fix py-bonjour port Ticket: #27001

Revision a3f879de (diff)
Added by John Hixson almost 2 years ago

Fix py-bonjour port Ticket: #27001

Revision 13f39afc (diff)
Added by John Hixson over 1 year ago

Fix py-bonjour port Ticket: #27001

Revision 49c236ee (diff)
Added by John Hixson over 1 year ago

Fix py-bonjour port Ticket: #27001

Revision d848af83 (diff)
Added by John Hixson over 1 year ago

Fix py-bonjour port Ticket: #27001

Revision 507d8854 (diff)
Added by John Hixson about 1 year ago

Fix py-bonjour port Ticket: #27001

Revision ee182d69 (diff)
Added by John Hixson about 1 year ago

Fix py-bonjour port Ticket: #27001

History

#1 Updated by John Hixson almost 3 years ago

  • Status changed from Untriaged to Screened

I noticed this at home this weekend as well (not even on FreeNAS, but on TrueOS). It appears to be related to python3, since the same code works fine with python2.7. It worked fine until I upgraded ;-)

#2 Updated by John Hixson almost 3 years ago

John Hixson wrote:

I noticed this at home this weekend as well (not even on FreeNAS, but on TrueOS). It appears to be related to python3, since the same code works fine with python2.7. It worked fine until I upgraded ;-)

I can confirm it working in python 3.6.1. Nightlies are running 3.6.3.

#3 Updated by William Grzybowski almost 3 years ago

So is STABLE because of critical bugs < 3.6.3

#4 Updated by John Hixson almost 3 years ago

#5 Updated by William Grzybowski almost 3 years ago

John Hixson wrote:

https://bugs.python.org/issue32041 and https://github.com/python/cpython/pull/2285 point out the problem here.

Interesting! Apparently all we gotta do is use bytes and not string?

#6 Updated by John Hixson almost 3 years ago

  • Priority changed from No priority to Expected
  • Target version changed from 11.1-U1 to 11.1

#7 Updated by Dru Lavigne almost 3 years ago

  • Subject changed from Traceback in mdns threads to Fix mDNS traceback

#8 Updated by John Hixson almost 3 years ago

Fixed in commit: 80d163e1779fb247c7719c498d3c98d3df2a96b9

PR for master:
https://github.com/freenas/ports/pull/56

PR for stable:
https://github.com/freenas/ports/pull/57

#9 Updated by John Hixson almost 3 years ago

  • Status changed from Screened to Needs Developer Review
  • Assignee changed from John Hixson to Release Council

#10 Updated by Dru Lavigne almost 3 years ago

  • Assignee changed from Release Council to Kris Moore

Kris: do you have time to review this one?

#11 Avatar?id=14398&size=24x24 Updated by Kris Moore almost 3 years ago

  • Assignee changed from Kris Moore to William Grzybowski

Looks fine to me, but my python is weak. William can you look also?

#12 Avatar?id=14398&size=24x24 Updated by Kris Moore almost 3 years ago

  • Status changed from Needs Developer Review to Reviewed by Developer
  • Assignee changed from William Grzybowski to John Hixson

Oh, duh, its just an .encode() line. I can approve that ;)

#13 Updated by Dru Lavigne almost 3 years ago

  • Status changed from Reviewed by Developer to Ready For Release

#14 Updated by Joe Maloney almost 3 years ago

  • Needs QA changed from Yes to No
  • QA Status Test Passes FreeNAS added
  • QA Status deleted (Not Tested)

#15 Updated by Dru Lavigne almost 3 years ago

  • Status changed from Ready For Release to Resolved

Also available in: Atom PDF