Project

General

Profile

Bug #27009

New UI looks ... horrible ... on macOS + Firefox

Added by Sean Fagan almost 3 years ago. Updated over 2 years ago.

Status:
Closed
Priority:
No priority
Assignee:
Erin Clark
Category:
GUI (new)
Target version:
Severity:
Reason for Closing:
Duplicate
Reason for Blocked:
Needs QA:
Yes
Needs Doc:
Yes
Needs Merging:
Yes
Needs Automation:
No
Support Suite Ticket:
n/a
Hardware Configuration:
ChangeLog Required:
No

Description

FreeNAS-11-MASTER-201712040418 (1d3f3dd)
macOS 10.12.6
Firefox 57.0.1 (64-bit)

See attached sreenshot.

Screen Shot 2017-12-04 at 1.10.27 PM.png (769 KB) Screen Shot 2017-12-04 at 1.10.27 PM.png Sean Fagan, 12/04/2017 01:13 PM
Screen Shot 2017-12-13 at 10.54.14 AM.png (1010 KB) Screen Shot 2017-12-13 at 10.54.14 AM.png Lola Yang, 12/13/2017 10:58 AM
ss.png (822 KB) ss.png Sean Fagan, 12/18/2017 01:28 PM
13288
13363
13464

Related issues

Is duplicate of FreeNAS - Bug #27997: GUI unusable without access to Google servicesDone

History

#1 Updated by Sean Fagan almost 3 years ago

  • Assignee deleted (Sean Fagan)

#2 Updated by Dru Lavigne almost 3 years ago

  • Status changed from Untriaged to Unscreened
  • Assignee set to Erin Clark

#3 Avatar?id=14398&size=24x24 Updated by Kris Moore almost 3 years ago

Sean,

Can you try clearing your local browser cache quickly? I've seen this one time before and when I cleared cache it went away.

#4 Updated by Sean Fagan almost 3 years ago

I cleared cache & cookies since the beginning of time and it still looks awful.

#5 Updated by Sean Fagan almost 3 years ago

Then I cleared everything, and quit & restart, and it still looks awful.

Interestingly, though, there are real graphs below the horribleness.

#6 Updated by Dru Lavigne almost 3 years ago

  • Target version set to 11.2-BETA1

#7 Updated by Erin Clark almost 3 years ago

  • Assignee changed from Erin Clark to Lola Yang

Lola, you have a Mac, do you see these problems on your Mac with Firefox?

#8 Updated by Lola Yang almost 3 years ago

13363

Erin Clark wrote:

Lola, you have a Mac, do you see these problems on your Mac with Firefox?

It works fine on my mac.
FreeNAS: FreeNAS-11-MASTER-201712110432
MacOS: high sierra version 10.13.1
firefox: version 57.0.2 (64-bit)

#9 Updated by Lola Yang almost 3 years ago

  • Assignee changed from Lola Yang to Erin Clark

#10 Updated by Erin Clark almost 3 years ago

  • Status changed from Unscreened to 15

I'm not sure how to reproduce the firefox graphics glitches Sef, I've been testing with firefox too without any problems. Does this happen if you point your web browser at a different machine's webui than the one you tested it on?

#11 Updated by Sean Fagan almost 3 years ago

Looks the same from the laptop on both the nas at home and at work.

Looks correct on another Mac with a freshly-installed Firefox to the nas a hoome.

#12 Updated by Erin Clark almost 3 years ago

Do you use any kind of addons?

#13 Updated by Erin Clark almost 3 years ago

Could you do right click > inspect element and go to the console and see if you get a traceback?

#14 Updated by Sean Fagan almost 3 years ago

Where would I see the traceback?

#15 Updated by Sean Fagan almost 3 years ago

13464

When I clicked on one of the things, the text rotated and is now upside down. wtf?

#16 Avatar?id=14398&size=24x24 Updated by Kris Moore over 2 years ago

  • Target version changed from 11.2-BETA1 to 11.3

#17 Updated by Dru Lavigne over 2 years ago

  • Status changed from 15 to Unscreened

#18 Updated by Erin Clark over 2 years ago

  • Status changed from Unscreened to Screened

#19 Avatar?id=14398&size=24x24 Updated by Kris Moore over 2 years ago

  • Status changed from Screened to Not Started

#20 Updated by Anthony Takata over 2 years ago

This seems to indicate that the woff (web fonts) for the icons aren't loading for whatever reason. Are you able to get to https://fonts.googleapis.com/css?family=Roboto:300,400,500,700|Material+Icons ?
See issue https://redmine.ixsystems.com/issues/27997 which I think is the same problem.

#21 Updated by Dru Lavigne over 2 years ago

  • Is duplicate of Bug #27997: GUI unusable without access to Google services added

#22 Updated by Dru Lavigne over 2 years ago

  • Status changed from Not Started to Closed
  • Target version changed from 11.3 to N/A
  • Reason for Closing set to Duplicate

Also available in: Atom PDF