Project

General

Profile

Bug #27012

Add ability to set password in new UI if it wasn't configured during installation

Added by IT IGP over 2 years ago. Updated almost 2 years ago.

Status:
Done
Priority:
No priority
Assignee:
Lola Yang
Category:
GUI (new)
Target version:
Severity:
New
Reason for Closing:
Reason for Blocked:
Needs QA:
No
Needs Doc:
No
Needs Merging:
No
Needs Automation:
No
Support Suite Ticket:
n/a
Hardware Configuration:
ChangeLog Required:
No

Description

you can install FreeNAS without password. but upon first login to the new UI you are forced to input something into the password field - otherwise the "sign in" button stays greyed out. currently you HAVE to go to the old UI to get the change password dialog and set a password, to be able to login through the new UI afterwards.

offtopic question: when i test with https://download.freenas.org/11/MASTER/latest/x64/ - as i did - this is considered "Master - FreeNAS Nightlies"?

Screenshot_41.png (25.5 KB) Screenshot_41.png IT IGP, 12/05/2017 04:10 AM
example.png (28.3 KB) example.png Dru Lavigne, 06/25/2018 10:34 AM
13290
19413

Related issues

Has duplicate FreeNAS - Bug #45314: Add the ability to set the password on first login if user left password blank during installationClosed
Blocked by FreeNAS - Bug #41844: Add middleware API for setting password on first login if user left password blank during installationDone

History

#1 Updated by Dru Lavigne over 2 years ago

  • Assignee changed from Release Council to Erin Clark

#2 Updated by Dru Lavigne over 2 years ago

  • Target version set to 11.2-BETA1

#3 Updated by Erin Clark over 2 years ago

  • Status changed from Unscreened to Screened

#4 Avatar?id=14398&size=24x24 Updated by Kris Moore over 2 years ago

  • Target version changed from 11.2-BETA1 to 11.3

#5 Updated by IT IGP over 2 years ago

the new UI seems to be default now. if it should go live in the next release this issue might cause some confusion...

#6 Avatar?id=14398&size=24x24 Updated by Kris Moore over 2 years ago

  • Status changed from Screened to Not Started

#7 Avatar?id=13649&size=24x24 Updated by Ben Gadd about 2 years ago

  • Target version changed from 11.3 to Backlog

#8 Avatar?id=13649&size=24x24 Updated by Ben Gadd about 2 years ago

  • Severity set to New

#9 Updated by Dru Lavigne about 2 years ago

19413

Attached is the screen which the legacy UI pops up if a password is not present.

#10 Updated by Dru Lavigne almost 2 years ago

  • Target version changed from 11.2-RC2 to 11.2-BETA3

#11 Updated by Aaron St. John almost 2 years ago

Tested in the latest nightlies (FreeNAS-11.2-MASTER-201807190857).

This is still an issue. After the initial set up and not creating a password there's no option to set one up from the UI.

To reproduce:
1. Download latest nightlies.
2. Install and go through the set up; choose <cancel> when it ask to create a password.
3. Go to web UI and notice the issue.

Sidenote: going back to the legacy UI still prompts for the creation of a password.

#13 Updated by Erin Clark almost 2 years ago

  • Target version changed from 11.2-BETA3 to 11.2-RC1

This ticket needs middleware work, see https://redmine.ixsystems.com/issues/41844

#14 Updated by Erin Clark almost 2 years ago

  • Blocked by Bug #41844: Add middleware API for setting password on first login if user left password blank during installation added

#15 Updated by Erin Clark almost 2 years ago

  • Assignee changed from Erin Clark to Lola Yang

#16 Updated by Dru Lavigne almost 2 years ago

  • Has duplicate Bug #45314: Add the ability to set the password on first login if user left password blank during installation added

#17 Updated by Lola Yang almost 2 years ago

  • Status changed from Not Started to In Progress

#18 Updated by Lola Yang almost 2 years ago

  • Status changed from In Progress to Ready for Testing
  • Needs Merging changed from Yes to No

#19 Updated by Dru Lavigne almost 2 years ago

  • Subject changed from "Sign in" greyed out with empty password - even after install without password / new UI missing change password dialog to Add ability to set password in new UI if it wasn't specified during installation

#20 Updated by Dru Lavigne almost 2 years ago

  • Subject changed from Add ability to set password in new UI if it wasn't specified during installation to Add ability to set password in new UI if it wasn't configured during installation

#21 Updated by Timothy Moore II almost 2 years ago

  • Status changed from Ready for Testing to Passed Testing
  • Needs QA changed from Yes to No

Testing with a FreeNAS VM installed with FreeNAS-11.2-MASTER-201809200901:

Install FreeNAS with no root password in a VM. Review set password dialog in the UI at first boot. Set root password and log in. Log out and back in to confirm root password is set.

#22 Updated by Timothy Moore II almost 2 years ago

  • Needs Doc changed from Yes to No

#23 Updated by Dru Lavigne almost 2 years ago

  • Status changed from Passed Testing to Done

Also available in: Atom PDF