Project

General

Profile

Bug #27018

Avatar?id=14398&size=22x22

Don't create iocage datasets if no jails exist

Added by Bonnie Follweiler about 1 year ago. Updated 12 months ago.

Status:
Resolved
Priority:
Blocks Until Resolved
Assignee:
Kris Moore
Category:
Middleware
Target version:
Seen in:
Severity:
New
Reason for Closing:
Reason for Blocked:
Needs QA:
No
Needs Doc:
Yes
Needs Merging:
Yes
Needs Automation:
No
Support Suite Ticket:
n/a
Hardware Configuration:
ChangeLog Required:
No

Description

I upgraded to FreeNAS-11.1-INTERNAL2
During the upgrade, after reboot, iocage datasets were created. I have no jails. I deleted the datasets and rebooted. During the reboot it recreated them again
Screen shots provided

Screen Shot 2017-12-05 at 10.33.29 AM.png (98.5 KB) Screen Shot 2017-12-05 at 10.33.29 AM.png no jails Bonnie Follweiler, 12/05/2017 07:37 AM
Screen Shot 2017-12-05 at 10.33.19 AM.png (196 KB) Screen Shot 2017-12-05 at 10.33.19 AM.png Created during the reboot Bonnie Follweiler, 12/05/2017 07:38 AM
iocage.jpg (145 KB) iocage.jpg What my console showed Bonnie Follweiler, 12/05/2017 07:39 AM
Screen Shot 2017-12-07 at 2.53.47 PM.png (35.4 KB) Screen Shot 2017-12-07 at 2.53.47 PM.png Bonnie Follweiler, 12/07/2017 12:07 PM
Screen Shot 2017-12-07 at 2.54.51 PM.png (118 KB) Screen Shot 2017-12-07 at 2.54.51 PM.png Bonnie Follweiler, 12/07/2017 12:08 PM
Screen Shot 2017-12-07 at 2.55.41 PM.png (173 KB) Screen Shot 2017-12-07 at 2.55.41 PM.png Bonnie Follweiler, 12/07/2017 12:08 PM
Screen Shot 2017-12-07 at 3.01.58 PM.png (193 KB) Screen Shot 2017-12-07 at 3.01.58 PM.png Bonnie Follweiler, 12/07/2017 12:08 PM
Screen Shot 2017-12-07 at 3.17.01 PM.png (60.6 KB) Screen Shot 2017-12-07 at 3.17.01 PM.png Bonnie Follweiler, 12/07/2017 12:22 PM
Screen Shot 2017-12-07 at 5.18.25 PM.png (103 KB) Screen Shot 2017-12-07 at 5.18.25 PM.png Bonnie Follweiler, 12/07/2017 02:26 PM
Screen Shot 2017-12-07 at 5.22.33 PM.png (151 KB) Screen Shot 2017-12-07 at 5.22.33 PM.png Bonnie Follweiler, 12/07/2017 02:26 PM
Screen Shot 2017-12-07 at 5.18.36 PM.png (46.7 KB) Screen Shot 2017-12-07 at 5.18.36 PM.png Bonnie Follweiler, 12/07/2017 02:28 PM
13299
13300
13302
13321
13322
13323
13324
13326
13329
13330
13331

History

#1 Updated by Bonnie Follweiler about 1 year ago

  • Private changed from No to Yes

This is on my mini 10.231.1.76 root:abcd1234
Right now it has the created directories but I can certainly roll it back and take more screenshots if you need them.

Please note that, if you delete the iocage datasets, when you reboot they will be recreated

#2 Updated by Bonnie Follweiler about 1 year ago

  • Seen in changed from TrueNAS 11.1-U1 to 11.1

#3 Updated by Bonnie Follweiler about 1 year ago

  • Assignee changed from Kris Moore to Brandon Schneider

#4 Updated by Brandon Schneider about 1 year ago

  • Status changed from Unscreened to Closed: Behaves correctly

iocage recreates any missing datasets. Since we enabled it at boot a couple days ago, it creates datasets :)

This is intended and necessary.

#5 Avatar?id=14398&size=24x24 Updated by Kris Moore about 1 year ago

Do you want it creating datasets on first boot or before user has activated?

#6 Updated by Dru Lavigne about 1 year ago

  • Status changed from Closed: Behaves correctly to 46

#7 Updated by William Grzybowski about 1 year ago

It cannot create datasets if the user currently has no jails setup.

#8 Avatar?id=14398&size=24x24 Updated by Kris Moore about 1 year ago

  • Priority changed from No priority to Expected
  • Target version set to 11.1

Brandon, afraid I'm going to have to re-open this. Its too big of a WTF to see datasets get randomly made when no jails have been requested (yet). Plus the potential for dataset spam on a zpool we didn't want it on. Can you please add the check we discussed so it doesn't do the dataset creation if running in startup / stop mode of rc.d

#9 Updated by Bonnie Follweiler about 1 year ago

13321
13322
13323
13324

William Grzybowski wrote:

It cannot create datasets if the user currently has no jails setup.

When I reported the bug it was, and it still is, in FreeNAS-11.1-INTERNAL4, creating the iocage dataset (and subdatasets). My system had no jails and it created the iocage datasets during/after a reboot from the gui anyway. (screenshots provided)

#10 Updated by Bonnie Follweiler about 1 year ago

13326

I don't know if this helps, but I just noticed that after I delete the created iocage datasets. I wanted to set up a Periodic Snapshot Task. In the volume/dataset I have the option of choosing tank/.bhyve.containers.

#11 Updated by Bonnie Follweiler about 1 year ago

13329
13330
13331

On another VM I upgraded from FreNAS 11.1Beta1 to FreeNAS-11.1-INTERNAL4
I had no jail, and still don't. When I upgraded it created the iocage datasets
(Screenshots provided)

#12 Updated by Brandon Schneider about 1 year ago

  • Target version changed from 11.1 to 11.2-BETA1

This is the current expected behavior since you have multiple pools. iocage will automatically activate on the first zpool it sees that isn't freenas-boot (tank in this case). So this is working as designed. Since we call iocage on every boot, it will do this each time. tank will remain activated after that until a different pool (the user's choice) becomes the new target.

Kris and myself have talked about this and I'll try to skip this process in the rc of iocage. But this won't be in 11.1.

Also the old UI screenshots you supplied is warden, that would never show iocage jails.

#13 Updated by William Grzybowski about 1 year ago

Imagine how many people are not running jails and will see iocage datasets. Worse, they will delete datasets and they will come back after reboot.

I know we talked about it already but can we try to make it into 11.1 using a workaround? I believe this to be an important bug and will generate quite a few tickets.

#14 Avatar?id=14398&size=24x24 Updated by Kris Moore about 1 year ago

  • Priority changed from Expected to Blocks Until Resolved
  • Target version changed from 11.2-BETA1 to 11.1

Brandon,

This is going to need to be fixed in 11.1,otherwise I'll need to revert the iocage_enable stuff. Right now having it create datasets on a random pool is too big of a "huh?" operation for users.

#15 Avatar?id=14398&size=24x24 Updated by Kris Moore about 1 year ago

  • Status changed from 46 to Unscreened

#17 Updated by Dru Lavigne about 1 year ago

  • File deleted (debug-bonniemini-20171205073815.tgz)

#18 Updated by Dru Lavigne about 1 year ago

  • Subject changed from Reboot after upgrade installd iocage datasets even though I have no jails to Don't create iocage datasets if no jails exist
  • Status changed from Ready For Release to Needs Developer Review
  • Assignee changed from Brandon Schneider to Kris Moore

#19 Updated by Dru Lavigne about 1 year ago

  • Private changed from Yes to No

#20 Avatar?id=14398&size=24x24 Updated by Kris Moore about 1 year ago

  • Status changed from Needs Developer Review to Ready For Release

Reviewed and its already merged in

#21 Updated by Joe Maloney 12 months ago

  • Needs QA changed from Yes to No
  • QA Status Test Passes FreeNAS added
  • QA Status deleted (Not Tested)

#22 Updated by Dru Lavigne 12 months ago

  • Status changed from Ready For Release to Resolved

Also available in: Atom PDF