Project

General

Profile

Bug #27019

Launching a VM crashes the (legacy) Web-GUI

Added by Mac Lemon almost 2 years ago. Updated almost 2 years ago.

Status:
Closed: Duplicate
Priority:
No priority
Assignee:
Release Council
Category:
GUI (new)
Target version:
Seen in:
Severity:
New
Reason for Closing:
Reason for Blocked:
Needs QA:
Yes
Needs Doc:
Yes
Needs Merging:
Yes
Needs Automation:
No
Support Suite Ticket:
n/a
Hardware Configuration:

Motherboard: SUPERMICRO A1SAM-2750F (Atom C2758)
HBA: IBM ServeRAID M1015 (Crossflashed to LSI 9211-8i in IT mode)
4x8GB DDR3 1333 1.35V ECC UDIMM
Pool: 6x4TB HGST as RAIDZ2.

ChangeLog Required:
No

Description

Summary: Launching a VM crashes the legacy Web-GUI.

Steps to reproduce:

Create a zvol to contain the VM storage.

Go to storage, select appropriate dataset, click [create zvol].
Name it VMTEST, 10GiB, Tick Sparse Volume,
Blocksize: 4k
Click [add zvol]

Create the VM

Click [Add VM]
Name it TEST
Select 2 CPUs
Select 4096MB RAM
Set Boot Method to UEFI
Do not tick autostart
Click [Create VM]

Add Disk to VM

Select TEST VM
Click [DEVICES]
Already comes with VNC and A NIC.
Click [Add device]
Select TEST from the VM menu
Select Disk from the Type menu
Select the VMTEST zvol from the ZVol menu
Select AHCI from the Mode menu

Add CD-ROM to VM

Click [Add Device]
Select TEST from the VM menu
Select CD-ROM from the Type menu
CD-ROM (ISO): Select an ISO image to use as install media. (eg. Ubuntu Server [sic]; Actually doesn't matter if it's Ubuntu, FreeBSD, OpenBSD or any other OS.)
Click [OK]

Start the VM.

Go to VMs Tab again
Select eh newly created TEST VM.
Click [Start]
Confirm by clickoing [YES]

Web GUI reloads.
Brief notification that the VM has been started is shown at the top of the page.
In the list of available VMs TEST shows State RUNNING.

VNC is not able to connect on port 5903. (Tested with Apple ScreenSharing.app and Jolly's Fast VNC 1.5.4 on macOS 10.12.6 Sierra. Jolly's Fast VNC is usually able to connect to bhyve VMs after the host has been restarted completely.)
sockstat on host shows bhyve to be listening on *:5903.

Restart the VM

Click [STOP VM]
Click [START VM]
Notification that the VM started is shown again.

Firefox shows warning that a JavaScript is now slowing down the browser, asks if I want to wait or kill it. I click [Wait]

Firefox now hardly reacts to any clicks anymore.
Even when clicking [kill it] in the JS warning that comes again.
Firefox is now beachballing.

Eventually Firefox crashes (losing all windows, tabs, history in the process). (Somebody elses problem, I know, still annoying and (somewhat) unexpected.)

After relaunching Firefox new connections to the Web GUI now error with a 502 presented by nginx.

On the host:

In /var/log/messages I can find these:

Dec 4 19:52:38 mcp kernel: sonewconn: pcb 0xfffff80028cb41d0: Listen queue overflow: 151 already in queue awaiting acceptance (1002 occurrences)
Dec 4 19:52:40 mcp root: /usr/sbin/service: WARNING: $growfs_enable is not set properly - see rc.conf(5).
Dec 4 19:52:40 mcp root: /usr/sbin/service: WARNING: $ is not set properly - see rc.conf(5).
Dec 4 19:52:40 mcp root: /usr/sbin/service: WARNING: $vmware_guest__enable is not set properly - see rc.conf(5).
Dec 4 19:52:40 mcp root: /usr/sbin/service: WARNING: $vboxnet_enable is not set properly - see rc.conf(5).
Dec 4 19:52:40 mcp root: /usr/sbin/service: WARNING: $tpmd_enable is not set properly - see rc.conf(5).
Dec 4 19:52:40 mcp root: /usr/sbin/service: WARNING: $tcsd_enable is not set properly - see rc.conf(5).
Dec 4 19:52:41 mcp root: /usr/sbin/service: WARNING: $vm_enable is not set properly - see rc.conf(5).
Dec 4 19:52:41 mcp root: /usr/sbin/service: WARNING: $stunnel_enable is not set properly - see rc.conf(5).
Dec 4 19:52:41 mcp root: /usr/sbin/service: WARNING: $uuidd_enable is not set properly - see rc.conf(5).
Dec 4 19:52:41 mcp root: /usr/sbin/service: WARNING: $ipfs_go_enable is not set properly - see rc.conf(5).
Dec 4 19:52:41 mcp root: /usr/sbin/service: WARNING: $nut_enable is not set properly - see rc.conf(5).
Dec 4 19:52:41 mcp root: /usr/sbin/service: WARNING: $nut_upslog_enable is not set properly - see rc.conf(5).
Dec 4 19:52:41 mcp root: /usr/sbin/service: WARNING: $nut_upsmon_enable is not set properly - see rc.conf(5).
Dec 4 19:52:41 mcp root: /usr/sbin/service: WARNING: $zerotier_enable is not set properly - see rc.conf(5).
Dec 4 19:52:41 mcp root: /usr/sbin/service: WARNING: $vault_enable is not set properly - see rc.conf(5).
Dec 4 19:52:41 mcp root: /usr/sbin/service: WARNING: $uwsgi_enable is not set properly - see rc.conf(5).
Dec 4 19:52:41 mcp root: /usr/sbin/service: WARNING: $snmptrapd_enable is not set properly - see rc.conf(5).
Dec 4 19:52:41 mcp root: /usr/sbin/service: WARNING: $rrdcached_enable is not set properly - see rc.conf(5).
Dec 4 19:52:41 mcp root: /usr/sbin/service: WARNING: $openvpn_enable is not set properly - see rc.conf(5).
Dec 4 19:52:41 mcp root: /usr/sbin/service: WARNING: $nomad_enable is not set properly - see rc.conf(5).
Dec 4 19:52:41 mcp root: /usr/sbin/service: WARNING: $netdata_enable is not set properly - see rc.conf(5).
Dec 4 19:52:41 mcp root: /usr/sbin/service: WARNING: $mdnsresponderposix_enable is not set properly - see rc.conf(5).
Dec 4 19:52:41 mcp root: /usr/sbin/service: WARNING: $kpropd_enable is not set properly - see rc.conf(5).
Dec 4 19:52:41 mcp root: /usr/sbin/service: WARNING: $iohyve_enable is not set properly - see rc.conf(5).
Dec 4 19:52:41 mcp root: /usr/sbin/service: WARNING: $iocage_enable is not set properly - see rc.conf(5).
Dec 4 19:52:41 mcp root: /usr/sbin/service: WARNING: $htcacheclean_enable is not set properly - see rc.conf(5).
Dec 4 19:52:41 mcp root: /usr/sbin/service: WARNING: $git_daemon_enable is not set properly - see rc.conf(5).
Dec 4 19:52:41 mcp root: /usr/sbin/service: WARNING: $django_enable is not set properly - see rc.conf(5).
Dec 4 19:52:41 mcp root: /usr/sbin/service: WARNING: $collectdmon_enable is not set properly - see rc.conf(5).
@
@Dec 4 19:54:31 mcp uwsgi: [freeadmin.tree.tree:98] Failed to get item order

Traceback (most recent call last):
File "./freenasUI/freeadmin/tree/tree.py", line 95, in __lt__
return self.gname.lower() < other.gname.lower()
AttributeError: 'int' object has no attribute 'lower'
Dec 4 19:54:31 mcp uwsgi: [freeadmin.tree.tree:98] Failed to get item order
Traceback (most recent call last):
File "./freenasUI/freeadmin/tree/tree.py", line 95, in __lt__
return self.gname.lower() < other.gname.lower()
AttributeError: 'int' object has no attribute 'lower'

Expected Results:

Starting a VM should just start the VM.

Actual Results:

The VM seems to be started but the Web-GUI crashes.

Temporary fix:

SSH into the box, and
service django restart
brings back the Web-GUI for a few moments.

I can now login to the GUI again.
The VM still cannot be connected to via VNC.
The problem with repeating tree entries still persists and after a few minutes, the GUI crashes again.

Workaround

To get back to a stable Web-GUI state I must reboot the host.

Notes

Screenshots of funny GUI misbehaviour before the browser crashes attacked for your entertainment.
I haven't tested this with the future-GUI.


Related issues

Related to FreeNAS - Bug #26990: Fix regression that prevented VNC connectionResolved2017-12-03

History

#1 Updated by Dru Lavigne almost 2 years ago

  • Status changed from Unscreened to 15

Mac: this may be fixed for 11.1. Can you test on RC3 (or on RELEASE next week) and let us know if the issue persists?

#2 Updated by Mac Lemon almost 2 years ago

Given my current time constraints, I'll check on that in FreeNAS 11.1-RELEASE and report back.

#3 Updated by George Dinolt almost 2 years ago

VNC access for Ubuntu VMs fail for me under 11.1 RC3 but work as expected under RC1. VNC access fails under both Apple VNC access and tigervnc (from MacPorts) on my iXSystems FreeNAS 2U server.

#4 Updated by Dru Lavigne almost 2 years ago

  • Related to Bug #26990: Fix regression that prevented VNC connection added

#5 Updated by Dru Lavigne almost 2 years ago

  • Status changed from 15 to Closed: Duplicate
  • Target version set to N/A

This has been fixed for 11.1.

#6 Updated by Dru Lavigne almost 2 years ago

  • File deleted (WEB-GUI-Misbehaviour_Screenshots.zip)

Also available in: Atom PDF