Project

General

Profile

Feature #27048

Umbrella #25917: Move business logic from Django to middlewared and make websocket API feature complete

Convert Services:SSH to Middlewared

Added by William Grzybowski over 1 year ago. Updated 10 months ago.

Status:
Done
Priority:
Expected
Assignee:
Vladimir Vinogradenko
Category:
Middleware
Target version:
Estimated time:
Severity:
Low Medium
Reason for Closing:
Reason for Blocked:
Needs QA:
No
Needs Doc:
No
Needs Merging:
No
Needs Automation:
Yes
Support Suite Ticket:
n/a
Hardware Configuration:

Description

Ticket to track transfer of business logic from Django/GUI to middlewared and making use of middleware client in GUI.

Associated revisions

Revision d4a61bbd (diff)
Added by Vladimir Vinogradenko about 1 year ago

SSH to Middlewared

Ticket: #27048

History

#1 Updated by Vladimir Vinogradenko over 1 year ago

  • Status changed from Unscreened to Screened

#2 Avatar?id=14398&size=24x24 Updated by Kris Moore over 1 year ago

  • Target version changed from 11.2-BETA1 to 11.3

#3 Avatar?id=14398&size=24x24 Updated by Kris Moore about 1 year ago

  • Status changed from Screened to Not Started

#4 Updated by William Grzybowski about 1 year ago

  • Target version changed from 11.3 to 11.2-RC2
  • Severity set to Low Medium

#5 Updated by Joe Maloney about 1 year ago

  • Needs Automation changed from No to Yes

#6 Updated by Joe Maloney about 1 year ago

  • Needs Automation changed from Yes to No

#7 Updated by Joe Maloney about 1 year ago

  • Needs Automation changed from No to Yes

#8 Updated by Vladimir Vinogradenko about 1 year ago

  • Status changed from Not Started to Done

#9 Updated by Dru Lavigne about 1 year ago

  • Target version changed from 11.2-RC2 to 11.2-BETA1
  • Needs QA changed from No to Yes
  • Needs Doc changed from Yes to No
  • Needs Merging changed from Yes to No

#10 Updated by Dru Lavigne 12 months ago

  • Status changed from Done to Ready for Testing

#11 Updated by Bonnie Follweiler 10 months ago

I assigned this one to Ethan Large to test

#12 Updated by Ethan Large 10 months ago

  • Status changed from Ready for Testing to Passed Testing
  • Needs QA changed from Yes to No

Using: FreeNAS-11.2-MASTER-201806130421-3db2ca8.iso

Working as intended.

#13 Updated by Dru Lavigne 10 months ago

  • Status changed from Passed Testing to Done

Also available in: Atom PDF