Project

General

Profile

Bug #27105

Network Global Configuration appears broken

Added by William Grzybowski almost 3 years ago. Updated almost 3 years ago.

Status:
Resolved
Priority:
Critical
Assignee:
Erin Clark
Category:
GUI (new)
Severity:
New
Reason for Closing:
Reason for Blocked:
Needs QA:
Yes
Needs Doc:
Yes
Needs Merging:
Yes
Needs Automation:
No
Support Suite Ticket:
n/a
Hardware Configuration:
ChangeLog Required:
No

Description

If you go to Interfaces and then try to move to another section, it will append the content at the top (screenshot added)

vendor.eac793028c167dada2aa.bundle.js:1 ERROR TypeError: Cannot read property 'then' of undefined
    at n.ngOnInit (13.326f31cb8a53bbce8f76.chunk.js:1)
    at wn (vendor.eac793028c167dada2aa.bundle.js:1)
    at pr (vendor.eac793028c167dada2aa.bundle.js:1)
    at cr (vendor.eac793028c167dada2aa.bundle.js:1)
    at Nr (vendor.eac793028c167dada2aa.bundle.js:1)
    at Object.updateDirectives (13.326f31cb8a53bbce8f76.chunk.js:1)
    at Object.updateDirectives (vendor.eac793028c167dada2aa.bundle.js:1)
    at lr (vendor.eac793028c167dada2aa.bundle.js:1)
    at xr (vendor.eac793028c167dada2aa.bundle.js:1)
    at _r (vendor.eac793028c167dada2aa.bundle.js:1)
    at lr (vendor.eac793028c167dada2aa.bundle.js:1)
    at xr (vendor.eac793028c167dada2aa.bundle.js:1)
    at vr (vendor.eac793028c167dada2aa.bundle.js:1)
    at lr (vendor.eac793028c167dada2aa.bundle.js:1)
    at xr (vendor.eac793028c167dada2aa.bundle.js:1)
    at _r (vendor.eac793028c167dada2aa.bundle.js:1)
    at lr (vendor.eac793028c167dada2aa.bundle.js:1)
    at xr (vendor.eac793028c167dada2aa.bundle.js:1)
    at vr (vendor.eac793028c167dada2aa.bundle.js:1)
    at Object.lr [as checkAndUpdateView] (vendor.eac793028c167dada2aa.bundle.js:1)
    at t.detectChanges (vendor.eac793028c167dada2aa.bundle.js:1)
    at vendor.eac793028c167dada2aa.bundle.js:1
    at Array.forEach (<anonymous>)
    at e.tick (vendor.eac793028c167dada2aa.bundle.js:1)
    at vendor.eac793028c167dada2aa.bundle.js:1
    at t.invoke (polyfills.f3d73c0bd9b08d387336.bundle.js:1)
    at Object.onInvoke (vendor.eac793028c167dada2aa.bundle.js:1)
    at t.invoke (polyfills.f3d73c0bd9b08d387336.bundle.js:1)
    at n.run (polyfills.f3d73c0bd9b08d387336.bundle.js:1)
    at t.run (vendor.eac793028c167dada2aa.bundle.js:1)
    at Object.next (vendor.eac793028c167dada2aa.bundle.js:1)
    at e.object.i [as _next] (vendor.eac793028c167dada2aa.bundle.js:1)
    at e.__tryOrUnsub (vendor.eac793028c167dada2aa.bundle.js:1)
    at e.next (vendor.eac793028c167dada2aa.bundle.js:1)
    at e._next (vendor.eac793028c167dada2aa.bundle.js:1)
    at e.next (vendor.eac793028c167dada2aa.bundle.js:1)
    at e.next (vendor.eac793028c167dada2aa.bundle.js:1)
    at e.emit (vendor.eac793028c167dada2aa.bundle.js:1)
    at it (vendor.eac793028c167dada2aa.bundle.js:1)
    at Object.onHasTask (vendor.eac793028c167dada2aa.bundle.js:1)
    at t.hasTask (polyfills.f3d73c0bd9b08d387336.bundle.js:1)
    at t._updateTaskCount (polyfills.f3d73c0bd9b08d387336.bundle.js:1)
    at n._updateTaskCount (polyfills.f3d73c0bd9b08d387336.bundle.js:1)
    at n.runTask (polyfills.f3d73c0bd9b08d387336.bundle.js:1)
    at u (polyfills.f3d73c0bd9b08d387336.bundle.js:1)
    at HTMLAnchorElement.invoke (polyfills.f3d73c0bd9b08d387336.bundle.js:1)
vI5cBmx.png (47.4 KB) vI5cBmx.png William Grzybowski, 12/08/2017 09:08 AM
13337

Associated revisions

Revision 30de444c (diff)
Added by Erin Clark almost 3 years ago

Tooltip service appears to be broken and unused so removing it from global configuration since it is breaking this page Ticket: #27105

History

#1 Updated by Dru Lavigne almost 3 years ago

  • Status changed from Untriaged to Unscreened
  • Assignee changed from Release Council to Erin Clark

Erin: please load balance.

#2 Updated by Dru Lavigne almost 3 years ago

  • Target version set to 11.2-BETA1

#3 Updated by Erin Clark almost 3 years ago

You didn't by chance click on global configuration after interfaces did you? I can't reproduce the bug simply from going from interfaces to something else but going from interfaces to global configuration seems to exhibit this kind of behavior. I'll look into global configuration and see what is up

#4 Updated by William Grzybowski almost 3 years ago

Erin Clark wrote:

You didn't by chance click on global configuration after interfaces did you? I can't reproduce the bug simply from going from interfaces to something else but going from interfaces to global configuration seems to exhibit this kind of behavior. I'll look into global configuration and see what is up

That may be right, I dont call exactly where now, I just know it was under Network.

#5 Updated by Erin Clark almost 3 years ago

  • Subject changed from Broken navigation after going to Interfaces to Network Global Configuration appears broken
  • Status changed from Unscreened to Needs Developer Review
  • Assignee changed from Erin Clark to Lola Yang
  • Priority changed from No priority to Critical

#6 Updated by Lola Yang almost 3 years ago

  • Status changed from Needs Developer Review to Reviewed by Developer
  • Assignee changed from Lola Yang to Erin Clark

LGTM

#7 Updated by Dru Lavigne almost 3 years ago

  • Status changed from Reviewed by Developer to Resolved
  • Target version changed from 11.2-BETA1 to Master - FreeNAS Nightlies

Also available in: Atom PDF