Project

General

Profile

Bug #27229

Manual disk replacement with spare throws traceback

Added by Michael Dexter over 3 years ago. Updated over 3 years ago.

Status:
Closed
Priority:
Expected
Assignee:
Waqar Ahmed
Category:
Middleware
Target version:
Seen in:
Severity:
Reason for Closing:
Duplicate
Reason for Blocked:
Needs QA:
Yes
Needs Doc:
Yes
Needs Merging:
Yes
Needs Automation:
No
Support Suite Ticket:
n/a
Hardware Configuration:
ChangeLog Required:
No

Description

Possibly a duplicate. Couldn't find it.

Sequence: Select one of two disks in a two-disk mirror pool that has a spare disk available.
Select the active spare for "Replace(ment)"
Check "Force: Disk is not clear, partitions or ZFS labels were found"
Click: "Replace Disk" as per attached screen shot.

POST
Request URL: http://10.0.0.185/storage/zpool-test/disk/replace/gptid/2083b6d0-e08e-11e7-9537-3860775656f5/
Software Version: FreeNAS-11.1-RELEASE (dc7d195f4)
Exception Type: MiddlewareError
Exception Value:
[MiddlewareError: Unable to GPT format the disk "da3": gpart: geom 'da3': File exists
]
Exception Location: ./freenasUI/middleware/notifier.py in __gpt_labeldisk, line 359
Server time: Wed, 13 Dec 2017 21:18:29 -0800

Request information

GET

No GET data
POST

Variable Value
all ''
force 'on'
replace_disk 'da3'
__form_id 'form_ZFSDiskReplacementForm'
FILES

No FILES data
COOKIES

Variable Value
csrftoken 'Ro7udIgpLokZSk1A2X3gaa0lK8Y0kfr3rQzp2ShBZw9fRw0j9GJonO4T5O5Ga5qt'
fntreeSaveStateCookie 'root'
sessionid 'vzubtw4cgdqx5psljtfgqasupb2agd9m'
META

Variable Value

Bonus, the "Volume Status" thought bubble is STILL visible in the top level corner after getting Volume Status under Volumes. "Not to be fixed" yet preventing the use of full-motion videos in training.

SpareCarnage.jpg (237 KB) SpareCarnage.jpg Michael Dexter, 12/13/2017 09:27 PM
13367

Related issues

Is duplicate of FreeNAS - Bug #26659: Ensure that disks attached to a pool are not available for use as a spareDone

History

#1 Updated by Dru Lavigne over 3 years ago

  • Status changed from Unscreened to 15
  • Assignee changed from Release Council to William Grzybowski
  • Priority changed from No priority to Expected
  • Target version set to 11.1-U1

Michael: please attach a debug created after the replacement fails.

#2 Updated by Michael Dexter over 3 years ago

  • File debug-freenas-20171214112828.tgz added

Attaching Debug. Nothing sensitive in it. Test machine.

Taken while the traceback is still on screen in another browser tab.

#3 Updated by Dru Lavigne over 3 years ago

  • Private changed from No to Yes

#4 Updated by William Grzybowski over 3 years ago

  • Status changed from 15 to Screened

#5 Avatar?id=14398&size=24x24 Updated by Kris Moore over 3 years ago

  • Target version changed from 11.1-U1 to 11.2-BETA1

#6 Updated by Dru Lavigne over 3 years ago

  • Status changed from Screened to Not Started

#7 Avatar?id=13649&size=24x24 Updated by Ben Gadd over 3 years ago

  • Due date set to 03/09/2018

#8 Updated by William Grzybowski over 3 years ago

  • Category changed from GUI (new) to Middleware

#9 Updated by William Grzybowski over 3 years ago

  • Assignee changed from William Grzybowski to Waqar Ahmed

Waqar, can you check if it was fixed in the last PR you made about spares?

#10 Updated by Waqar Ahmed over 3 years ago

Sure, will update this accordingly then

#11 Updated by Waqar Ahmed over 3 years ago

  • Status changed from Not Started to In Progress

#12 Updated by Waqar Ahmed over 3 years ago

  • Status changed from In Progress to Closed
  • Reason for Closing set to Duplicate

Duplicate of #Ticket: 26659

PR ( 26659 ) -- https://github.com/freenas/freenas/pull/955

#13 Updated by Dru Lavigne over 3 years ago

  • Is duplicate of Bug #26659: Ensure that disks attached to a pool are not available for use as a spare added

#14 Updated by Dru Lavigne over 3 years ago

  • File deleted (debug-freenas-20171214112828.tgz)

#15 Updated by Dru Lavigne over 3 years ago

  • Target version changed from 11.2-BETA1 to N/A
  • Private changed from Yes to No

Also available in: Atom PDF