Project

General

Profile

Bug #27249

Can't sign in to beta UI but can sign in to the legacy UI

Added by Samantha Bonham over 1 year ago. Updated over 1 year ago.

Status:
Closed: Duplicate
Priority:
Expected
Assignee:
William Grzybowski
Category:
GUI (new)
Severity:
New
Reason for Closing:
Reason for Blocked:
Needs QA:
Yes
Needs Doc:
Yes
Needs Merging:
Yes
Needs Automation:
No
Support Suite Ticket:
n/a
Hardware Configuration:
ChangeLog Required:
No

Description

Hi,

I updated to today's iso [FreeNAS-11-MASTER-201712140629-9a615e6.iso ] from yesterday's iso and ran into an issue signing in. I can sign in to the legacy UI but I can't sign in to the beta UI.

This is what shows up under System -> General

Request Method: GET
Request URL: http://192.168.1.113/legacy/system/info/?dojo.preventCache=1513274903457
Software Version: FreeNAS-11-MASTER-201712140629 (9a615e6)
Exception Type: ConnectionRefusedError
Exception Value:
[Errno 61] Connection refused
Exception Location: /usr/local/lib/python3.6/site-packages/ws4py/client/__init__.py in connect, line 209
Server time: Thu, 14 Dec 2017 10:08:23 -0800

Traceback
Environment:

Software Version: FreeNAS-11-MASTER-201712140629 (9a615e6)
Request Method: GET
Request URL: http://192.168.1.113/legacy/system/info/?dojo.preventCache=1513274903457

Traceback:
File "/usr/local/lib/python3.6/site-packages/django/core/handlers/exception.py" in inner
42. response = get_response(request)
File "/usr/local/lib/python3.6/site-packages/django/core/handlers/base.py" in legacy_get_response
249. response = self._get_response(request)
File "/usr/local/lib/python3.6/site-packages/django/core/handlers/base.py" in _get_response
178. response = middleware_method(request, callback, callback_args, callback_kwargs)
File "./freenasUI/freeadmin/middleware.py" in process_view
162. return login_required(view_func)(request, *view_args, **view_kwargs)
File "/usr/local/lib/python3.6/site-packages/django/contrib/auth/decorators.py" in _wrapped_view
23. return view_func(request, *args, **kwargs)
File "./freenasUI/system/views.py" in system_info
109. with client as c:
File "./freenasUI/middleware/client.py" in enter
7. self.client = Client()
File "/usr/local/lib/python3.6/site-packages/middlewared/client/client.py" in init
268. self._ws.connect()
File "/usr/local/lib/python3.6/site-packages/middlewared/client/client.py" in connect
159. rv = super(WSClient, self).connect()
File "/usr/local/lib/python3.6/site-packages/ws4py/client/
_init__.py" in connect
209. self.sock.connect(self.bind_addr)

Exception Type: ConnectionRefusedError at /legacy/system/info/
Exception Value: [Errno 61] Connection refused


Related issues

Is duplicate of FreeNAS - Bug #27253: Update iocage Makefile with required dependencyResolved2017-12-14

History

#1 Updated by Dru Lavigne over 1 year ago

  • Status changed from Untriaged to Unscreened
  • Assignee changed from Release Council to Erin Clark
  • Priority changed from No priority to Expected
  • Target version set to Master - FreeNAS Nightlies

Erin: this prevents the doc team for working on tooltips. Note that login worked yesterday but failed after today's install/upgrade.

#2 Updated by Erin Clark over 1 year ago

  • Status changed from Unscreened to Screened

#3 Updated by Erin Clark over 1 year ago

It appears to not be connecting to the websocket, I will investigate

#4 Updated by Erin Clark over 1 year ago

Doc team, go ahead and use yesterday's nightly for now, we will test the code before bringing it in to make sure it works with current versions when we pull the PR in

#5 Updated by Erin Clark over 1 year ago

  • Assignee changed from Erin Clark to William Grzybowski

William, I can't find any reason that the GUI would not login other than the fact that websockets aren't connecting, I also notice that system info and some other things in the old GUI like vms (things that use websocket?) aren't working properly either (I can't even activate the old boot environment to go back from the old ui). Did something happen on the middleware side?

#6 Updated by William Grzybowski over 1 year ago

  • Status changed from Screened to Closed: Duplicate

Yes, middleware is broken on latest nightly.

#7 Updated by William Grzybowski over 1 year ago

  • Is duplicate of Bug #27253: Update iocage Makefile with required dependency added

Also available in: Atom PDF