Project

General

Profile

Bug #27432

bsdloader fails on Dell R730xd in UEFI mode

Added by Greg DePasse almost 2 years ago. Updated 8 months ago.

Status:
Closed
Priority:
Nice to have
Assignee:
Ryan Moeller
Category:
OS
Target version:
Seen in:
Severity:
Medium
Reason for Closing:
Duplicate Issue
Reason for Blocked:
Needs QA:
Yes
Needs Doc:
Yes
Needs Merging:
No
Needs Automation:
No
Support Suite Ticket:
n/a
Hardware Configuration:

Dell R730xd with a PERC H730 mini.
BIOS 2.6.0

ChangeLog Required:
No

Description

Somewhat related to https://redmine.ixsystems.com/issues/25405, which appears to be resolved in that case, but not for me.

In UEFI mode I get error #1.
In BIOS mode I get error #2.

2-freenas 11-1 dell r73xd-BIOS.jpg (79.5 KB) 2-freenas 11-1 dell r73xd-BIOS.jpg Greg DePasse, 12/26/2017 01:48 PM
1-freenas 11-1 dell r73xd-UEFI.jpg (47.5 KB) 1-freenas 11-1 dell r73xd-UEFI.jpg Greg DePasse, 12/26/2017 01:48 PM
freenas1.jpg (44.8 KB) freenas1.jpg Greg DePasse, 02/06/2018 03:44 PM
Capture-11.2-20180507.PNG (31.2 KB) Capture-11.2-20180507.PNG Greg DePasse, 05/08/2018 11:28 AM
Capture-freenas boot bug-bios-2.6.0.PNG (70.7 KB) Capture-freenas boot bug-bios-2.6.0.PNG Greg DePasse, 08/31/2018 09:08 AM
Capture-freenas boot bug-bios-2.8.0.PNG (50.6 KB) Capture-freenas boot bug-bios-2.8.0.PNG Greg DePasse, 08/31/2018 09:08 AM
13599
13600
14273
17304
27839
27850

Related issues

Is duplicate of FreeNAS - Bug #65994: Merge in FreeBSD boot loader fixesReady for Testing

History

#1 Avatar?id=14398&size=24x24 Updated by Kris Moore almost 2 years ago

  • Assignee changed from Release Council to Benno Rice
  • Priority changed from No priority to Nice to have
  • Target version set to 11.3

#2 Updated by Benno Rice almost 2 years ago

Have you tried installing vanilla FreeBSD 11.1 on this system? If so, do you get the same panics?

Also are you willing to let us take a look at this system remotely? We don't have any of these systems available internally so we won't be able to properly investigate this otherwise.

#3 Updated by Dru Lavigne almost 2 years ago

  • Status changed from Unscreened to 15

#4 Updated by Dru Lavigne almost 2 years ago

  • Status changed from 15 to Closed: Insufficient Info
  • Target version changed from 11.3 to N/A

#5 Updated by Greg DePasse almost 2 years ago

Hi there. Sorry for the delay. My lab schedule was tough. Yes, I was able to get FreeBSD 11.1 installed using the default UEFI boot.

I can support a remote troubleshooting session if you've like.

I should clarify that this is booting from the installer and this is what appears right after the GNU Grub boot otion screen to install.

#6 Updated by Dru Lavigne almost 2 years ago

  • Status changed from Closed: Insufficient Info to Closed

#7 Updated by Dru Lavigne almost 2 years ago

  • Status changed from Closed to Not Started
  • Target version changed from N/A to 11.1-U2

#8 Updated by Greg DePasse almost 2 years ago

I noticed another user is having the same boot error issue with a different set of HW:
https://forums.freenas.org/index.php?threads/help-installation-failures-installer-panic-immediately-after-boot.60991/
"I've recently acquired some new server hardware to host my freenas setup - a Lenovo x3650 M5 Machine Type 5462
Its specs are:
CPU : E5 2603 v4 (6C/6T)
RAM : 8GB ECC
HBA/RAID: IBM ServeRaid M1215 Flashed to IT Mode (No Drives currently connected)
Firmware: Latest"

#9 Avatar?id=13649&size=24x24 Updated by Ben Gadd almost 2 years ago

  • Due date set to 02/12/2018

Due date updated to reflect the code freeze for 11.1U2.

#10 Avatar?id=13649&size=24x24 Updated by Ben Gadd almost 2 years ago

  • Severity set to New

#11 Avatar?id=13649&size=24x24 Updated by Ben Gadd almost 2 years ago

  • Target version changed from 11.1-U2 to 11.2-RC2

#12 Updated by Greg DePasse almost 2 years ago

LMK if you need any info from my system to troubleshoot.

#13 Updated by Benno Rice almost 2 years ago

Could you try booting this image under UEFI, either as a CD or as a USB image?

http://people.freebsd.org/~benno/freebsd-hybrid-bootonly.iso

If it works then I think FreeNAS 11.2 will work better for you.

The problem you're seeing, under UEFI at least, is that GRUB isn't handling off to the kernel in the right way. Newer versions of FreeNAS switch back to using FreeBSD's loader but we still need to remove GRUB from the install media. If that image works for you then that'll help us get the FreeBSD-loader-based install media working.

Thanks!

#14 Updated by Greg DePasse almost 2 years ago

Benno Rice wrote:

Could you try booting this image under UEFI, either as a CD or as a USB image?

I get error 404 when trying that link.

#15 Updated by Benno Rice almost 2 years ago

#16 Updated by Greg DePasse almost 2 years ago

I was able to download and extract. Are you sure it's bootable?

If I mount the ISO remotely using iDRAC, I get no bootable media error message.

If I write it to a USB using Rufus (and dd option), I get no bootable device found.

#17 Updated by Benno Rice almost 2 years ago

It's an experimental hybrid image I'm working on. It's worked in a bunch of situations but, well, still experimental.

#18 Updated by Greg DePasse almost 2 years ago

14273

Here's what I get when I tell iDRAC to boot the remote ISO (I don't even see the device in the UEFI menu if I use a USB).

#19 Updated by Benno Rice almost 2 years ago

Oh hang on, that image is compressed. Did you decompress it? I've also put a decompressed version here if that's easier:

http://people.freebsd.org/~benno/freebsd-hybrid-bootonly.iso

#20 Updated by Greg DePasse almost 2 years ago

I used 7-zip on the original to get the .ISO. I was able to burn the ISO to a usb using Rufus.

I just tried the straight ISO image you just posted with the same results.

#21 Avatar?id=13649&size=24x24 Updated by Ben Gadd almost 2 years ago

  • Due date deleted (02/12/2018)

#22 Updated by Greg DePasse over 1 year ago

  • Subject changed from Fresh install of 11.1 on Dell R730xd crashes at boot to Fresh install attempt of 11.1 on Dell R730xd crashes at boot

Any updates on this?

#23 Updated by Greg DePasse over 1 year ago

I'm still unable to install using 11.1_U2. I get the same panic.

#24 Updated by Greg DePasse over 1 year ago

Any progress?

To recap:
11.1-u4 ISO won't boot in UEFI
11.1-u4 ISO will boot and install in BIOS
9.10.2-u6 ISO won't boot in UEFI

FreeBSD 11.1 will boot and install in UEFI

I'm able to get the Grub boot menu in both the UEFI and BIOS modes. I've noticed that the UEFI mode looks different (more ascii text like - see the lines in the attached grub.jpg) When I choose to install in UEFI, I get the 1-FreeNAS 11-1 dell r73xd-UEFI.jpg error immediately.

I would really like to use UEFI, because I'm running into issues with BIOS mode and virtual machines (can only use VNC in UEFI).

#25 Updated by Benno Rice over 1 year ago

Hi, could you try this image? This replaces GRUB with the FreeBSD loader. You don't have to install it if you don't want to run the nightly but if this fixes things for you then 11.2 should be a good release for you to try.

https://download.freenas.org/11.2/MASTER/201805070407/x64/FreeNAS-11.2-MASTER-201805070407-0b8821f-NOGRUB.iso

Thanks!

#26 Updated by Greg DePasse over 1 year ago

17304

I wasn't able to boot that in UEFI mode. See attached screencapture.

I was able to boot that in BIOS though (but couldn't actually install to da0 or da1)

#27 Updated by Rob Hutton over 1 year ago

I have the same issue. I'll be happy to work with someone on it, because I need to get this machine converted to FreeNAS.

#28 Updated by Rob Hutton over 1 year ago

Current Nightly gives me:

Greg DePasse wrote:

I wasn't able to boot that in UEFI mode. See attached screencapture.

I was able to boot that in BIOS though (but couldn't actually install to da0 or da1)

I get the same thing with the latest nightly as of 5/29

#29 Updated by Matthew Rabjones over 1 year ago

I too have the same issue on a Lenovo x3650 M5. Would be very interested in getting this fixed. Haven't tested nightlies for about a month so will do that when i get a chance.

#30 Updated by Dru Lavigne over 1 year ago

  • Assignee changed from Benno Rice to Alexander Motin

#31 Avatar?id=13649&size=24x24 Updated by Ben Gadd over 1 year ago

  • Target version changed from 11.2-RC2 to Backlog

#32 Updated by Alexander Motin over 1 year ago

  • Severity changed from New to Medium

#33 Updated by Alexander Motin over 1 year ago

  • Subject changed from Fresh install attempt of 11.1 on Dell R730xd crashes at boot to bsdloader fails on Dell R730xd in UEFI mode

#34 Updated by Alexander Motin over 1 year ago

  • Assignee changed from Alexander Motin to Ryan Moeller

#35 Updated by Ryan Moeller about 1 year ago

  • Status changed from Not Started to Blocked
  • Reason for Blocked set to Waiting for feedback

I'm interested to know if the problem was fixed by the updates to boot code that have occurred in the past few months. Can someone with one of these systems test this nightly build?
https://download.freenas.org/11.2/MASTER/201808220903/x64/FreeNAS-11.2-MASTER-201808220903-2ffe99d.iso

It also may be worth trying the latest UEFI firmware version in the Dell system, I saw the changelog for version 2.8.0 mentions a fix for an MTRR bug that may have been related (though I am somewhat skeptical since this same bug affects systems from other vendors).

#36 Updated by Matthew Rabjones about 1 year ago

Hello,

I'll be able to test this on my x3650 m5 tomorrow morning. (I dont have physical access to that machine today). I'll also do a firmware update on that machine to ensure it is the latest version - maybe there is a similar fix as you mentioned for the r730 since they are the same platform processor. Will get back to you then.

#37 Updated by Matthew Rabjones about 1 year ago

Update:

It took me ages to get my server to even detect the usb as bootable (tried several tools, got it to work finally with rufus in dd mode with the latest build). Never got the installer to work in UEFI only mode - kept saying that the device was invalid or something (didnt think to screenshot that). when booting in legacy mode i was able to get to the installer, however then i decided to update firmware and haven't been able to get it to detect the installer again since (UEFI or Legacy). will get back to you when i have more info to report since this issue was occurring after install.

#38 Updated by Greg DePasse about 1 year ago

27839
27850

I just tested the version linked a week ago and I have the same failures.

I tried with both BIOS version 2.6.0 and 2.8.0.

#39 Updated by Ryan Moeller about 1 year ago

  • Status changed from Blocked to Screened
  • Reason for Blocked deleted (Waiting for feedback)

Greg DePasse wrote:

I just tested the version linked a week ago and I have the same failures.

The screenshots show you booted from the virtual CDROM, did you try USB as well?

#40 Updated by Matthew Rabjones about 1 year ago

In response to my issue: I was able to boot the installer (usb) using legacy mode. I installed the OS in UEFI mode (successfully) to a second internal USB. I was then able to boot Freenas Successfully once the server had been set to UEFI mode.

#41 Updated by Greg DePasse about 1 year ago

Ryan Moeller wrote:

Greg DePasse wrote:

I just tested the version linked a week ago and I have the same failures.

The screenshots show you booted from the virtual CDROM, did you try USB as well?

No I didn't but I can try next week. I've had better luck using iDRAC to remotely mount ISOs and perform OS installs though.

#42 Updated by Greg DePasse about 1 year ago

I used Rufus to burn the ISO to a reliable USB stick that I've used in the past. When booting the server and selecting that USB, there wasn't anything bootable on it.

#43 Updated by Cpu Roast about 1 year ago

Here's a thought, when you are writing the ISO via Rufus are you using DD mode or ISO mode?
If you are using ISO mode, under partition scheme, make sure you pick GPT and not MBR as UEFI requires GPT.

Your Target system would be UEFI (Non CSM)
File System should be FAT32 or Large FAT32.

For FreeNAS-11.2-BETA2.iso, Rufus insists on using DD as it doesn't understand it's boot format.
For FreeNAS-11.1-U6.iso, Rufus 2.x allowed you to pick GPT, Rufus 3.x no-longer does.

Try https://rufus.akeo.ie/downloads/rufus-2.18p.exe and pick GPT as well as FAT32 or Large FAT32 in ISO mode and see if it helps.

But yeah booting the iso from virtual media over the DRAC should always work and should expose 2 boot options, Boot Legacy CSM and Boot UEFI.
The previous versions of FreeNAS only supported Legacy CSM boot.

Another thought, what about Secure Boot, does FreeBSD and therefore FreeNAS support Secure Boot yet? If not, it should be disabled in the UEFI config.

#44 Updated by Ryan Moeller about 1 year ago

With Rufus I recommend using only DD mode for our installer images.

For reference:
http://doc.freenas.org/11.2/install.html#on-windows

#45 Updated by Cpu Roast about 1 year ago

Yeah DD mode makes the most sense for FreeNAS, Rufus doesn't quite understand the installer structure, like it does with your average Linux ISO, so why allow it to mangle the installer.

#46 Updated by Rob Hutton about 1 year ago

Ryan Moeller wrote:

Greg DePasse wrote:

I just tested the version linked a week ago and I have the same failures.

The screenshots show you booted from the virtual CDROM, did you try USB as well?

Just tried both Virtual CDROM and writing USB with Beta2 using etcher and rufus, and I still have the same problem. I updated the firmware before trying, so it is the latest firmware from Dell.

#47 Updated by Rob Hutton about 1 year ago

Burned Beta3 to a DVD today. BIOS mode will boot, but immediately back to the USB timeouts. UEFI mode results in the "Can't find device by handle" message again.

#48 Updated by Rob Hutton about 1 year ago

Is there anything any of us can do to help move this along?

#49 Updated by Ryan Moeller about 1 year ago

Rob Hutton wrote:

Burned Beta3 to a DVD today. BIOS mode will boot, but immediately back to the USB timeouts. UEFI mode results in the "Can't find device by handle" message again.

USB timeouts?

#50 Updated by Ryan Moeller 10 months ago

  • Status changed from Screened to Blocked
  • Reason for Blocked set to Need verification

Rob have you tried the 11.2 release?

#51 Updated by Ryan Moeller 9 months ago

  • Status changed from Blocked to Closed
  • Target version changed from Backlog to N/A
  • Reason for Closing set to Cannot Reproduce
  • Reason for Blocked deleted (Need verification)

I do not possess the hardware to reproduce the issue at this time, and with no response there is not much else I can do.

#52 Updated by Greg DePasse 9 months ago

I tried 11.1 and had the same issue, but haven't tried 11.2 (sorry I missed your last note). I can try it this weekend when I get back from the road.

I can also get you remote access to a server if you'd like.

#53 Updated by Ryan Moeller 9 months ago

  • Status changed from Closed to Blocked
  • Reason for Closing deleted (Cannot Reproduce)
  • Reason for Blocked set to Need verification

Sorry Greg, I guess I lost track of who was having what issue.

Please try FreeNAS 11.2 and let me know how it goes.

#54 Updated by Ryan Moeller 9 months ago

  • Target version changed from N/A to Backlog
  • Reason for Blocked changed from Need verification to Waiting for feedback

There has been significant work to the bootloader merged into our freenas/11-stable branch. If someone would like to test a build:
https://download.freenas.org/11.3/MASTER/201902231007/x64/FreeNAS-11.3-MASTER-201902231007-e132e27.iso

#55 Updated by Ryan Moeller 8 months ago

  • Is duplicate of Bug #65994: Merge in FreeBSD boot loader fixes added

#56 Updated by Ryan Moeller 8 months ago

  • Status changed from Blocked to Closed
  • Target version changed from Backlog to N/A
  • Reason for Closing set to Duplicate Issue
  • Reason for Blocked deleted (Waiting for feedback)
  • Needs Merging changed from Yes to No

I suspect this issue will be resolved by the boot loader fixes merged for the other ticket. If not please do let us know.

Also available in: Atom PDF