Project

General

Profile

Bug #27458

Lost swapfile after update to 11.1

Added by AndrX AndrX almost 2 years ago. Updated almost 2 years ago.

Status:
Closed: Insufficient Info
Priority:
No priority
Assignee:
William Grzybowski
Category:
Middleware
Target version:
Seen in:
Severity:
New
Reason for Closing:
Reason for Blocked:
Needs QA:
Yes
Needs Doc:
Yes
Needs Merging:
Yes
Needs Automation:
No
Support Suite Ticket:
n/a
Hardware Configuration:
ChangeLog Required:
No

Description

After update server freenas from 11.0-U4 to 11.1 I have problem to swap file. He is lost.
On server 11.0-U4 swap file have size 4Gb and use 600-700Mb.
After update swap trend is empty.
But advanced option is set swap file is 4Gb

Command TOP look like this:

last pid: 28164; load averages: 0.45, 0.64, 0.73 up 0+02:52:49 21:16:45
62 processes: 1 running, 60 sleeping, 1 zombie

Mem: 962M Active, 1758M Inact, 7801M Wired, 5330M Free
ARC: 5463M Total, 318M MFU, 5085M MRU, 12M Anon, 33M Header, 15M Other
5241M Compressed, 9284M Uncompressed, 1.77:1 Ratio
Swap:

PID USERNAME    THR PRI NICE   SIZE    RES STATE   C   TIME    WCPU COMMAND
6620 root 14 20 0 2120M 874M kqread 0 33:56 19.24% bhyve
4997 root 16 20 0 194M 147M piperd 1 0:41 0.59% uwsg

How can I set manual to start size of swap file?

memoryleak.jpg (91.5 KB) memoryleak.jpg AndrX AndrX, 12/29/2017 12:32 AM
13660

Related issues

Related to FreeNAS - Bug #27270: Fix memory leakResolved2017-12-15

History

#1 Updated by AndrX AndrX almost 2 years ago

  • File debug-freenas-20171228102037.txz added
  • Private changed from No to Yes

#2 Updated by William Grzybowski almost 2 years ago

  • Category changed from 129 to Middleware
  • Status changed from Unscreened to 15
  • Assignee changed from Release Council to William Grzybowski
  • Target version set to 11.1-U1

Whats the output of:

midclt call disk.swaps_configure
swapinfo

#3 Updated by AndrX AndrX almost 2 years ago

William Grzybowski wrote:

Whats the output of:

midclt call disk.swaps_configure
swapinfo

Good day
information from terminal

[root@freenas ~]# swapinfo
Device 512-blocks Used Avail Capacity
[root@freenas ~]# midclt call disk.swaps_configure
["mirror/swap0"]
[root@freenas ~]#

#4 Updated by AndrX AndrX almost 2 years ago

AndrX AndrX wrote:

William Grzybowski wrote:

Whats the output of:

midclt call disk.swaps_configure
swapinfo

Good day
information from terminal

[root@freenas ~]# swapinfo
Device 512-blocks Used Avail Capacity
[root@freenas ~]# midclt call disk.swaps_configure
["mirror/swap0"]
[root@freenas ~]#

One more information, after reboot and manual set swap 4Gb
Trend swap was show 2 Gb free and 0Mb used

terminal output is show 4Gb, wtf?

[root@freenas ~]# swapinfo
Device 512-blocks Used Avail Capacity
/dev/mirror/swap0.eli 4194304 0 4194304 0%
[root@freenas ~]# midclt call disk.swaps_configure
["mirror/swap0"]
[root@freenas ~]#

How terminal inform 4Gb, trend swap - 2Gb
And swap not used and system random reboot

#5 Updated by AndrX AndrX almost 2 years ago

13660

AndrX AndrX wrote:

AndrX AndrX wrote:

William Grzybowski wrote:

Whats the output of:

midclt call disk.swaps_configure
swapinfo

Good day
information from terminal

[root@freenas ~]# swapinfo
Device 512-blocks Used Avail Capacity
[root@freenas ~]# midclt call disk.swaps_configure
["mirror/swap0"]
[root@freenas ~]#

One more information, after reboot and manual set swap 4Gb
Trend swap was show 2 Gb free and 0Mb used

terminal output is show 4Gb, wtf?

[root@freenas ~]# swapinfo
Device 512-blocks Used Avail Capacity
/dev/mirror/swap0.eli 4194304 0 4194304 0%
[root@freenas ~]# midclt call disk.swaps_configure
["mirror/swap0"]
[root@freenas ~]#

How terminal inform 4Gb, trend swap - 2Gb
And swap not used and system random reboot

see jpeg memory trend
memory leak
in freenas server run VM with ubuntu+zabbix

This problem started after 11.1 update

How can I fix this problem?

#6 Updated by William Grzybowski almost 2 years ago

Lets not confuse things, please. One thing at a time.

The original bug report says you have no swap, but that does not seem to be the case, right? Can you reproduce not having a swap? If so, how?

The memory leak is probably addressed in #27270

#7 Updated by Dru Lavigne almost 2 years ago

  • Status changed from 15 to Closed: Insufficient Info
  • Target version changed from 11.1-U1 to N/A
  • Private changed from Yes to No

#8 Updated by Dru Lavigne almost 2 years ago

  • File deleted (debug-freenas-20171228102037.txz)

#9 Updated by Dru Lavigne almost 2 years ago

Also available in: Atom PDF