Project

General

Profile

Bug #27493

Clicking save on a form might lead to no error feedback

Added by William Grzybowski almost 3 years ago. Updated almost 3 years ago.

Status:
Resolved
Priority:
Expected
Assignee:
Erin Clark
Category:
GUI (new)
Severity:
New
Reason for Closing:
Reason for Blocked:
Needs QA:
Yes
Needs Doc:
No
Needs Merging:
No
Needs Automation:
No
Support Suite Ticket:
n/a
Hardware Configuration:
ChangeLog Required:
No

Description

Say you are at the bottom of a page bigger than your screen (e.g. Tasks Scrub Add) and click save nothing will happen if there is an error in the form.

You will be left at the same scroll position and everything will appear normal like nothing happened.

The user should be redirected (scroll up) to the first error in the form.

Seen in 28 Dec nightly.

Associated revisions

Revision 89c7f1ca (diff)
Added by Erin Clark almost 3 years ago

Add ids to all of the entity-form components for dom manipulation Ticket: #27493

Revision b0e11877 (diff)
Added by Erin Clark almost 3 years ago

Add capability to scroll up to the first error and to expand advanced fields if the error is in them Ticket: #27493

Revision 6d60aab4 (diff)
Added by Erin Clark almost 3 years ago

Move form success and errors to the bottom since the user will likely be at the bottom when they submit the form Ticket: #27493

History

#1 Avatar?id=14398&size=24x24 Updated by Kris Moore almost 3 years ago

  • Status changed from Untriaged to Unscreened
  • Assignee changed from Release Council to Erin Clark
  • Target version set to 11.3

#2 Updated by Erin Clark almost 3 years ago

  • Status changed from Unscreened to 15

I believe I fixed this last week, could you try again and see if you can reproduce it somewhere?

#3 Updated by William Grzybowski almost 3 years ago

  • Status changed from 15 to Unscreened

Exact same issue reproduced on 3 Jan nightly.

#4 Updated by Erin Clark almost 3 years ago

  • Status changed from Unscreened to Screened

#5 Updated by Erin Clark almost 3 years ago

I figured out why, now just to figure out how to fix it. The problem also occurrs when the error is happening with a field that is hidden in advanced fields and the user is in basic mode

#6 Updated by Erin Clark almost 3 years ago

  • Priority changed from No priority to Expected
  • Target version changed from 11.3 to 11.2-BETA1

#7 Updated by Erin Clark almost 3 years ago

  • Status changed from Screened to Needs Developer Review
  • Assignee changed from Erin Clark to Lola Yang

#8 Updated by Lola Yang almost 3 years ago

  • Status changed from Needs Developer Review to Reviewed by Developer
  • Assignee changed from Lola Yang to Erin Clark

LGTM

#9 Updated by Dru Lavigne almost 3 years ago

  • Status changed from Reviewed by Developer to Resolved
  • Target version changed from 11.2-BETA1 to Master - FreeNAS Nightlies
  • Needs Doc changed from Yes to No
  • Needs Merging changed from Yes to No

Also available in: Atom PDF