Project

General

Profile

Bug #27516

Only run savecore in unused partitions

Added by Elandril DoUrden over 1 year ago. Updated about 1 year ago.

Status:
Done
Priority:
Nice to have
Assignee:
William Grzybowski
Category:
Middleware
Target version:
Seen in:
Severity:
Reason for Closing:
Reason for Blocked:
Needs QA:
Yes
Needs Doc:
No
Needs Merging:
No
Needs Automation:
No
Support Suite Ticket:
n/a
Hardware Configuration:

11 HDs in an encrypted ZFS volume as raidz-3.
2 USB sticks as ZFS mirror for system/boot.

ChangeLog Required:
No

Description

I have just upgraded to 11.1 and get the following messages on the console:

Dec 30 13:11:31 freenas savecore: /dev/da10p1: Operation not permitted
Dec 30 13:11:31 freenas savecore: /dev/da9p1: Operation not permitted
Dec 30 13:11:31 freenas savecore: /dev/da8p1: Operation not permitted
Dec 30 13:11:31 freenas savecore: /dev/da7p1: Operation not permitted
Dec 30 13:11:31 freenas savecore: /dev/da6p1: Operation not permitted
Dec 30 13:11:31 freenas savecore: /dev/da5p1: Operation not permitted
Dec 30 13:11:31 freenas savecore: /dev/da4p1: Operation not permitted
Dec 30 13:11:31 freenas savecore: /dev/da3p1: Operation not permitted
Dec 30 13:11:31 freenas savecore: /dev/da2p1: Operation not permitted
Dec 30 13:11:31 freenas savecore: /dev/da1p1: Operation not permitted

The messages appeared after unlocking the encrypted ZFS and the start of the jails. Interestingly the /dev/da0p1 is missing in the log entries, while the other 10 disks are mentioned.

freenas_iKVM_capture.jpg (64.1 KB) freenas_iKVM_capture.jpg Victor Häggqvist, 12/30/2017 08:04 AM
13685

Related issues

Has duplicate FreeNAS - Bug #27517: duplicate of #27516 for the purposes of attaching a debug tarballClosed: Duplicate2017-12-30

Associated revisions

Revision 4a80398c (diff)
Added by William Grzybowski about 1 year ago

fix(middlewared/disk): only run savecore in unused partitions

Ticket: #27516

Revision e11079e0 (diff)
Added by William Grzybowski about 1 year ago

fix(middlewared/disk): only run savecore in unused partitions

Ticket: #27516
(cherry picked from commit 4a80398c5991c6d176e07c38ad8bba4bf6191d51)

Revision f2d2a281 (diff)
Added by William Grzybowski about 1 year ago

fix(middlewared/disk): only run savecore in unused partitions

Ticket: #27516

History

#1 Updated by Victor Häggqvist over 1 year ago

13685

I am seeing this as well.
As stated above it appears while unlocking encrypted ZFS, additionally it appeared while importing encrypted ZFS as well.

Also this time when I was screen capturing a segfault appeared just before savecore, first time that happened.

#2 Updated by Eric Loewenthal over 1 year ago

A debug tarball would be useful. Elandril, please attach a debug file and mark the ticket as private.

Victor, if you want to mark your debug output as private, too, open a new ticket that mentions this one ("duplicate of #27516 for the purposes of attaching a debug tarball") and mark that one as private.

#3 Updated by Victor Häggqvist over 1 year ago

added debug output in #27517

#4 Updated by Elandril DoUrden over 1 year ago

  • File debug-freenas-20171230233723.tgz added
  • Private changed from No to Yes

#5 Updated by Dru Lavigne over 1 year ago

  • Has duplicate Bug #27517: duplicate of #27516 for the purposes of attaching a debug tarball added

#6 Updated by Dru Lavigne over 1 year ago

  • Assignee changed from Release Council to William Grzybowski

#7 Updated by William Grzybowski over 1 year ago

  • Status changed from Unscreened to Screened
  • Priority changed from No priority to Important
  • Target version set to 11.2-BETA1

#8 Updated by William Grzybowski over 1 year ago

  • Priority changed from Important to Nice to have

These are not harmful and do not indicate any issue. They are just overly verbose.

I'll try to get rid of them before 11.2.

#9 Updated by Dru Lavigne about 1 year ago

  • Status changed from Screened to Not Started

#10 Updated by William Grzybowski about 1 year ago

  • Due date set to 02/12/2018
  • Target version changed from 11.2-BETA1 to 11.1-U2
  • Needs Doc changed from Yes to No

#11 Updated by William Grzybowski about 1 year ago

  • Category changed from OS to Middleware

#12 Updated by William Grzybowski about 1 year ago

  • Status changed from Not Started to In Progress

#13 Updated by Dru Lavigne about 1 year ago

  • File deleted (debug-freenas-20171230233723.tgz)

#14 Updated by Dru Lavigne about 1 year ago

  • Subject changed from savecore: Operation not permitted to Only run savecore in unused partitions
  • Private changed from Yes to No

#15 Updated by William Grzybowski about 1 year ago

  • Status changed from In Progress to Done
  • Needs Merging changed from Yes to No

Also available in: Atom PDF