Project

General

Profile

Bug #27529

Unlocking encrypted pool throws exception "MiddlewareError"

Added by Christian Flämig over 2 years ago. Updated about 2 years ago.

Status:
Closed
Priority:
No priority
Assignee:
John Hixson
Category:
Services
Target version:
Seen in:
Severity:
Low Medium
Reason for Closing:
Not Applicable
Reason for Blocked:
Needs QA:
Yes
Needs Doc:
Yes
Needs Merging:
Yes
Needs Automation:
No
Support Suite Ticket:
n/a
Hardware Configuration:

AMD Phenom(tm) II X4 B50 Processor, 16 GB Ram, Asus M4A78LT-M Mainboard

ChangeLog Required:
No

Description

I installed FreeNAS 11.1 as clean install on a new USB-Stick and as upgrade of an existing 11.0-U4. In both cases If I try to unlock my pool a exception is thrown and displayed:

Environment:

Software Version: FreeNAS-11.1-RELEASE (dc7d195f4)
Request Method: POST
Request URL: http://sharkoon.local/storage/volume/1/unlock/?X-Progress-ID=e85e6f02-dc03-4d0f-855a-41c7d0bd5d16

Traceback:
File "/usr/local/lib/python3.6/site-packages/django/core/handlers/exception.py" in inner
42. response = get_response(request)
File "/usr/local/lib/python3.6/site-packages/django/core/handlers/base.py" in _legacy_get_response
249. response = self._get_response(request)
File "/usr/local/lib/python3.6/site-packages/django/core/handlers/base.py" in _get_response
178. response = middleware_method(request, callback, callback_args, callback_kwargs)
File "./freenasUI/freeadmin/middleware.py" in process_view
162. return login_required(view_func)(request, *view_args, **view_kwargs)
File "/usr/local/lib/python3.6/site-packages/django/contrib/auth/decorators.py" in _wrapped_view
23. return view_func(request, *args, **kwargs)
File "./freenasUI/storage/views.py" in volume_unlock
1005. form.done(volume=volume)
File "./freenasUI/storage/forms.py" in done
2792. raise MiddlewareError(msg)

Exception Type: MiddlewareError at /storage/volume/1/unlock/
Exception Value: [MiddlewareError: Volume could not be imported: 6 devices failed to decrypt]

Debug tar is attached.

History

#1 Updated by Christian Flämig over 2 years ago

  • File debug-sharkoon-20180101105040.txz added
  • Private changed from No to Yes

#2 Updated by Christian Flämig over 2 years ago

  • File debug-sharkoon-20180101113036.tar added

#3 Updated by Christian Flämig over 2 years ago

  • Hardware Configuration updated (diff)

#4 Updated by Dru Lavigne over 2 years ago

  • Assignee changed from Release Council to William Grzybowski

#5 Updated by William Grzybowski over 2 years ago

  • Status changed from Unscreened to 15

Does it work if you go back to 11.0-U4?

#6 Updated by Christian Flämig over 2 years ago

Yes, It works if I use the 11.0-U4 boot environment.

#7 Updated by William Grzybowski over 2 years ago

The debug file you attached does not contain any useful information.

Did you do it after you have tried to unlock the volume?

#8 Updated by William Grzybowski over 2 years ago

Also, we are probably gonna have to do screen sharing to debug it. When are you open for a Team Viewer session?

#9 Updated by Christian Flämig over 2 years ago

William Grzybowski wrote:

The debug file you attached does not contain any useful information.

Did you do it after you have tried to unlock the volume?

I‘m not sure, I will create a second debug file asap (tomorrow) teamviewer session is possible Thursday, 04, 20:00 UTC+1.

#10 Updated by William Grzybowski over 2 years ago

Christian Flämig wrote:

William Grzybowski wrote:

The debug file you attached does not contain any useful information.

Did you do it after you have tried to unlock the volume?

I‘m not sure, I will create a second debug file asap (tomorrow) teamviewer session is possible Thursday, 04, 20:00 UTC+1.

Thats a bit too late for me. Whats the earliest you can do? Could be another day.

#11 Updated by Christian Flämig over 2 years ago

William Grzybowski wrote:

Christian Flämig wrote:

William Grzybowski wrote:

The debug file you attached does not contain any useful information.

Did you do it after you have tried to unlock the volume?

I‘m not sure, I will create a second debug file asap (tomorrow) teamviewer session is possible Thursday, 04, 20:00 UTC+1.

Thats a bit too late for me. Whats the earliest you can do? Could be another day.

Friday, 05, 16:00, UTC+1?

#12 Updated by William Grzybowski over 2 years ago

Christian Flämig wrote:

William Grzybowski wrote:

Christian Flämig wrote:

William Grzybowski wrote:

The debug file you attached does not contain any useful information.

Did you do it after you have tried to unlock the volume?

I‘m not sure, I will create a second debug file asap (tomorrow) teamviewer session is possible Thursday, 04, 20:00 UTC+1.

Thats a bit too late for me. Whats the earliest you can do? Could be another day.

Friday, 05, 16:00, UTC+1?

That should work great. Shoot me an email (william at ixsystems com) or a private note here with the credentials.

Thanks

#13 Updated by Christian Flämig over 2 years ago

  • File debug-sharkoon-20180104185457.tgz added

#14 Updated by Christian Flämig over 2 years ago

  • File deleted (debug-sharkoon-20180101113036.tar)

#15 Updated by Christian Flämig over 2 years ago

I just tried to unlock the pool to collect the debug information.
The exception is still thrown, the storage screen was not updated.
But the pool has been unlocked, even there was no such refresh of the web view... After creating the debug tar, I switched back to the storage view an now the pool is shown unlocked.

In detail the bug report is still true (exception is thrown), anyway the pool is successfully unlocked.

Unfortunately now netatalk is running at 100% load without any possibility to kill or restart the process.

#16 Updated by Christian Flämig over 2 years ago

  • File deleted (debug-sharkoon-20180101105040.txz)

#17 Updated by William Grzybowski over 2 years ago

Christian Flämig wrote:

I just tried to unlock the pool to collect the debug information.
The exception is still thrown, the storage screen was not updated.
But the pool has been unlocked, even there was no such refresh of the web view... After creating the debug tar, I switched back to the storage view an now the pool is shown unlocked.

In detail the bug report is still true (exception is thrown), anyway the pool is successfully unlocked.

Unfortunately now netatalk is running at 100% load without any possibility to kill or restart the process.

Still gonna need to do a TeamViewer.

#18 Updated by Christian Flämig over 2 years ago

William Grzybowski wrote:

Still gonna need to do a TeamViewer.

Of course.

#19 Updated by Christian Flämig over 2 years ago

Update:

Reason for the exception was that the netatalk/afp service was running at 100% and the system was not able to restart the service after unlocking the pool.
AFP service was configured to bind a ipv4 and ipv6 address. After removing this two settings, netatalk/afp was running without problems and the unlocking process was able to restart the afp service.

#20 Updated by William Grzybowski over 2 years ago

  • Status changed from 15 to Unscreened
  • Assignee changed from William Grzybowski to Sean Fagan

Sean, is this something you can investigate?

Over teamviewer we saw the behavior Christian described in the last comment. This seems to be a regression since he says this worked in 11.0

#21 Updated by Sean Fagan over 2 years ago

  • Status changed from Unscreened to Screened

Hm, let me look at it. I don't use IPv6 at home so that could be ab issue. (It sounds like netatalk went nuts when having both ipv4 and ipv6.)

#22 Updated by Dru Lavigne over 2 years ago

  • Target version set to 11.2-BETA1
  • Seen in changed from Unspecified to 11.1

#23 Updated by Dru Lavigne over 2 years ago

  • Status changed from Screened to Not Started

#24 Avatar?id=13649&size=24x24 Updated by Ben Gadd over 2 years ago

  • Due date set to 03/09/2018

#25 Updated by Dru Lavigne over 2 years ago

  • Target version changed from 11.2-BETA1 to 11.2-RC2

#26 Updated by William Grzybowski over 2 years ago

  • Category changed from Middleware to OS

#27 Updated by Nick Wolff over 2 years ago

  • Severity set to Low Medium

#28 Updated by Dru Lavigne about 2 years ago

  • Target version changed from 11.2-RC2 to 11.2-BETA3

#29 Updated by Dru Lavigne about 2 years ago

  • Category changed from OS to Services
  • Assignee changed from Sean Fagan to John Hixson
  • Target version changed from 11.2-BETA3 to Backlog

#31 Updated by Dru Lavigne about 2 years ago

  • File deleted (debug-sharkoon-20180104185457.tgz)

#32 Updated by Dru Lavigne about 2 years ago

  • Status changed from Not Started to Closed
  • Target version changed from Backlog to N/A
  • Private changed from Yes to No
  • Reason for Closing set to Not Applicable

Chris: I'm closing out this issue as you were able to resolve it with William and we have since then fixed several Netatalk issues. Feel free to leave a comment on this ticket if you continue to experience AFP lockups.

Also available in: Atom PDF