Project

General

Profile

Bug #27543

Getting logged out while the console log popup is up blocks the login form

Added by Anthony Takata almost 3 years ago. Updated almost 3 years ago.

Status:
Resolved
Priority:
No priority
Assignee:
ChenTao Wang
Category:
GUI (new)
Severity:
New
Reason for Closing:
Reason for Blocked:
Needs QA:
Yes
Needs Doc:
Yes
Needs Merging:
Yes
Needs Automation:
No
Support Suite Ticket:
n/a
Hardware Configuration:

FreeNAS-11-MASTER-201712310456

ChangeLog Required:
No

Description

You can get back the login window if you click "Close" on the log window, but it's funny in any case.

Capture.PNG (68.2 KB) Capture.PNG Anthony Takata, 01/02/2018 11:09 AM
13717

History

#1 Updated by Dru Lavigne almost 3 years ago

  • Assignee changed from Release Council to Erin Clark
  • Target version set to 11.2-BETA1

#2 Updated by Erin Clark almost 3 years ago

  • Assignee changed from Erin Clark to ChenTao Wang

#3 Updated by ChenTao Wang almost 3 years ago

  • Status changed from Unscreened to Fix In Progress

#4 Updated by ChenTao Wang almost 3 years ago

  • Status changed from Fix In Progress to 15

I can't reproduce this issue in the recent version. Please confirm as soon as possible.

#5 Updated by Anthony Takata almost 3 years ago

Ok, I'll update to the latest nightly and check.

#6 Updated by Anthony Takata almost 3 years ago

  • File debug-bob-20180110153459.tgz added

Yes, this happens on FreeNAS-11-MASTER-201801100459

It does take a while to get kicked, I only notice it when coming back to the page in Chrome after "a while".

#7 Updated by Dru Lavigne almost 3 years ago

  • Status changed from 15 to Unscreened
  • Private changed from No to Yes

#8 Updated by ChenTao Wang almost 3 years ago

  • Status changed from Unscreened to Screened

#9 Updated by ChenTao Wang almost 3 years ago

I will check again

#10 Updated by Anthony Takata almost 3 years ago

I think it might have something to do with the tab being in the background? Try leaving it alone for a while.

#11 Updated by ChenTao Wang almost 3 years ago

On Dashboard page, I opened console log dialog. After that, I didn't have any action on browser, for 13 minutes.
The console log dialog still opens but the site was automatically sign out and so login page is displayed.

This is JUST an issue you had?

#12 Updated by Anthony Takata almost 3 years ago

Right, if I have the console log dialog displayed, when I come back to it after the login page is displayed the console dialog is still open (since I didn't close it).

#13 Updated by ChenTao Wang almost 3 years ago

When site is signed out, console log dialog needs to close as well. correct?

#14 Updated by Anthony Takata almost 3 years ago

Yes, basically. If it doesn't, it blocks the login form from displaying.

#15 Updated by ChenTao Wang almost 3 years ago

  • Status changed from Screened to Fix In Progress

#16 Updated by ChenTao Wang almost 3 years ago

  • Status changed from Fix In Progress to Needs Developer Review

#17 Updated by Dru Lavigne almost 3 years ago

  • Assignee changed from ChenTao Wang to Lola Yang

#18 Updated by Dru Lavigne almost 3 years ago

  • Status changed from Needs Developer Review to Resolved
  • Assignee changed from Lola Yang to ChenTao Wang
  • Target version changed from 11.2-BETA1 to Master - FreeNAS Nightlies
  • Private changed from Yes to No

#19 Updated by Dru Lavigne almost 3 years ago

  • File deleted (debug-bob-20180110153459.tgz)

Also available in: Atom PDF