Project

General

Profile

Bug #27581

SMB share/s unresponsive

Added by peter tosney over 2 years ago. Updated over 2 years ago.

Status:
Closed
Priority:
No priority
Assignee:
Timur Bakeyev
Category:
OS
Target version:
Seen in:
Severity:
Reason for Closing:
User Configuration Error
Reason for Blocked:
Needs QA:
Yes
Needs Doc:
Yes
Needs Merging:
Yes
Needs Automation:
No
Support Suite Ticket:
n/a
Hardware Configuration:
ChangeLog Required:
No

Description

I'm not too sure whats happening with my freenas OS, however its stopped responding twice now with the errors in the screenshot. I'm assuming its something to do with the Samba, but I've no idea what! Would anybody have any suggestions how I would go around diagnosing this or resolving the issue?

Thanks,
Pete

20180103_122404.jpg (5.39 MB) 20180103_122404.jpg peter tosney, 01/03/2018 04:58 AM
13730

History

#1 Updated by peter tosney over 2 years ago

  • File debug-FREENAS-20180103125722.txz added
  • Private changed from No to Yes

#2 Updated by peter tosney over 2 years ago

13730

#3 Updated by peter tosney over 2 years ago

  • Seen in changed from Unspecified to 11.1

#4 Updated by Dru Lavigne over 2 years ago

  • Assignee changed from Release Council to Timur Bakeyev
  • Target version set to 11.2-BETA1

Timur: possibly a DDNS issue?

#5 Updated by peter tosney over 2 years ago

yeah - i'm just looking through the log and thinking the same....i do recall the ddns service has stopped working previously....usually a service restart gets it going again. Perhaps I should stop the ddns service altogether as a test?

#6 Updated by Dru Lavigne over 2 years ago

Sure, let us know whether or not that resolves it.

#7 Updated by Dru Lavigne over 2 years ago

  • Status changed from Unscreened to 15

#8 Updated by peter tosney over 2 years ago

great - I will give it a try....thanks for the help :)

#9 Updated by peter tosney over 2 years ago

So, I've removed my net gear routers ability to dynamically update DNS for my IP....and I've increased the update period/time of the Freenas DDNS service to 1 hr from 1 minute... a combination of these two actions has resulted in no issues within the last 24 hrs.

I'll report back later with any further updates.

Thanks
Pete

#10 Updated by peter tosney over 2 years ago

Unfortunately the issue still remains with DDNS service stopped.

I'm still receiving the below error in the console/shell :

Jan 7 04:21:34 FREENAS /alert.py: [system.alert:400] Alert module '<samba4.Samba4Alert object at 0x81725ba20>' failed: Call timeout
Jan 7 04:52:08 FREENAS /alert.py: [system.alert:400] Alert module '<samba4.Samba4Alert object at 0x81725ba20>' failed: timed out
Jan 7 05:25:40 FREENAS /alert.py: [system.alert:400] Alert module '<samba4.Samba4Alert object at 0x81725ba20>' failed: timed out
Jan 7 05:33:47 FREENAS /alert.py: [system.alert:400] Alert module '<samba4.Samba4Alert object at 0x81725ba20>' failed: Failed connection handshake

Any suggestions would be welcomed and appreciated?

Thanks
Pete

#11 Updated by Dru Lavigne over 2 years ago

  • Status changed from 15 to Investigation

#12 Updated by peter tosney over 2 years ago

just fyi - I have dropped back to 11.0-U4 to see if the issue still exists within that build - I will report back in a couple of days.

#13 Updated by Dru Lavigne over 2 years ago

  • Status changed from Investigation to Not Started

#14 Updated by Timur Bakeyev over 2 years ago

Hi, Peter!

Redmine managed to lose my my comment to your ticket, so I'll give it's short version.

It seems that your problems caused by lack of the appropriate vfs objects in your smb4.conf. You need to visit and edit configuration of EVERY (Samba) share and in Advanced mode make sure that you have selected zfs_space, zfsacl and streams_xattr modules. Don't deselect other, already selected modules, if any.

I hope that would fix issues, you experience with Samba.

#15 Updated by peter tosney over 2 years ago

Hi,

Thank you for the response...I have made the changes you have suggested and i'll see if that manages to resolve the issue over the next few days....then i'll report back with the results... :)

Thanks again,
Pete

#16 Updated by Dru Lavigne over 2 years ago

  • Reason for Blocked set to Need verification

#17 Updated by Timur Bakeyev over 2 years ago

  • Status changed from Not Started to Blocked

#18 Updated by peter tosney over 2 years ago

Well its been over 36hrs now and there has not been a hint of trouble - therefore I can confirm the fix is working.

Thank you for your help and hopefully this call/ticket will assist others in future should they experience the same issue.

Thank,
Pete

#19 Updated by Dru Lavigne over 2 years ago

  • File deleted (debug-FREENAS-20180103125722.txz)

#20 Updated by Dru Lavigne over 2 years ago

  • Status changed from Blocked to Closed
  • Target version changed from 11.2-BETA1 to N/A
  • Private changed from Yes to No
  • Reason for Closing set to User Configuration Error
  • Reason for Blocked deleted (Need verification)

Thanks for the update, Peter. I'll close out this ticket.

#21 Updated by Timur Bakeyev over 2 years ago

Thanks, Peter!

For the record, log.smbd contains following log lines:

[2017/12/18 21:51:27.956928,  1] ../source3/modules/vfs_posixacl.c:172(smb_ace_to_internal)
  ACL tag type ACL_EVERYONE. FreeBSD with ZFS? Use 'vfs objects = zfsacl'
[2017/12/18 21:51:31.123789,  1] ../source3/modules/vfs_posixacl.c:172(smb_ace_to_internal)
  ACL tag type ACL_EVERYONE. FreeBSD with ZFS? Use 'vfs objects = zfsacl'
[2017/12/18 21:51:34.971091,  1] ../source3/modules/vfs_posixacl.c:172(smb_ace_to_internal)
  ACL tag type ACL_EVERYONE. FreeBSD with ZFS? Use 'vfs objects = zfsacl'
[2017/12/18 21:51:38.212376,  1] ../source3/modules/vfs_posixacl.c:172(smb_ace_to_internal)
  ACL tag type ACL_EVERYONE. FreeBSD with ZFS? Use 'vfs objects = zfsacl'
[2017/12/18 21:51:41.029132,  1] ../source3/modules/vfs_posixacl.c:172(smb_ace_to_internal)
  ACL tag type ACL_EVERYONE. FreeBSD with ZFS? Use 'vfs objects = zfsacl'

Also available in: Atom PDF