Project

General

Profile

Bug #27583

cannot set Link-Local IPv6 default Gateway

Added by Emanuel Klein over 1 year ago. Updated over 1 year ago.

Status:
Closed
Priority:
No priority
Assignee:
Vladimir Vinogradenko
Category:
GUI (new)
Target version:
Seen in:
Severity:
New
Reason for Closing:
Duplicate
Reason for Blocked:
Needs QA:
Yes
Needs Doc:
Yes
Needs Merging:
Yes
Needs Automation:
No
Support Suite Ticket:
n/a
Hardware Configuration:
ChangeLog Required:
No

Description

Background:
In order to address a target Link Local IPv6 address, a source Interface must be used as reference using the '%' sign.
I.e. 'ping6 fe80::10%igb0'

Current behaviour:
It is not possible to set a Link Local IPv6 default gateway (possibly static routes aswell?) using the GUI, as the GUI prohibits the '%' sign as special character.
Not tested via CLI.

Expected behaviour
I can set 'fe80::10%igb0' using the GUI


Related issues

Is duplicate of FreeNAS - Bug #26895: Allow IPv6 addresses with zone indexes for IPv6 Default GatewayDone

History

#1 Updated by Dru Lavigne over 1 year ago

  • Status changed from Unscreened to 15
  • Seen in changed from TrueNAS 11.1-U1 to 11.1

Emanuel: is this in the new or the old GUI? If the old one, does the issue also exist in the new GUI?

#2 Updated by Emanuel Klein over 1 year ago

Dru Lavigne wrote:

Emanuel: is this in the new or the old GUI? If the old one, does the issue also exist in the new GUI?

This is seen using the old GUI. Have not (and not planning to) use the new one.

#3 Updated by Dru Lavigne over 1 year ago

  • Status changed from 15 to Unscreened
  • Assignee changed from Release Council to William Grzybowski
  • Target version set to 11.2-BETA1

William: passing to you first in case a middleware piece is needed. If the middleware is fine, please pass to Erin so her team can verify that the new UI is doing the right thing.

#4 Updated by William Grzybowski over 1 year ago

  • Assignee changed from William Grzybowski to Vladimir Vinogradenko

Vladimir, this is a low priority, feel free to punt it to 11.3.

#5 Updated by Vladimir Vinogradenko over 1 year ago

  • Status changed from Unscreened to Screened

#6 Updated by Dru Lavigne over 1 year ago

  • Status changed from Screened to Not Started
  • Target version changed from 11.2-BETA1 to 11.2-RC2

#7 Updated by Dru Lavigne over 1 year ago

  • Is duplicate of Bug #26895: Allow IPv6 addresses with zone indexes for IPv6 Default Gateway added

#8 Updated by Dru Lavigne over 1 year ago

  • Status changed from Not Started to Closed
  • Target version changed from 11.2-RC2 to N/A
  • Reason for Closing set to Duplicate

Also available in: Atom PDF