Project

General

Profile

Bug #27595

mount_* settings in beta UI have no effect on iocage jails

Added by Patrick M. Hausen over 2 years ago. Updated over 2 years ago.

Status:
Closed: Behaves correctly
Priority:
Expected
Assignee:
Brandon Schneider
Category:
Middleware
Target version:
Seen in:
TrueNAS - TrueNAS 11.1-U1
Severity:
New
Reason for Closing:
Reason for Blocked:
Needs QA:
Yes
Needs Doc:
Yes
Needs Merging:
Yes
Needs Automation:
No
Support Suite Ticket:
n/a
Hardware Configuration:
ChangeLog Required:
No

Description

root@freenas-pmh:/mnt/iocage/jails/test # iocage get mount_devfs test
1
root@freenas-pmh:/mnt/iocage/jails/test # iocage get mount_fdescfs test
1
root@freenas-pmh:/mnt/iocage/jails/test # iocage start test
* Starting test
  + Started OK
  + Configuring VNET OK
  + Starting services OK
root@freenas-pmh:/mnt/iocage/jails/test # iocage console test
Last login: Thu Dec 28 21:01:56 on pts/0
FreeBSD 11.1-STABLE (FreeNAS.amd64) #0 r321665+d4625dcee3e(freenas/11.1-stable): Wed Dec 13 16:33:42 UTC 2017
Welcome to FreeBSD!
[...]
root@test:~ # df
Filesystem                  1K-blocks   Used      Avail Capacity  Mounted on
zfs/iocage/jails/test/root 5268294657 345373 5267949284     0%    /
root@test:~ #

I assume this is just not implemented yet. I set mount_devfs and mount_fdescfs in the UI, then confirmed they were set with iocage (see above) - boot jail, filesystems not mounted.

Kind regards,
Patrick

History

#1 Updated by Dru Lavigne over 2 years ago

  • Assignee changed from Release Council to Erin Clark
  • Target version set to 11.2-BETA1

#2 Updated by Dru Lavigne over 2 years ago

  • Category changed from 38 to GUI (new)

#3 Updated by Erin Clark over 2 years ago

  • Assignee changed from Erin Clark to Lola Yang

#4 Updated by Patrick M. Hausen over 2 years ago

Hey,

this is clearly most probably not a UI issue. As you can see from the first two commands in my initial report the UI settings are reflected into iocage attributes.
It is iocage that does not mount the file systems even with the correct settings present ...

Please reconsider assignee and category for this issue.

Patrick

#5 Avatar?id=14398&size=24x24 Updated by Kris Moore over 2 years ago

  • Category changed from GUI (new) to 38
  • Assignee changed from Lola Yang to Brandon Schneider
  • Priority changed from No priority to Expected

Brandon - Is this still something broken in master code?

#6 Updated by Brandon Schneider over 2 years ago

  • Status changed from Unscreened to Closed: Behaves correctly

These mount from the host, and the default is 1. So setting this from the GUI would not change a thing. So everything is correctly working, what Patrick likely wants is allow_mount_devfs and then mounting it inside the jail himself or via the jails fstab.

#7 Updated by Dru Lavigne over 2 years ago

  • Target version changed from 11.2-BETA1 to N/A

Also available in: Atom PDF