Project

General

Profile

Bug #27612

Browser login disabled and being shut down by browsers for not using HTTPS in all modern browsers on windows and other OSs.

Added by Peter Southwell almost 4 years ago. Updated almost 4 years ago.

Status:
Closed: Duplicate
Priority:
No priority
Assignee:
-
Category:
GUI (new)
Target version:
-
Severity:
New
Reason for Closing:
Reason for Blocked:
Needs QA:
Yes
Needs Doc:
Yes
Needs Merging:
Yes
Needs Automation:
No
Support Suite Ticket:
n/a
Hardware Configuration:
ChangeLog Required:
No

Description

Latest chrome firefox and IE browsers on windows shut down our UI on http. Giving the followng browser generated error (not from our angular code).

This page includes a password or credit card input in a non-secure context. A warning has been added to the URL bar. For more information, see https://goo.gl/zmWq3m.

Ive confirmed this in nightly as of the day of this writing.

I CAN force the UI to work using the following procedure. (Setting up HTTPS in the OLD UI sense the New UI is disable until you do this step).

Generate a .key/.cert files

1. openssl genrsa -out freenasssh.key
2 openssl req -new -x509 -days 365 -key freenasssh.key -out freenasssh.crt -sha256
3. Go to the legacy UI.... Go to System / Certificates.
4. Import this certificate.
5. Go to to General I selected HTTP + HTTPS. And the cert under my root user was now (after having imported it).. In the drop down.

Saved... The WEB UI RESTARTS

6) https://your_free_nas_ip

The browser says.. WO.... Thats not a secure website are you sure.. Proceed anyways under "Advanced".

Boom.. The website works and so does login. FYI.

Now i Know your all thinking.. Wow.. Windows Who cares.. Well...

According to google..
"
What is the most common operating system?
The three most common operating systems for personal computers are Microsoft Windows, Mac OS X, and Linux.
"

So.. IMHO.. We need to make the nightlies.> Default setup for https... ?

But.. that's how to make our current stuff work... If your running latest browser versions. At least that's true for windows 10. I believe other people are seeing this error... But it has to do with using a most recent version of browsers Firefox (latest stable), Chrome (Latest stable), IE (Latest Stable). and probably others...

Erin Assigned this to you.. Hoping you know who to direct it to.... I realize you don't control directly the https/http default freenas deployment. The freenas would have to be setup default https... Inorder for the user to not need the Old UI to unlock the new UI... On Windowes.. Anny browser. and I believe also the mac.


Related issues

Is duplicate of FreeNAS - Bug #27444: Unable to login to the latest nightlies 12/27/2017 I think the latest nightly is still (FreeNAS-11-MASTER-201712250515)Resolved2017-12-27

History

#1 Updated by Peter Southwell almost 4 years ago

Google Chrome is up to date
Version 63.0.3239.108 (Official Build) (64-bit)

Firefox 56.0.3 64 Bit

#2 Updated by Anonymous almost 4 years ago

  • Is duplicate of Bug #27444: Unable to login to the latest nightlies 12/27/2017 I think the latest nightly is still (FreeNAS-11-MASTER-201712250515) added

#3 Updated by Anonymous almost 4 years ago

  • Status changed from Screened to 15

I believe this is a duplicate of 27444, the problem was that the button was checking for form.invalid and that modern browsers define invalid to be false if the page has a login and is not secure so I changed it to just check if username or password has errors in it. I had Pete test my fix, would you like to confirm Pete?

#4 Updated by Anonymous almost 4 years ago

  • Status changed from 15 to Closed: Duplicate

Pete tells me it is good, closing ticket

Also available in: Atom PDF