Project

General

Profile

Bug #27636

Daily unauthorized system reboots after Upgrading to 11.1

Added by René Keller over 2 years ago. Updated over 2 years ago.

Status:
Closed: Duplicate
Priority:
No priority
Assignee:
Sean Fagan
Category:
OS
Target version:
Seen in:
Severity:
New
Reason for Closing:
Reason for Blocked:
Needs QA:
Yes
Needs Doc:
Yes
Needs Merging:
Yes
Needs Automation:
No
Support Suite Ticket:
n/a
Hardware Configuration:
ChangeLog Required:
No

Description

After Upgrading to 11.1 (Update completed @ 24.12.2017) my system reboots every day.

Reboot Times:
System booted at Mon Dec 25 02:47:56 2017 was not shut down properly
System booted at Tue Dec 26 02:47:58 2017 was not shut down properly
System booted at Wed Dec 27 02:47:58 2017 was not shut down properly
System booted at Thu Dec 28 02:47:57 2017 was not shut down properly
System booted at Fri Dec 29 02:47:56 2017 was not shut down properly
System booted at Sat Dec 30 02:47:57 2017 was not shut down properly
System booted at Sat Dec 30 23:15:48 2017 was not shut down properly
System booted at Sat Dec 30 23:32:27 2017 was not shut down properly
System booted at Sat Dec 30 23:49:08 2017 was not shut down properly
System booted at Sun Dec 31 00:05:35 2017 was not shut down properly
System booted at Sun Dec 31 00:22:15 2017 was not shut down properly
System booted at Sun Dec 31 00:38:52 2017 was not shut down properly
System booted at Sun Dec 31 00:55:16 2017 was not shut down properly
System booted at Sun Dec 31 01:13:10 2017 was not shut down properly
System booted at Sun Dec 31 01:30:48 2017 was not shut down properly
System booted at Sun Dec 31 01:48:39 2017 was not shut down properly
System booted at Sun Dec 31 01:48:39 2017 was not shut down properly
System booted at Sun Dec 31 02:23:12 2017 was not shut down properly
System booted at Sun Dec 31 02:47:58 2017 was not shut down properly
System booted at Sun Dec 31 03:04:37 2017 was not shut down properly
System booted at Sun Dec 31 03:21:11 2017 was not shut down properly
System booted at Sun Dec 31 03:37:50 2017 was not shut down properly
.
.
.
.
.
.
.
And since monday, 01.01.2018 daily

System booted at Mon Jan 1 02:47:58 2018 was not shut down properly
System booted at Tue Jan 2 02:47:56 2018 was not shut down properly
System booted at Wed Jan 3 02:47:57 2018 was not shut down properly
System booted at Thu Jan 4 02:47:57 2018 was not shut down properly
System booted at Fri Jan 5 02:47:56 2018 was not shut down properly


Related issues

Is duplicate of FreeNAS - Bug #27524: Fix panic on resilver or scrubResolved2017-12-31

History

#1 Updated by René Keller over 2 years ago

  • File debug-nas-20180105090138.txz added
  • Private changed from No to Yes

#2 Updated by René Keller over 2 years ago

  • Seen in changed from Unspecified to 11.1

#3 Updated by Dru Lavigne over 2 years ago

  • Assignee changed from Release Council to Benno Rice

Benno: passing to you as it may be related to 27514.

#4 Updated by Benno Rice over 2 years ago

So #27514 has a huge call stack that ping-pongs between various bits of ZFS and nullfs. This one has the following panic:

panic: solaris assert: spa->spa_scrub_inflight > 0 (0x0 > 0x0), file: /freenas-11-releng/freenas/_BE/os/sys/cddl/contrib/opensolaris/uts/common/fs/zfs/dsl_scan.c, line: 1450
cpuid = 1
KDB: stack backtrace:
db_trace_self_wrapper() at db_trace_self_wrapper+0x2b/frame 0xfffffe0423e59820
vpanic() at vpanic+0x186/frame 0xfffffe0423e598a0
panic() at panic+0x43/frame 0xfffffe0423e59900
assfail3() at assfail3+0x2c/frame 0xfffffe0423e59920
dsl_scan_prefetch_cb() at dsl_scan_prefetch_cb+0x77/frame 0xfffffe0423e599a0
arc_read_done() at arc_read_done+0x6ad/frame 0xfffffe0423e599f0
zio_done() at zio_done+0x10ee/frame 0xfffffe0423e59a90
zio_execute() at zio_execute+0x17c/frame 0xfffffe0423e59ae0
taskqueue_run_locked() at taskqueue_run_locked+0x15d/frame 0xfffffe0423e59b40
taskqueue_thread_loop() at taskqueue_thread_loop+0x88/frame 0xfffffe0423e59b70
fork_exit() at fork_exit+0x84/frame 0xfffffe0423e59bb0
fork_trampoline() at fork_trampoline+0xe/frame 0xfffffe0423e59bb0
--- trap 0, rip = 0, rsp = 0, rbp = 0 ---
KDB: enter: panic

I'm fairly sure these are unrelated.

#5 Updated by Benno Rice over 2 years ago

  • Assignee changed from Benno Rice to Sean Fagan

Is this a dupe of #27524?

#6 Updated by Sean Fagan over 2 years ago

  • Is duplicate of Bug #27524: Fix panic on resilver or scrub added

#7 Updated by Sean Fagan over 2 years ago

  • Status changed from Unscreened to Closed: Duplicate

Yes.

#8 Updated by René Keller over 2 years ago

I cant view 27524 because of missing permissions.

#9 Updated by Dru Lavigne over 2 years ago

  • Target version set to N/A

It is viewable now as I removed the reporter's debug info.

#10 Updated by Dru Lavigne over 2 years ago

  • File deleted (debug-nas-20180105090138.txz)

#11 Updated by Dru Lavigne over 2 years ago

  • Private changed from Yes to No

Also available in: Atom PDF