Project

General

Profile

Feature #27656

Avatar?id=13649&size=50x50

Include Intel Meltdown workaround code

Added by Ben Gadd over 1 year ago. Updated 10 months ago.

Status:
Done
Priority:
Blocks Until Resolved
Assignee:
Alexander Motin
Category:
OS
Target version:
Estimated time:
Severity:
Med High
Reason for Closing:
Reason for Blocked:
Needs QA:
No
Needs Doc:
No
Needs Merging:
No
Needs Automation:
No
Support Suite Ticket:
n/a
Hardware Configuration:

Description

This will be a placeholder for the intel bug. When more information is available, we will edit this bug to track the details.


Related issues

Related to FreeNAS - Umbrella #28498: Implement Meltdown mitigationDone

History

#1 Avatar?id=13649&size=24x24 Updated by Ben Gadd over 1 year ago

  • Status changed from 46 to 15
  • Priority changed from No priority to Blocks Until Resolved
  • Target version set to 11.1-U1

Awaiting Meltdown fix from FreeBSD

#2 Avatar?id=13649&size=24x24 Updated by Ben Gadd over 1 year ago

  • Assignee changed from Release Council to Kris Moore
  • Private changed from Yes to No

#3 Updated by Dru Lavigne over 1 year ago

  • Category set to 129
  • Status changed from 15 to Investigation

#4 Updated by Dru Lavigne over 1 year ago

  • Target version changed from 11.1-U1 to 11.1-U2

#5 Avatar?id=13649&size=24x24 Updated by Ben Gadd over 1 year ago

  • Subject changed from Placeholder for Intel bug to Placeholder for Intel Meltdown bug

#6 Updated by Dru Lavigne about 1 year ago

  • Status changed from Investigation to Not Started

#7 Avatar?id=13649&size=24x24 Updated by Ben Gadd about 1 year ago

  • Due date set to 02/12/2018

Due date updated to reflect the code freeze for 11.1U2.

#8 Avatar?id=13649&size=24x24 Updated by Ben Gadd about 1 year ago

  • Severity set to New

#9 Avatar?id=13649&size=24x24 Updated by Ben Gadd about 1 year ago

  • Category changed from 129 to 2

#10 Avatar?id=13649&size=24x24 Updated by Ben Gadd about 1 year ago

  • Target version changed from 11.1-U2 to 11.2-RC2

#11 Avatar?id=13649&size=24x24 Updated by Ben Gadd about 1 year ago

  • Due date deleted (02/12/2018)

#12 Avatar?id=14398&size=24x24 Updated by Kris Moore about 1 year ago

  • Category changed from GUI (new) to OS
  • Status changed from Not Started to In Progress

#13 Updated by Dru Lavigne 11 months ago

  • Assignee changed from Kris Moore to Alexander Motin
  • Target version changed from 11.2-RC2 to Backlog

#14 Updated by Alexander Motin 11 months ago

  • Tracker changed from Bug to Feature
  • Subject changed from Placeholder for Intel Meltdown bug to Intel Meltdown bug workaround
  • Status changed from In Progress to Ready for Testing
  • Target version changed from Backlog to 11.2-RC2
  • Severity changed from New to Med High
  • Seen in deleted (N/A)
  • ChangeLog Required deleted (No)

Meltdown workaround code is merged into 11.2 since February. It should be automatically enabled on Intel systems, that can be checked via sysctl vm.pmap.pti, and controlled via respective loader tunable. We still need to measure its performance effects.

#15 Updated by Dru Lavigne 11 months ago

  • Target version changed from 11.2-RC2 to 11.2-BETA1

#16 Updated by Dru Lavigne 11 months ago

#17 Updated by Dru Lavigne 11 months ago

  • Subject changed from Intel Meltdown bug workaround to Include Intel Meltdown workaround code
  • Needs Doc changed from Yes to No
  • Needs Merging changed from Yes to No

#18 Avatar?id=55038&size=24x24 Updated by Zackary Welch 10 months ago

I can confirm vm.pmap.pti is 1 by default on new builds. It seems this code has been integrated successfully, though I'm not sure about the performance impacts.

#19 Updated by Dru Lavigne 10 months ago

  • Status changed from Ready for Testing to Passed Testing
  • Needs Doc changed from No to Yes

#20 Avatar?id=55038&size=24x24 Updated by Zackary Welch 10 months ago

Performance impact moved to related ticket: https://redmine.ixsystems.com/issues/34987

#22 Updated by Dru Lavigne 10 months ago

  • Status changed from Passed Testing to Done
  • Needs Doc changed from Yes to No

#23 Updated by Dru Lavigne 10 months ago

  • Needs QA changed from Yes to No

Also available in: Atom PDF