Project

General

Profile

Bug #27672

TimeMachine quota value is taken as MB, not GB

Added by han sooloo over 1 year ago. Updated over 1 year ago.

Status:
Closed: Duplicate
Priority:
No priority
Assignee:
Release Council
Category:
OS
Target version:
Seen in:
Severity:
New
Reason for Closing:
Reason for Blocked:
Needs QA:
Yes
Needs Doc:
Yes
Needs Merging:
Yes
Needs Automation:
No
Support Suite Ticket:
n/a
Hardware Configuration:
ChangeLog Required:
No

Description

TimeMachine quota value is indicated in GB in the UI. However, when I set the value to, e.g., 500, the value that gets written to the `plist` file is 524288000.

This causes the macOS TimeMachine client to think that it ONLY has 500 MB to use, and quits the backup process.

Either the UI hint should be changed or the UI should properly translate the user input to the file that needs to be stored in `.com.apple.TimeMachine.quota.plist`.

<!DOCTYPE plist PUBLIC "-//Apple//DTD PLIST 1.0//EN" "http://www.apple.com/DTDs/PropertyList-1.0.dtd">
<plist version="1.0">
<dict>
<key>GlobalQuota</key>
<integer>524288000</integer>
</dict>
</plist>


Related issues

Is duplicate of FreeNAS - Bug #17875: Specify a quota per time machine backupResolved2016-09-29

History

#1 Updated by han sooloo over 1 year ago

  • File debug-zfs-20180107222947.txz added
  • Private changed from No to Yes

#2 Updated by han sooloo over 1 year ago

  • Subject changed from TimeMachine quota value is taken as bytes, not GB to TimeMachine quota value is taken as MB, not GB

#3 Updated by Dru Lavigne over 1 year ago

  • Is duplicate of Bug #17875: Specify a quota per time machine backup added

#4 Updated by Dru Lavigne over 1 year ago

  • File deleted (debug-zfs-20180107222947.txz)

#5 Updated by Dru Lavigne over 1 year ago

  • Status changed from Unscreened to Closed: Duplicate
  • Target version set to N/A
  • Private changed from Yes to No
  • Seen in changed from Unspecified to 11.1

Han: this will be fixed in the next update.

Also available in: Atom PDF