Project

General

Profile

Bug #27683

Popup message preventing creation of shares from jails

Added by Drin Ny over 2 years ago. Updated over 2 years ago.

Status:
Closed
Priority:
Nice to have
Assignee:
William Grzybowski
Category:
Middleware
Target version:
Seen in:
Severity:
Low Medium
Reason for Closing:
Not to be fixed
Reason for Blocked:
Needs QA:
Yes
Needs Doc:
Yes
Needs Merging:
Yes
Needs Automation:
No
Support Suite Ticket:
n/a
Hardware Configuration:
ChangeLog Required:
No

Description

In trying to create a SMB share from a home directory for an iocage jail (i.e. /mnt/iocage/jails/nameofjail/root/home/user), I receive the error message "This field is required" in both the standard UI and the beta UI and the SMB share is not created.

History

#1 Updated by Dru Lavigne over 2 years ago

  • Status changed from Unscreened to 15
  • Private changed from No to Yes

Drin: please attach a debug (System -> Advanced -> Save Debug).

#2 Updated by Drin Ny over 2 years ago

  • File debug-rivendell-20180109140357.tgz added

Dru Lavigne wrote:

Drin: please attach a debug (System -> Advanced -> Save Debug).

debug attached as requested

#3 Updated by Dru Lavigne over 2 years ago

  • Category changed from OS to 38
  • Status changed from 15 to Unscreened
  • Assignee changed from Release Council to Brandon Schneider
  • Target version set to 11.1-U2

#4 Avatar?id=14398&size=24x24 Updated by Kris Moore over 2 years ago

Can you create SMB shares elsewhere? Normally it's not considered good to create a share under a jail. Its safer to make your share elsewhere, then use the jails nullfs mount system to map that share into the jail instead.The old UI is even supposed to block such attempts to avoid problems.

#5 Updated by Dru Lavigne over 2 years ago

  • Status changed from Unscreened to 15

#6 Updated by Drin Ny over 2 years ago

Kris Moore wrote:

Can you create SMB shares elsewhere? Normally it's not considered good to create a share under a jail. Its safer to make your share elsewhere, then use the jails nullfs mount system to map that share into the jail instead.The old UI is even supposed to block such attempts to avoid problems.

Yes, shares are working elsewhere. But I've had these types of SMB shares for years now using FreeNAS and this has only stopped working once I recreated my jails over from warden jails to iocage ones.

Technically, I can do what you're asking but it does represent a change to the type of behavior that has been allowed for a while now. So I figured I'd file a bug report in case it was an oversight in development. I imagine that others may have a problem with this restriction when the tool is created that will convert warden jails to iocage?

#7 Avatar?id=13649&size=24x24 Updated by Ben Gadd over 2 years ago

  • Due date set to 02/02/2018

#8 Avatar?id=14398&size=24x24 Updated by Kris Moore over 2 years ago

  • Category changed from 38 to GUI (new)
  • Status changed from 15 to Not Started
  • Assignee changed from Brandon Schneider to Erin Clark
  • Priority changed from No priority to Nice to have
  • Target version changed from 11.1-U2 to 11.2-BETA1

Erin, the best practice here is to prohibit creating shares directly in jails. It can cause all sorts of unexpected behavior especially when the share or jail toolchain gets updated.

For the new UI, please add some human readable error explaining why this isnt allowed and recommend using jails nullfs mounts instead.

#9 Updated by Dru Lavigne over 2 years ago

  • Subject changed from Trying to share directory under /mnt/iocage leads to error "This field is required" to Popup message preventing creation of shares from jails

Erin: the doc team can assist in the wording of the error once the code to trigger the condition is created.

#10 Updated by Dru Lavigne over 2 years ago

  • File deleted (debug-rivendell-20180109140357.tgz)

#11 Updated by Dru Lavigne over 2 years ago

  • Private changed from Yes to No

#12 Updated by Erin Clark over 2 years ago

  • Category changed from GUI (new) to Middleware
  • Assignee changed from Erin Clark to William Grzybowski

William, would this by chance be handled better on the middleware side (what is to prevent a user from making a rest or websocket call that would do the same thing otherwise?), if the middleware spits out an error that says it can't create a jail on this location it should propagate through the UI

#13 Avatar?id=13649&size=24x24 Updated by Ben Gadd over 2 years ago

  • Due date changed from 02/02/2018 to 03/09/2018

#14 Updated by William Grzybowski over 2 years ago

  • Due date deleted (03/09/2018)
  • Target version changed from 11.2-BETA1 to 11.3
  • Severity set to Low Medium

This has lower priority, moving target.

#15 Avatar?id=13649&size=24x24 Updated by Ben Gadd over 2 years ago

  • Target version changed from 11.3 to Backlog

#16 Updated by William Grzybowski over 2 years ago

  • Status changed from Not Started to Closed
  • Target version changed from Backlog to N/A
  • Reason for Closing set to Not to be fixed

Now that I am thinking about it again. /mnt/iocage is not a valid mountpoint since its not a volume.

New UI should handle that gracefully by default.

Also available in: Atom PDF