Project

General

Profile

Bug #27749

Traceback when trying to mirror boot device

Added by Felix C. Morency over 1 year ago. Updated over 1 year ago.

Status:
Closed
Priority:
Important
Assignee:
William Grzybowski
Category:
Middleware
Target version:
Seen in:
Severity:
Reason for Closing:
Not Applicable
Reason for Blocked:
Needs QA:
Yes
Needs Doc:
Yes
Needs Merging:
Yes
Needs Automation:
No
Support Suite Ticket:
n/a
Hardware Configuration:
ChangeLog Required:
No

Description

- Originally installed FreeNAS 11.0-U4 on a single Verbatim 16Gb USB key (da0). Pool is encrypted.
- Upgraded to FreeNAS 11.1-RELEASE.
- Bought another Verbatim 16Gb USB key to mirror the boot device. Plug-in the new USB key.
- Go to the "Boot Status" page and click "Attach"
- Add the new device (da1)
- Got a Traceback saying that `gpart` exited with a non-zero code 1.

[root@freenas ~]# gpart show da1                                                
=>      40  31489968  da1  GPT  (15G)                                           
        40    532480    1  efi  (260M)                                          
    532520  30957488       - free -  (15G)                                      

[root@freenas ~]# gpart show da0                                                
=>      40  31489968  da0  GPT  (15G)                                           
        40    204800    1  efi  (100M)                                          
    204840  31285160    2  freebsd-zfs  (15G)                                   
  31490000         8       - free -  (4.0K) 

Related issues

Related to FreeNAS - Bug #27860: Display proper error message when mirroring boot device fails due to target device size being too smallDone2018-01-182018-02-12

History

#1 Updated by Dru Lavigne over 1 year ago

  • Assignee changed from Release Council to William Grzybowski
  • Target version set to 11.1-U2
  • Private changed from No to Yes

#2 Updated by William Grzybowski over 1 year ago

  • Status changed from Unscreened to Screened
  • Priority changed from No priority to Important
  • Target version changed from 11.1-U2 to 11.2-BETA1

As far as I understand thats because the disks are of the same size but the current boot disk has been created some time ago and since then we have bumped the size of the EFI partition from 100mb to 260mb.

You will need a bigger disk to be able to mirror it.

The issue here is that the message does not give a clue about the real issue.

#3 Updated by William Grzybowski over 1 year ago

  • File deleted (debug-freenas-20180110181330.tgz)

#4 Updated by William Grzybowski over 1 year ago

  • Private changed from Yes to No

#5 Updated by Felix C. Morency over 1 year ago

William Grzybowski wrote:

As far as I understand thats because the disks are of the same size but the current boot disk has been created some time ago and since then we have bumped the size of the EFI partition from 100mb to 260mb.

You will need a bigger disk to be able to mirror it.

The issue here is that the message does not give a clue about the real issue.

William, are you aware of any workaround that would allow me to use my current disk? The information that a bigger disk is needed when trying to mirror a pre-11.1 boot disk under 11.1 might be worth mentioning in the documentation.

I bought the exact same USB key thinking it would work and, based on the current FreeNAS documentation, it should have.

#6 Updated by William Grzybowski over 1 year ago

Felix C. Morency wrote:

William Grzybowski wrote:

As far as I understand thats because the disks are of the same size but the current boot disk has been created some time ago and since then we have bumped the size of the EFI partition from 100mb to 260mb.

You will need a bigger disk to be able to mirror it.

The issue here is that the message does not give a clue about the real issue.

William, are you aware of any workaround that would allow me to use my current disk? The information that a bigger disk is needed when trying to mirror a pre-11.1 boot disk under 11.1 might be worth mentioning in the documentation.

I bought the exact same USB key thinking it would work and, based on the current FreeNAS documentation, it should have.

Right, sorry this has happened to you.

Only way I can think of is if you backup the configuration and install fresh, formatting both disks, uploading configuration back when reinstalled.

#7 Updated by Dru Lavigne over 1 year ago

Notes that the Guide has had a note for some time: http://doc.freenas.org/11/system.html#mirroring-the-boot-device.

#8 Updated by William Grzybowski over 1 year ago

Dru Lavigne wrote:

Notes that the Guide has had a note for some time: http://doc.freenas.org/11/system.html#mirroring-the-boot-device.

Thats a different issue. The device is of the same size. The problem here was caused by us, by increasing the EFI partition size.

#9 Updated by Warren Block over 1 year ago

  • Related to Bug #27860: Display proper error message when mirroring boot device fails due to target device size being too small added

#10 Updated by Dru Lavigne over 1 year ago

  • Status changed from Screened to Not Started

#11 Updated by William Grzybowski over 1 year ago

  • Status changed from Not Started to Closed
  • Target version changed from 11.2-BETA1 to N/A
  • Reason for Closing set to Not Applicable

The related ticket will rightfully provide a meaningful error message.

There isn't much else we can do here AFAIK.

Thank you.

Also available in: Atom PDF