Project

General

Profile

Bug #27760

Samba: suspicious folder besides shares

Added by Siegfried Beeh over 2 years ago. Updated over 2 years ago.

Status:
Closed
Priority:
No priority
Assignee:
Timur Bakeyev
Category:
OS
Target version:
Seen in:
Severity:
New
Reason for Closing:
Behaves as Intended
Reason for Blocked:
Needs QA:
Yes
Needs Doc:
Yes
Needs Merging:
Yes
Needs Automation:
No
Support Suite Ticket:
n/a
Hardware Configuration:
ChangeLog Required:
No

Description

Situation:
  • Update to latest (=current) Version of FreeNAS 11 Stable Train. ZFS hasn't been updated.
  • Network drive (on Windows PC) is connected to SMB service, with currently 3 active shares.
  • All shares have several top-folders.

eg: P:\top-folder1
P:\top-folder2
P:\top-folder3
where P: is connected to a Windows-share that is connected to the ZFS dataset /mnt/Vol1/shared/Eltern.
top-folder1...3 are just plain folders within the ZFS dataset.

Observation:
  • A suspicious folder occurs besides the (valid) top-folders. e.g.
    P:\suspiousfolder
This suspicious folder is named like a (previously) valid folder that has been existing at another location on the file system. It contains valid files/subfolders. But the folder is located at a very wrong place.
  • Action: Moved that folder back to the original location. This was possible, but now another suspicious folder occurred at the same place within the top level
  • Double-check on the command line shows, that the suspicious folder really exists at this location. So it is not only a visualization bug, it seems to be a bug that corrupts existing data.

History

#1 Updated by Siegfried Beeh over 2 years ago

  • File debug-verliernix-20180111174958.txz added
  • Private changed from No to Yes

#2 Updated by Siegfried Beeh over 2 years ago

  • Subject changed from Samba: Suspicios folder besides shares to ZFS/Samba: Suspicios folder move
  • Seen in changed from Unspecified to 11.1

#3 Updated by Dru Lavigne over 2 years ago

  • Subject changed from ZFS/Samba: Suspicios folder move to Samba: suspicious folder besides shares
  • Assignee changed from Release Council to Timur Bakeyev
  • Target version set to 11.1-U2

#4 Updated by Siegfried Beeh over 2 years ago

  • Description updated (diff)

descr updated with the ZFS dataset where the problem has been observed.

#5 Avatar?id=13649&size=24x24 Updated by Ben Gadd over 2 years ago

  • Due date set to 02/02/2018

#6 Updated by Dru Lavigne over 2 years ago

  • Status changed from Unscreened to Not Started

#7 Avatar?id=13649&size=24x24 Updated by Ben Gadd over 2 years ago

  • Due date changed from 02/02/2018 to 02/12/2018

Due date updated to reflect the code freeze for 11.1U2.

#8 Avatar?id=13649&size=24x24 Updated by Ben Gadd over 2 years ago

  • Severity set to New

#9 Updated by Timur Bakeyev over 2 years ago

  • Status changed from Not Started to Closed
  • Target version deleted (11.1-U2)
  • Reason for Closing set to Behaves as Intended

Hi, Siegfried!

I went through your debug log and couldn't find anything unusual. It doesn't help that your SMB service configured with minimal logging, so almost nothing is written to the log.

In general, from your description it sounds like there is a machine or service in your network, that was previously writing that suspicious folder to the disk P:, which was mounting different dataset/folder.

I can recommend you to run zpool scrub Vol1 just in case to make sure that there is no pool corruption.

Also, it could be useful to run smbstatus if you'd see that suspicious folder(s) again, that may reveal which user from which machine creates them.

If you really up to resolve that mystery for yourself - you can enable one of the Samba audit modules and that, eventually, may show you when and how suspicious folder(s) get created. Keep in mind that audit modules may significantly slow down your SMB service.

#10 Updated by Timur Bakeyev over 2 years ago

  • File deleted (debug-verliernix-20180111174958.txz)

#11 Updated by Timur Bakeyev over 2 years ago

  • Private changed from Yes to No

#12 Updated by Dru Lavigne over 2 years ago

  • Target version set to N/A

Also available in: Atom PDF