Project

General

Profile

Bug #27769

CPU usage graph uses wrong data

Added by Landon Abney over 2 years ago. Updated over 1 year ago.

Status:
Closed
Priority:
Expected
Assignee:
Damian Szidiropulosz
Category:
GUI (new)
Target version:
Seen in:
Severity:
High
Reason for Closing:
Duplicate Issue
Reason for Blocked:
Needs QA:
Yes
Needs Doc:
Yes
Needs Merging:
Yes
Needs Automation:
No
Support Suite Ticket:
n/a
Hardware Configuration:
ChangeLog Required:
No

Description

My system is using an Intel i3-4130T CPU, as such it has 2 cores / 4 threads available to it.

The "CPU Usage" graph is showing numbers that make no sense under any scenario that I can come up with.

At the start of this the "Idle" value has an average value of 484. This obviously isn't on a scale of 100% being the maximum... but I can't determine what scale it is using, since if it was using the "each core = 100%" the maximum would still be 400.

The RRD generated graphs in the old UI at least have sensible numbers, even if it doesn't show you the same precision since it's zoomed out to an hour:

cpu_usage_reporting.png (84.6 KB) cpu_usage_reporting.png Landon Abney, 01/11/2018 01:47 PM
oldui_CPU_usage.png (18.4 KB) oldui_CPU_usage.png Landon Abney, 01/11/2018 01:52 PM
13877
13878

Related issues

Related to FreeNAS - Bug #59694: Fix %CPU in reporting section in new UIClosed
Has duplicate FreeNAS - Bug #53413: CPU Usage shows incorrect percentageClosed
Is duplicate of FreeNAS - Bug #57768: UI Reporting CPU tab reports 4000% idleClosed

History

#1 Updated by Dru Lavigne over 2 years ago

  • Assignee changed from Release Council to Erin Clark
  • Target version set to 11.2-BETA1

#2 Updated by Erin Clark over 2 years ago

  • Assignee changed from Erin Clark to Damian Szidiropulosz
  • Priority changed from No priority to Expected

#3 Updated by Damian Szidiropulosz over 2 years ago

  • Status changed from Unscreened to Screened

#4 Updated by Dru Lavigne over 2 years ago

  • Status changed from Screened to Not Started

#5 Updated by Damian Szidiropulosz over 2 years ago

  • Status changed from Not Started to In Progress

#6 Avatar?id=13649&size=24x24 Updated by Ben Gadd over 2 years ago

  • Due date set to 03/09/2018

#7 Updated by Damian Szidiropulosz over 2 years ago

  • Status changed from In Progress to Not Started
  • Target version changed from 11.2-BETA1 to 11.3

I've put this back to 11.3 since the entire reports section needs an overhaul. There are reports in there that for design as well as performance reasons need to be rethought. For example some of them don't need to be line graphs at all. Some like disk iops might be better as a summary instead of per disk stat since users with large configurations will not find that useful at all. This ticket was in progress because the work for the new charts was already done with the dashboard overhaul. That dashboard charts work has been completed so there has been some progress made to this end.

#8 Avatar?id=13649&size=24x24 Updated by Ben Gadd over 2 years ago

  • Target version changed from 11.3 to Backlog

#9 Updated by Damian Szidiropulosz over 2 years ago

  • Status changed from Not Started to Screened
  • Severity set to High

#10 Avatar?id=13649&size=24x24 Updated by Ben Gadd over 2 years ago

  • Target version changed from Backlog to 11.2-U2

When doing planning in the next sprint, a design dock will be needed before work goes into progress.

#12 Updated by Dru Lavigne almost 2 years ago

  • Has duplicate Bug #53413: CPU Usage shows incorrect percentage added

#13 Updated by Disk Didler almost 2 years ago

Based on the two example images in this thread, I feel my new job log / incident may have some relevance here.

https://redmine.ixsystems.com/issues/56745

Certainly feels more consistent and less 'wishy washy' in the old UI. No offense intended, I'm sure it's exceedingly difficult to write decent graphing tools, infact, if I recall, the ones in FreeNAS are using some kind of long term well known graphics generation tool (I don't know the name?)

None the less 'wishy washy' graphs, across the board, are unlikely to impress the hardcore sysadmin types who use FreeNAS, they may frustrate paying TrueNAS customers too.

#14 Updated by Dru Lavigne almost 2 years ago

  • Related to Bug #59694: Fix %CPU in reporting section in new UI added

#15 Updated by Dru Lavigne over 1 year ago

  • Target version changed from 11.2-U2 to 11.2-U3

#16 Updated by Damian Szidiropulosz over 1 year ago

  • Status changed from Screened to Closed
  • Reason for Closing set to Duplicate Issue

This is the same as ticket 57768.

https://redmine.ixsystems.com/issues/57768

#17 Updated by Dru Lavigne over 1 year ago

  • Is duplicate of Bug #57768: UI Reporting CPU tab reports 4000% idle added

#18 Updated by Dru Lavigne over 1 year ago

  • Target version changed from 11.2-U3 to N/A

#19 Updated by Dru Lavigne over 1 year ago

Landon: please refer to the workaround in https://redmine.ixsystems.com/issues/57768#note-16.

Also available in: Atom PDF