Project

General

Profile

Bug #27772

update.update sometimes gives me the error message "Fake Middleware object has no attribute call_sync"

Added by Erin Clark almost 2 years ago. Updated almost 2 years ago.

Status:
Closed: Duplicate
Priority:
No priority
Assignee:
William Grzybowski
Category:
Middleware
Target version:
Severity:
New
Reason for Closing:
Reason for Blocked:
Needs QA:
Yes
Needs Doc:
Yes
Needs Merging:
Yes
Needs Automation:
No
Support Suite Ticket:
n/a
Hardware Configuration:
ChangeLog Required:
No

Description

I'm not quite sure what this error means but I see it sometimes when I try to update but then if I try again the update will sometimes succeed. It is kind of hit or miss as to whether it will happen so I understand if you have a hard time reproducing it but I will gladly help in whatever way to figure this out. I attached a debug immediately after this error happened so maybe that will help you figure out why it is doing this. Let me know how I can help.

screenshot-20180111-144616.jpg (4.55 KB) screenshot-20180111-144616.jpg Erin Clark, 01/11/2018 02:52 PM
13881

Related issues

Is duplicate of FreeNAS - Bug #27739: Fix "coroutine object has no attribute result" errorDone2018-01-09

History

#1 Updated by William Grzybowski almost 2 years ago

  • Status changed from Unscreened to Closed: Duplicate

That error happens when no "train" attribute is passed.

This will be fixed in the other ticket already reported regarding update.update

#2 Updated by William Grzybowski almost 2 years ago

  • Is duplicate of Bug #27739: Fix "coroutine object has no attribute result" error added

#3 Updated by Dru Lavigne almost 2 years ago

  • File deleted (debug-freenas-20180111144639.tgz)

#4 Updated by Dru Lavigne almost 2 years ago

  • Target version changed from 11.2-BETA1 to N/A
  • Private changed from Yes to No

Also available in: Atom PDF