Project

General

Profile

Bug #27791

Problem installing packets

Added by Aljosa Ravnikar over 2 years ago. Updated over 2 years ago.

Status:
Closed: User Config Issue
Priority:
No priority
Assignee:
Release Council
Category:
Middleware
Target version:
Seen in:
Severity:
New
Reason for Closing:
Reason for Blocked:
Needs QA:
Yes
Needs Doc:
Yes
Needs Merging:
Yes
Needs Automation:
No
Support Suite Ticket:
n/a
Hardware Configuration:
ChangeLog Required:
No

Description

Hi,

When I try to install any program from ports, I am getting error

fetch: http://ftpmirror.gnu.org/texinfo/texinfo.tex: size mismatch: expected 380556, actual 382193

How can I fix this problem, I was try to update ports, but also getting error

root@unbound:/usr/ports/dns/unbound # pkg update -f
Updating FreeBSD repository catalogue...
[unbound] Fetching meta.txz: 100% 944 B 0.9kB/s 00:01
[unbound] Fetching packagesite.txz: 100% 1 MiB 16.6kB/s 01:10
pkg: http://pkg.FreeBSD.org/freebsd:11:x86:6... Operation timed out
Unable to update repository FreeBSD
Error updating repositories!

Internet connection works fine, I can ping google.

Thank you.

BR Aljosa

History

#1 Updated by Sean Fagan over 2 years ago

You don't install packages into FreeNAS. It's a different story if you're trying that from inside a jail or a VM, but you provided insufficient information to determine that.

#2 Updated by Aljosa Ravnikar over 2 years ago

Sean Fagan wrote:

You don't install packages into FreeNAS. It's a different story if you're trying that from inside a jail or a VM, but you provided insufficient information to determine that.

Hi,

Sorry for insufficient message. Yes I try to install messages in Jail. If I skip some important information please excuse me, I am greenhorn in BSD world.

root@unbound:/usr/ports/dns/unbound # make clean install
===>  Cleaning for autoconf-2.69_1
===>  Cleaning for m4-1.4.18,1
===>  Cleaning for unbound-1.6.2
===>  License BSD3CLAUSE accepted by the user
===>   unbound-1.6.2 depends on file: /usr/local/sbin/pkg - found
===> Fetching all distfiles required by unbound-1.6.2 for building
===>  Extracting for unbound-1.6.2
=> SHA256 Checksum OK for unbound-1.6.2.tar.gz.
===>  Patching for unbound-1.6.2
===>   unbound-1.6.2 depends on executable: autoconf-2.69 - not found
===>   autoconf-2.69_1 depends on file: /usr/local/sbin/pkg - found
===> Fetching all distfiles required by autoconf-2.69_1 for building
===>  Extracting for autoconf-2.69_1
=> SHA256 Checksum OK for autoconf-2.69.tar.xz.
===>  Patching for autoconf-2.69_1
===>  Applying FreeBSD patches for autoconf-2.69_1
===>   autoconf-2.69_1 depends on executable: gm4 - not found
===>  License GPLv3 accepted by the user
===>   m4-1.4.18,1 depends on file: /usr/local/sbin/pkg - found
===> Fetching all distfiles required by m4-1.4.18,1 for building
===>  Extracting for m4-1.4.18,1
=> SHA256 Checksum OK for m4-1.4.18.tar.xz.
===>  Patching for m4-1.4.18,1
===>  Applying FreeBSD patches for m4-1.4.18,1
===>   m4-1.4.18,1 depends on executable: makeinfo - not found
===>  License GPLv3+ accepted by the user
===>   texinfo-6.3_1,1 depends on file: /usr/local/sbin/pkg - found
=> texinfo.tex doesn't seem to exist in /usr/ports/distfiles/texinfo/6.3.
=> Attempting to fetch http://ftpmirror.gnu.org/texinfo/texinfo.tex
fetch: http://ftpmirror.gnu.org/texinfo/texinfo.tex: size mismatch: expected 380556, actual 382193
=> Attempting to fetch http://ftp.gnu.org/gnu/texinfo/texinfo.tex
fetch: http://ftp.gnu.org/gnu/texinfo/texinfo.tex: size mismatch: expected 380556, actual 382193
=> Attempting to fetch ftp://ftp.gnu.org/gnu/texinfo/texinfo.tex
fetch: ftp://ftp.gnu.org/gnu/texinfo/texinfo.tex: size mismatch: expected 380556, actual 382193
=> Attempting to fetch http://www.gtlib.gatech.edu/pub/gnu/gnu/texinfo/texinfo.tex
fetch: http://www.gtlib.gatech.edu/pub/gnu/gnu/texinfo/texinfo.tex: size mismatch: expected 380556, actual 381336
=> Attempting to fetch http://mirrors.kernel.org/gnu/texinfo/texinfo.tex
fetch: http://mirrors.kernel.org/gnu/texinfo/texinfo.tex: size mismatch: expected 380556, actual 382193
=> Attempting to fetch ftp://ftp.kddlabs.co.jp/GNU/gnu/texinfo/texinfo.tex
fetch: ftp://ftp.kddlabs.co.jp/GNU/gnu/texinfo/texinfo.tex: size mismatch: expected 380556, actual 382193
=> Attempting to fetch ftp://ftp.dti.ad.jp/pub/GNU/texinfo/texinfo.tex
fetch: ftp://ftp.dti.ad.jp/pub/GNU/texinfo/texinfo.tex: Protocol error
=> Attempting to fetch ftp://ftp.mirrorservice.org/sites/ftp.gnu.org/gnu/texinfo/texinfo.tex
fetch: ftp://ftp.mirrorservice.org/sites/ftp.gnu.org/gnu/texinfo/texinfo.tex: size mismatch: expected 380556, actual 382193
=> Attempting to fetch ftp://ftp.informatik.hu-berlin.de/pub/gnu/gnu/texinfo/texinfo.tex
fetch: ftp://ftp.informatik.hu-berlin.de/pub/gnu/gnu/texinfo/texinfo.tex: size mismatch: expected 380556, actual 382193
=> Attempting to fetch ftp://ftp.informatik.rwth-aachen.de/pub/mirror/ftp.gnu.org/pub/gnu/texinfo/texinfo.tex
fetch: ftp://ftp.informatik.rwth-aachen.de/pub/mirror/ftp.gnu.org/pub/gnu/texinfo/texinfo.tex: size mismatch: expected 380556, actual 382193
=> Attempting to fetch http://ftp.funet.fi/pub/gnu/prep/texinfo/texinfo.tex
fetch: http://ftp.funet.fi/pub/gnu/prep/texinfo/texinfo.tex: size mismatch: expected 380556, actual 382193
=> Attempting to fetch http://distcache.FreeBSD.org/local-distfiles/sunpoet/texinfo/6.3/texinfo.tex
fetch: http://distcache.FreeBSD.org/local-distfiles/sunpoet/texinfo/6.3/texinfo.tex: size mismatch: expected 380556, actual 380853
=> Attempting to fetch http://distcache.us-east.FreeBSD.org/local-distfiles/sunpoet/texinfo/6.3/texinfo.tex
fetch: http://distcache.us-east.FreeBSD.org/local-distfiles/sunpoet/texinfo/6.3/texinfo.tex: size mismatch: expected 380556, actual 380853
=> Attempting to fetch http://distcache.eu.FreeBSD.org/local-distfiles/sunpoet/texinfo/6.3/texinfo.tex
fetch: http://distcache.eu.FreeBSD.org/local-distfiles/sunpoet/texinfo/6.3/texinfo.tex: size mismatch: expected 380556, actual 380853
=> Attempting to fetch http://distcache.us-west.FreeBSD.org/local-distfiles/sunpoet/texinfo/6.3/texinfo.tex
fetch: http://distcache.us-west.FreeBSD.org/local-distfiles/sunpoet/texinfo/6.3/texinfo.tex: size mismatch: expected 380556, actual 380853
=> Attempting to fetch http://distcache.FreeBSD.org/ports-distfiles/texinfo/6.3/texinfo.tex
fetch: http://distcache.FreeBSD.org/ports-distfiles/texinfo/6.3/texinfo.tex: size mismatch: expected 380556, actual 380853
=> Couldn't fetch it - please try to retrieve this
=> port manually into /usr/ports/distfiles/texinfo/6.3 and try again.
*** Error code 1

Stop.
make[6]: stopped in /usr/ports/print/texinfo
*** Error code 1

Stop.
make[5]: stopped in /usr/ports/print/texinfo
*** Error code 1

Stop.
make[4]: stopped in /usr/ports/devel/m4
*** Error code 1

Stop.
make[3]: stopped in /usr/ports/devel/m4
*** Error code 1

Stop.
make[2]: stopped in /usr/ports/devel/autoconf
*** Error code 1

Stop.
make[1]: stopped in /usr/ports/dns/unbound
*** Error code 1

Stop.
make: stopped in /usr/ports/dns/unbound
root@unbound:/usr/ports/dns/unbound # 

#3 Updated by Dru Lavigne over 2 years ago

  • Status changed from Unscreened to Closed: User Config Issue
  • Target version set to N/A

Aljosa: this is not a bug. If you need assistance installing software in a jail, create a post at forums.freenas.org.

#4 Updated by Aljosa Ravnikar over 2 years ago

Dru Lavigne wrote:

Aljosa: this is not a bug. If you need assistance installing software in a jail, create a post at forums.freenas.org.

Thank you,

I did that, here is a link. Hope some one will give me right solution.

https://forums.freenas.org/index.php?threads/ports-downloading-problem.60616/

BR Aljosa

Also available in: Atom PDF