Project

General

Profile

Bug #27804

11.1-RELEASE failed to work with aac

Added by Tom Mü-Ko over 2 years ago. Updated over 2 years ago.

Status:
Closed: Duplicate
Priority:
No priority
Assignee:
Alexander Motin
Category:
OS
Target version:
Seen in:
Severity:
New
Reason for Closing:
Reason for Blocked:
Needs QA:
Yes
Needs Doc:
Yes
Needs Merging:
Yes
Needs Automation:
No
Support Suite Ticket:
n/a
Hardware Configuration:
ChangeLog Required:
No

Description

An older Adaptec 5805. 11.0-U4 is running fine:

root@baal5:~ # zpool status -v daten
  pool: daten
 state: ONLINE
  scan: scrub repaired 0 in 114h42m with 0 errors on Thu Dec 21 18:45:16 2017
config:

    NAME                                            STATE     READ WRITE CKSUM
    daten                                           ONLINE       0     0     0
      raidz1-0                                      ONLINE       0     0     0
        gptid/6f6ac255-cc92-11e4-aa84-003048f17736  ONLINE       0     0     0
        gptid/74459c18-cc91-11e4-aa84-003048f17736  ONLINE       0     0     0
        gptid/8d76db21-cc8f-11e4-aa84-003048f17736  ONLINE       0     0     0
        gptid/6ac29ee3-cc8d-11e4-aa84-003048f17736  ONLINE       0     0     0
      raidz1-1                                      ONLINE       0     0     0
        gptid/3ca061d2-467a-11e5-9e1f-003048f17736  ONLINE       0     0     0
        gptid/3ce42288-467a-11e5-9e1f-003048f17736  ONLINE       0     0     0
        gptid/3d1e7c8b-467a-11e5-9e1f-003048f17736  ONLINE       0     0     0
        gptid/3d5950c2-467a-11e5-9e1f-003048f17736  ONLINE       0     0     0

errors: No known data errors

root@baal5:~ # dmesg | grep aac
aac0: <Adaptec RAID 5805> mem 0xfbc00000-0xfbdfffff irq 24 at device 0.0 on pci2
aac0: Enabling 64-bit address support
aac0: Enable Raw I/O
aac0: Enable 64-bit array
aac0: New comm. interface enabled
aac0: Adaptec 5805, aac driver 2.1.9-1
aacp0 on aac0
aacp1 on aac0
aacp2 on aac0
aacd0 on aac0
aacd0: 3814389MB (7811868672 sectors)
aacd1 on aac0
aacd1: 3814389MB (7811868672 sectors)
aacd2 on aac0
aacd2: 3814389MB (7811868672 sectors)
aacd3 on aac0
aacd3: 3814389MB (7811868672 sectors)
aacd4 on aac0
aacd4: 3814389MB (7811868672 sectors)
aacd5 on aac0
aacd5: 3814389MB (7811868672 sectors)
aacd6 on aac0
aacd6: 3814389MB (7811868672 sectors)
aacd7 on aac0
aacd7: 3814389MB (7811868672 sectors)
pass0 at aacp0 bus 0 scbus0 target 0 lun 0
pass1 at aacp0 bus 0 scbus0 target 1 lun 0
pass2 at aacp0 bus 0 scbus0 target 2 lun 0
pass3 at aacp0 bus 0 scbus0 target 3 lun 0
pass4 at aacp0 bus 0 scbus0 target 4 lun 0
pass5 at aacp0 bus 0 scbus0 target 5 lun 0
pass6 at aacp0 bus 0 scbus0 target 6 lun 0
pass7 at aacp0 bus 0 scbus0 target 7 lun 0

First boot with 11.1 my heart stand still:

root@baal5:~ # zpool import
   pool: daten
     id: 1259816592746605001
  state: UNAVAIL
 status: One or more devices are missing from the system.
 action: The pool cannot be imported. Attach the missing
    devices and try again.
   see: http://illumos.org/msg/ZFS-8000-3C
 config:

    daten                                           UNAVAIL  insufficient replicas
      raidz1-1                                      UNAVAIL  insufficient replicas
        gptid/3ca061d2-467a-11e5-9e1f-003048f17736  ONLINE
        gptid/3ce42288-467a-11e5-9e1f-003048f17736  ONLINE
        10394004986298153169                        UNAVAIL  cannot open
        12709636963316013390                        UNAVAIL  cannot open

aac0: <Adaptec RAID 5805> mem 0xfbc00000-0xfbdfffff irq 24 at device 0.0 on pci2
aac0: Enabling 64-bit address support
aac0: Enable Raw I/O
aac0: Enable 64-bit array
aac0: New comm. interface enabled
aac0: Adaptec 5805, aac driver 2.1.9-1
aacp0 on aac0
aacp1 on aac0
aacp2 on aac0
aacd0 on aac0
aacd0: 3814389MB (7811868672 sectors)
aac0: aacd1Controller Suspended controller state = 0x1
 on aac0
aacd1: 3814389MB (7811868672 sectors)
aacd2aac0: Controller Suspended controller state = 0x1
aac0: Controller Suspended controller state = 0x1
 on aac0
aac0: aacd2: 3814389MB (7811868672 sectors)
aacd3aac0: Controller Suspended controller state = 0x1
aac0: Controller Suspended controller state = 0x1
aac0:  on aac0
aacd3: 3814389MB (7811868672 sectors)
aacd4aac0: Controller Suspended controller state = 0x1
aac0: Controller Suspended controller state = 0x1
aac0: Controller Suspended controller state = 0x1
aac0: Controller Suspended controller state = 0x1
aac0: Controller Suspended controller state = 0x1
aac0: Controller Suspended controller state = 0x1
aac0: Controller Suspended controller state = 0x1
aac0: Controller Suspended controller state = 0x1
aac0: Controller Suspended controller state = 0x1
aac0: Controller Suspended controller state = 0x1
aac0: Controller Suspended controller state = 0x1
aac0: Controller Suspended controller state = 0x1
aac0: Controller Suspended controller state = 0x1
aac0: Controller Suspended controller state = 0x1
aac0: Controller Suspended controller state = 0x1
aac0:  on aac0
aacd4: 3814389MB (7811868672 sectors)
aacd5aac0: Controller Suspended controller state = 0x1
aac0: Controller Suspended controller state = 0x1
aac0: Controller Suspended controller state = 0x1
aac0: Controller Suspended controller state = 0x1
aac0: Controller Suspended controller state = 0x1
aac0: Controller Suspended controller state = 0x1
aac0: Controller Suspended controller state = 0x1
 on aac0
aacd5: 3814389MB (7811868672 sectors)
aac0: ugen2.1: <Intel UHCI root HUB> at usbus2
aacd6 on aac0
aacd6: 3814389MB (7811868672 sectors)
aacd7aac0: Controller Suspended controller state = 0x1
aac0: Controller Suspended controller state = 0x1
aac0: Controller Suspended controller state = 0x1
aac0: Controller Suspended controller state = 0x1
aac0:  on aac0
aacd7: 3814389MB (7811868672 sectors)
root@baal5:~ # arcconf getconfig 1
Shared object "libstdc++.so.6" not found, required by "arcconf" 
IMG_0952.JPG (2.47 MB) IMG_0952.JPG Tom Mü-Ko, 01/19/2018 04:50 AM
IMG_0954.JPG (2.13 MB) IMG_0954.JPG Tom Mü-Ko, 01/19/2018 07:07 AM
13984
13987

Related issues

Is duplicate of FreeNAS - Bug #27674: Fix race condition in aac(4) driver Done2018-01-072018-02-12

History

#1 Updated by Dru Lavigne over 2 years ago

  • Status changed from Unscreened to 15
  • Assignee changed from Release Council to Alexander Motin
  • Target version set to 11.1-U2
  • Private changed from No to Yes

Tom: please attach a debug created from the 11.1 boot environment (System -> Advanced -> Save Debug).

#2 Updated by Alexander Motin over 2 years ago

I can confirm part about arcconf tool. It seems the port is missing FreeBSD 9 compat library dependency. I've written email to the port maintainer.

#3 Updated by Alexander Motin over 2 years ago

Generally I'd recommend to report this problem to FreeBSD. I may try that if I find the hardware (not sure I have one), while otherwise we do not officially support hardware RAID controllers.

#4 Avatar?id=13649&size=24x24 Updated by Ben Gadd over 2 years ago

  • Due date set to 02/02/2018

#5 Updated by Tom Mü-Ko over 2 years ago

I' try to boot 11.1 again and get this Debug-Report.
I'll also try to start 11.1 memstick an see if i can import zpool.
but arcconf is not part of FreeBSD:

root@baal5:~ # arcconf getconfig 1
Shared object "libstdc++.so.6" not found, required by "arcconf" 

#6 Updated by Alexander Motin over 2 years ago

Tom Mü-Ko wrote:

but arcconf is not part of FreeBSD:

It is a port there, and the port is broken now.

#7 Updated by Alexander Motin over 2 years ago

  • Is duplicate of Bug #27674: Fix race condition in aac(4) driver added

#8 Updated by Tom Mü-Ko over 2 years ago

13984

OK,
when i select "verbose mode" in grub, i get a panic:


in normal mode, server starts up but GUI is not funktional.
I created debug using "The following output was generated with: '/usr/local/bin/freenas-debug -A -e ..."
attachment:fndebug.tgz

#9 Updated by Dru Lavigne over 2 years ago

  • Status changed from 15 to Investigation

#10 Updated by Tom Mü-Ko over 2 years ago

13987

I just booted a freebsd-live stick (FreeBSD-11.1-RELEASE-amd64-memstick.img SHA256:d4c58df629c7db6bf2ee2d43ae7f7b9e1c8b98fca0b89dd1afa1bed21891ecc2)

I works without a problem:

#11 Updated by Alexander Motin over 2 years ago

  • Status changed from Investigation to Closed: Duplicate
  • Target version changed from 11.1-U2 to N/A

I think I understood the problem, and I think I found solution for it in FreeBSD head, which for some reason was not merged to stable/11. I am merging that patch now, and it should be available in nightly builds nearest time, and 11.1-U2 update, when it come out.

#12 Updated by Dru Lavigne over 2 years ago

  • File deleted (fndebug.tgz)

#13 Updated by Dru Lavigne over 2 years ago

  • Private changed from Yes to No

Also available in: Atom PDF