Project

General

Profile

Bug #27853

UPS servce fails when upgrading to 11

Added by Shawn Cox over 2 years ago. Updated over 2 years ago.

Status:
Closed
Priority:
Nice to have
Assignee:
Vladimir Vinogradenko
Category:
Middleware
Target version:
Seen in:
TrueNAS - 11.0-U6
Severity:
New
Reason for Closing:
Reason for Blocked:
Need additional information
Needs QA:
Yes
Needs Doc:
Yes
Needs Merging:
Yes
Needs Automation:
No
Support Suite Ticket:
n/a
Hardware Configuration:
ChangeLog Required:
No

Related projects 1 project

Description

The stored password goes away when upgrading from 9.10 to 11.

The password is also not starred.

Associated revisions

Revision 28f312e1 (diff)
Added by Vladimir Vinogradenko over 2 years ago

fix(gui): Hide UPS monitor password Ticket: #27853

Revision 07622a99 (diff)
Added by Vladimir Vinogradenko over 2 years ago

fix(gui): Hide UPS monitor password Ticket: #27853

Revision 256a175a (diff)
Added by Vladimir Vinogradenko over 2 years ago

fix(gui): Hide UPS monitor password Ticket: #27853

History

#1 Updated by Dru Lavigne over 2 years ago

  • Status changed from Untriaged to 15

Shawn: I'm not seeing anything in that support ticket related to a UPS issue.

Also, what do you mean by "the password is not starred"? Is it appearing in clear text when they type it in the UI?

#3 Updated by Dru Lavigne over 2 years ago

  • 1 added project (FreeNAS)
  • Status changed from 15 to Unscreened
  • Target version set to 11.1-U2
  • Private changed from No to Yes

Vlad: let us know if you are unable to access the debugs in the support suite ticket.

#4 Updated by Dru Lavigne over 2 years ago

  • Assignee changed from Release Council to Vladimir Vinogradenko

#5 Updated by Dru Lavigne over 2 years ago

  • Status changed from Unscreened to Not Started

#6 Avatar?id=13649&size=24x24 Updated by Ben Gadd over 2 years ago

  • Due date set to 02/12/2018

Due date updated to reflect the code freeze for 11.1U2.

#7 Avatar?id=13649&size=24x24 Updated by Ben Gadd over 2 years ago

  • Severity set to New

#9 Updated by Vladimir Vinogradenko over 2 years ago

  • Status changed from Broken to Blocked

#10 Updated by Dru Lavigne over 2 years ago

  • Status changed from Blocked to In Progress

Vlad: let us know if your newly created creds do not work.

#11 Updated by Vladimir Vinogradenko over 2 years ago

  • Status changed from In Progress to Blocked

I was not able to repeat gone password. Upgraded from 9.10 to 11-U1.

No debug log in the ticket contains these lines:

Jan 16 14:16:35 tn2 root: /usr/local/etc/rc.d/nut: WARNING: failed precmd routine for nut
Jan 16 14:16:35 tn2 root: /usr/local/etc/rc.d/nut_upsmon: WARNING: failed to start nut_upsmon

In fact, no logs there contain any UPS failures. So we have to ask them to pull logs again.

#12 Updated by Dru Lavigne over 2 years ago

Shawn: can you please get another debug from the affected system and attach it to this ticket?

#13 Avatar?id=14398&size=24x24 Updated by Kris Moore over 2 years ago

  • Priority changed from No priority to Nice to have
  • Target version changed from 11.1-U2 to 11.2-BETA1

#14 Avatar?id=13649&size=24x24 Updated by Ben Gadd over 2 years ago

  • Due date changed from 02/12/2018 to 03/09/2018

#15 Updated by William Grzybowski over 2 years ago

  • Category changed from OS to Middleware
  • Target version changed from 11.2-BETA1 to 11.3

We cannot reproduce this, also moving to 11.3.

Also as asked, we are waiting for new logs.

#16 Updated by Dru Lavigne over 2 years ago

  • 1 deleted project (FreeNAS)
  • Project changed from TrueNAS to FreeNAS
  • Category changed from Middleware to Middleware
  • Support Suite Ticket deleted (https://support.ixsystems.com/staff/index.php?/Tickets/Ticket/View/35494)
  • Migration Needed deleted (No)
  • Hide from ChangeLog deleted (No)
  • Support Department Priority deleted (0)

#17 Updated by Dru Lavigne over 2 years ago

  • Status changed from Blocked to Closed
  • Target version changed from 11.3 to N/A
  • Private changed from Yes to No
  • Reason for Blocked changed from Waiting for feedback to Need additional information

Also available in: Atom PDF