Project

General

Profile

Bug #27857

Issue when trying to copy snapshot data through "previous versions"

Added by Lewis Barclay over 2 years ago. Updated about 2 years ago.

Status:
Closed
Priority:
No priority
Assignee:
Timur Bakeyev
Category:
OS
Target version:
Seen in:
Severity:
Medium
Reason for Closing:
Cannot Reproduce
Reason for Blocked:
Needs QA:
No
Needs Doc:
No
Needs Merging:
No
Needs Automation:
No
Support Suite Ticket:
n/a
Hardware Configuration:

Intel(R) Xeon(R) CPU E3-1225 v3 @ 3.20GHz
16GB of Kingston ECC Memory
4 x 4TB WD Red

ChangeLog Required:
No

Description

We are having an issue that has appeared since updating from 11.0 U3 to 11.1. I am unsure whether this is a FreeNAS issue or if its an issue on the Windows side, cause you know, Windows.

The situation is this:
Go into the FreeNAS SMB share using windows explorer, right click, properties and choose previous version. Open the time period I am looking for.
Once there, I select the file, then copy and paste it to a location on the Windows Server.
Error message appears saying "You need permission from "Some user" in order to modify this file". I am that user it is asking for.
I notice the attached error in the log file at /var/log/samba4/log.smbd
This is on a Server 2008 R2 that we get the errors mentioned in step 3 and 4.

However there are two work arounds:
It works using a copy command through the Windows command prompt and copying the URL from explorer, on the same server.
It works from Server 2012 R2 or Windows 10.
The fact that it works on Server 2012 is odd, but so is the fact it works through the command prompt and not explorer. I was definitely leaning towards it being a Windows issue along the lines of SMB version (SMB1.0) because I noticed that in 11.1 update that the "minimum/maximum protocol level" drop downs were removed. However I tried setting "server min protocol = SMB2.0" in the share's auxiliary parameters box but this didn't make a difference. Also seeing errors in the Samba log file also make me question which side it is.

I hope that makes sense, any questions please let me know!

Thanks in advance!

SMB Bug windows message.PNG (10.9 KB) SMB Bug windows message.PNG Error in Windows when attempting copy paste. Lewis Barclay, 01/18/2018 05:08 AM
SMB Bug freenas message.PNG (18.9 KB) SMB Bug freenas message.PNG Error log at /var/log/samba4/smbd.log Lewis Barclay, 01/18/2018 05:08 AM
13958
13959

Related issues

Related to FreeNAS - Bug #25949: Fix Samba bug that prevented restoration of previous versions of files containing an alternate data streamReady for Testing
Related to FreeNAS - Umbrella #28426: shadow_copy2 doesn't cooperate well with other VFS modulesClosed
Related to FreeNAS - Bug #30768: Fix argument for SMB_VFS_NEXT_DISK_FREE in zfs_space VFS moduleDone

History

#1 Updated by Dru Lavigne over 2 years ago

  • Status changed from Unscreened to 15
  • Private changed from No to Yes

Lewis: please attach a debug (System -> Advanced -> Save Debug).

#2 Updated by Lewis Barclay over 2 years ago

  • File debug-freenasedb-20180118134959.tgz added

Hi Dru, Please find the attached! Thanks!

#3 Updated by Dru Lavigne over 2 years ago

  • Status changed from 15 to Unscreened
  • Assignee changed from Release Council to Timur Bakeyev
  • Target version set to 11.1-U2

Timur: what are your thoughts on this one?

#4 Updated by Lewis Barclay over 2 years ago

Hi there,

As per a suggestion on the forum post from Anodos (who I see is an iXSystems member of staff), I tried his suggestion:

"Try removing the zfs_space vfs object from the [edinburgh_data_jcca_docs] share."

Which does the trick. I have re-enabled it for now as I have no idea what it does (although just going to try and research it now!) but hopefully this might help narrow down the issue?

I assume something changed with this part of it in the last update?

Hope that helps.

#5 Updated by Lewis Barclay over 2 years ago

  • File debug-freenasedb-20180123105856.tgz added

Hi there, attaching new debug after setting SMB log level to debug at the request of Anodos. Thanks again for all your help.

#6 Updated by Timur Bakeyev over 2 years ago

  • Status changed from Unscreened to Not Started

Hi, Lewis!

The zfs_space module is reporting available free space on the ZFS share. We/you need this module cause calculating free space on ZFS isn't trivial. But, obviously you can live without it for a while.

I'll look into the possible code paths that may cause this issue with Anodos.

#7 Updated by Lewis Barclay over 2 years ago

Hi Timur!

Many thanks for the explanation, good to here I can safely deselect the module temporarily for the time being.

Any other testing or information you need me to do please let me know!

Thanks!

#8 Updated by Timur Bakeyev over 2 years ago

  • Related to Bug #27775: Unauthorized system reboot added

#9 Updated by Timur Bakeyev over 2 years ago

  • Related to deleted (Bug #27775: Unauthorized system reboot)

#10 Avatar?id=13649&size=24x24 Updated by Ben Gadd over 2 years ago

  • Due date set to 02/12/2018

Due date updated to reflect the code freeze for 11.1U2.

#11 Avatar?id=13649&size=24x24 Updated by Ben Gadd over 2 years ago

  • Severity set to New

#12 Updated by Timur Bakeyev over 2 years ago

  • Related to Bug #25949: Fix Samba bug that prevented restoration of previous versions of files containing an alternate data stream added

#13 Updated by Timur Bakeyev over 2 years ago

  • Related to Umbrella #28426: shadow_copy2 doesn't cooperate well with other VFS modules added

#14 Updated by Timur Bakeyev over 2 years ago

  • Target version changed from 11.1-U2 to 11.2-RC2

#15 Updated by Timur Bakeyev over 2 years ago

  • Status changed from Not Started to In Progress

#16 Updated by Timur Bakeyev over 2 years ago

  • Severity changed from New to Medium

#17 Updated by Timur Bakeyev about 2 years ago

  • Status changed from In Progress to Closed
  • Target version changed from 11.2-RC2 to N/A
  • Reason for Closing set to Cannot Reproduce
  • Needs QA changed from Yes to No
  • Needs Doc changed from Yes to No
  • Needs Merging changed from Yes to No

Hi, Lewis!

I was trying to reproduce this error, but seems it was fixed meanwhile. I think it's safe as of 11.2(b1) or 11.1-U5 to enable back zfs_space while accessing snapshots.

Keep in mind though, that there is still another open bug, which is triggered when you trying to restore files with ADS from the shadow copy. You can see reference to it in the ticket summary.

If you'd encounter that cannot open '': snapshot delimiter '@' is not expected here again with the latest FreeNAS - please, reopen this ticket.

#18 Updated by Timur Bakeyev about 2 years ago

  • Related to Bug #30768: Fix argument for SMB_VFS_NEXT_DISK_FREE in zfs_space VFS module added

#19 Updated by Timur Bakeyev about 2 years ago

  • File deleted (debug-freenasedb-20180118134959.tgz)

#20 Updated by Timur Bakeyev about 2 years ago

  • File deleted (debug-freenasedb-20180123105856.tgz)

#21 Updated by Dru Lavigne about 2 years ago

  • Private changed from Yes to No

#22 Updated by Lewis Barclay about 2 years ago

Hi there,

Thanks for your response, fingers crossed this issue is resolved. I have another issue now with one particular share not showing previous versions despite everything being set correctly and snapshots do exist (I can clone them manually). Should I open a new ticket?

Lewis

#23 Updated by Lewis Barclay about 2 years ago

I created a new ticket of #37550 since its technically a different issue.

Thanks again.

Also available in: Atom PDF